summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-09-29 09:15:43 +0000
committerRoy Marples <uberlord@gentoo.org>2006-09-29 09:15:43 +0000
commitb902640042c96263c9aa401cbc5c30ea6c0a9c84 (patch)
treefe46c72edefde8062e40ea4018ae0ccbe6cacfd2 /net-wireless
parentRevbump to ensure nobody has world-writable javaws. Synced with ibm-jdk-bin (... (diff)
downloadgentoo-2-b902640042c96263c9aa401cbc5c30ea6c0a9c84.tar.gz
gentoo-2-b902640042c96263c9aa401cbc5c30ea6c0a9c84.tar.bz2
gentoo-2-b902640042c96263c9aa401cbc5c30ea6c0a9c84.zip
Add a patch to enable dbus interface to compile on FreeBSD - you'll still need
the dbus-core from the overlay though AND tweak the ebuild slightly. Keyworded ~xf86-fbsd. (Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/wpa_supplicant/ChangeLog8
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.5-sigpoll.patch16
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild15
3 files changed, 32 insertions, 7 deletions
diff --git a/net-wireless/wpa_supplicant/ChangeLog b/net-wireless/wpa_supplicant/ChangeLog
index 627f35c6e118..839b283f5050 100644
--- a/net-wireless/wpa_supplicant/ChangeLog
+++ b/net-wireless/wpa_supplicant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/wpa_supplicant
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.76 2006/09/23 22:51:52 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.77 2006/09/29 09:15:43 uberlord Exp $
+
+ 29 Sep 2006; Roy Marples <uberlord@gentoo.org>
+ +files/wpa_supplicant-0.5.5-sigpoll.patch, wpa_supplicant-0.5.5.ebuild:
+ Add a patch to enable dbus interface to compile on FreeBSD - you'll still need
+ the dbus-core from the overlay though AND tweak the ebuild slightly.
+ Keyworded ~xf86-fbsd.
23 Sep 2006; Joseph Jezak <josejx@gentoo.org> wpa_supplicant-0.5.4.ebuild:
Marked ppc stable for bug #144997.
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.5-sigpoll.patch b/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.5-sigpoll.patch
new file mode 100644
index 000000000000..6460e8234c15
--- /dev/null
+++ b/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.5-sigpoll.patch
@@ -0,0 +1,16 @@
+--- ctrl_iface_dbus.h.orig 2006-09-29 09:41:07 +0100
++++ ctrl_iface_dbus.h 2006-09-29 09:44:23 +0100
+@@ -17,6 +17,13 @@
+
+ #ifdef CONFIG_CTRL_IFACE_DBUS
+
++/* If we don't have SIGPOLL, so use SIGIO instead */
++#ifndef SIGPOLL
++#ifdef SIGIO
++#define SIGPOLL SIGIO
++#endif
++#endif
++
+ #include <dbus/dbus.h>
+
+ #define WPAS_DBUS_OBJECT_PATH_MAX 150
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild
index 3f603d4cdbec..32cf47b90fc9 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild,v 1.5 2006/09/06 07:53:29 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild,v 1.6 2006/09/29 09:15:43 uberlord Exp $
inherit eutils toolchain-funcs
@@ -10,19 +10,19 @@ SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
LICENSE="|| ( GPL-2 BSD )"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="dbus gsm madwifi qt3 qt4 readline ssl kernel_linux kernel_FreeBSD"
-RDEPEND="dbus? ( sys-apps/dbus )
- gsm? ( sys-apps/pcsc-lite )
+#When dbus-core is out of package mask, this is how it works
+#RDEPEND="dbus? ( || ( sys-apps/dbus-core sys-apps/dbus ) )"
+RDEPEND="kernel_linux? ( dbus? ( sys-apps/dbus ) )
+ kernel_linux? ( gsm? ( sys-apps/pcsc-lite ) )
qt4? ( =x11-libs/qt-4* )
!qt4? ( qt3? ( =x11-libs/qt-3* ) )
readline? ( sys-libs/ncurses sys-libs/readline )
ssl? ( dev-libs/openssl )
kernel_linux? ( madwifi? ( || ( net-wireless/madwifi-ng net-wireless/madwifi-old ) ) )
!kernel_linux? ( net-libs/libpcap )"
-DEPEND="sys-apps/sed
- ${RDEPEND}"
pkg_setup() {
if use kernel_linux ; then
@@ -43,6 +43,9 @@ src_unpack() {
# Fix QT4 support, #146177 thanks to Horst Schirmeier.
epatch "${FILESDIR}/${P}-qt4.patch"
+ # If we don't have SIGPOLL (like FreeBSD), use SIGIO instead
+ epatch "${FILESDIR}/${P}-sigpoll.patch"
+
# net/bpf.h needed for net-libs/libpcap on Gentoo FreeBSD
sed -i \
-e "s:\(#include <pcap\.h>\):#include <net/bpf.h>\n\1:" \