summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-02-04 03:34:13 +0000
committerRick Farina <zerochaos@gentoo.org>2014-02-04 03:34:13 +0000
commitab270eb5e54408e09320ec653a5b9607f9442f09 (patch)
treefb9ea407b06b58897baba714792ef1e9367b43c0 /net-wireless
parentAdd more cross-compile related variables to force sane results. (diff)
downloadgentoo-2-ab270eb5e54408e09320ec653a5b9607f9442f09.tar.gz
gentoo-2-ab270eb5e54408e09320ec653a5b9607f9442f09.tar.bz2
gentoo-2-ab270eb5e54408e09320ec653a5b9607f9442f09.zip
version bump, bug 499850
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/aircrack-ng/ChangeLog10
-rw-r--r--net-wireless/aircrack-ng/aircrack-ng-1.2_beta2.ebuild97
-rw-r--r--net-wireless/aircrack-ng/files/aircrack-ng-9999-fix-labels.patch49
3 files changed, 154 insertions, 2 deletions
diff --git a/net-wireless/aircrack-ng/ChangeLog b/net-wireless/aircrack-ng/ChangeLog
index 6a3fff194877..d1897e3dba7a 100644
--- a/net-wireless/aircrack-ng/ChangeLog
+++ b/net-wireless/aircrack-ng/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/aircrack-ng
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/aircrack-ng/ChangeLog,v 1.78 2013/10/05 02:05:28 zerochaos Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/aircrack-ng/ChangeLog,v 1.79 2014/02/04 03:34:12 zerochaos Exp $
+
+*aircrack-ng-1.2_beta2 (04 Feb 2014)
+
+ 04 Feb 2014; Rick Farina <zerochaos@gentoo.org> +aircrack-ng-1.2_beta2.ebuild,
+ +files/aircrack-ng-9999-fix-labels.patch:
+ version bump, bug 499850
05 Oct 2013; Rick Farina <zerochaos@gentoo.org> aircrack-ng-9999.ebuild:
minor cleanup, fix tests
diff --git a/net-wireless/aircrack-ng/aircrack-ng-1.2_beta2.ebuild b/net-wireless/aircrack-ng/aircrack-ng-1.2_beta2.ebuild
new file mode 100644
index 000000000000..a5b3e357d511
--- /dev/null
+++ b/net-wireless/aircrack-ng/aircrack-ng-1.2_beta2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/aircrack-ng/aircrack-ng-1.2_beta2.ebuild,v 1.1 2014/02/04 03:34:12 zerochaos Exp $
+
+EAPI="5"
+
+inherit toolchain-funcs versionator
+
+DESCRIPTION="WLAN tools for breaking 802.11 WEP/WPA keys"
+HOMEPAGE="http://www.aircrack-ng.org"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit subversion
+ ESVN_REPO_URI="http://svn.aircrack-ng.org/trunk"
+ KEYWORDS=""
+else
+ MY_PV="$(replace_version_separator 2 '-')"
+ MY_P=${P/\_/-}
+ SRC_URI="http://download.aircrack-ng.org/${PN}-${MY_PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+ ESVN_WC_REVISION=0
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="+airdrop-ng +airgraph-ng kernel_linux kernel_FreeBSD netlink +sqlite +unstable"
+
+DEPEND="dev-libs/openssl
+ netlink? ( dev-libs/libnl:3 )
+ sqlite? ( >=dev-db/sqlite-3.4 )"
+RDEPEND="${DEPEND}
+ kernel_linux? (
+ net-wireless/iw
+ net-wireless/wireless-tools
+ sys-apps/ethtool
+ sys-apps/usbutils
+ sys-apps/pciutils )
+ sys-apps/hwids
+ airdrop-ng? ( net-wireless/lorcon[python] )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/aircrack-ng-9999-fix-labels.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ LD="$(tc-getLD)" \
+ RANLIB="$(tc-getRANLIB)" \
+ libnl=$(usex netlink true false) \
+ sqlite=$(usex sqlite true false) \
+ unstable=$(usex unstable true false) \
+ REVFLAGS=-D_REVISION="${ESVN_WC_REVISION}"
+}
+
+src_install() {
+ emake \
+ prefix="${ED}/usr" \
+ libnl=$(usex netlink true false) \
+ sqlite=$(usex sqlite true false) \
+ unstable=$(usex unstable true false) \
+ REVFLAGS=-D_REVISION="${ESVN_WC_REVISION}" \
+ install
+
+ dodoc AUTHORS ChangeLog INSTALLING README
+
+ if use airgraph-ng; then
+ cd "${S}/scripts/airgraph-ng"
+ emake prefix="${ED}/usr" install
+ fi
+ if use airdrop-ng; then
+ cd "${S}/scripts/airdrop-ng"
+ emake prefix="${ED}/usr" install
+ fi
+
+ #we don't need aircrack-ng's oui updater, we have our own
+ rm "${ED}"/usr/sbin/airodump-ng-oui-update
+}
+
+pkg_postinst() {
+ # Message is (c) FreeBSD
+ # http://www.freebsd.org/cgi/cvsweb.cgi/ports/net-mgmt/aircrack-ng/files/pkg-message.in?rev=1.5
+ if use kernel_FreeBSD ; then
+ einfo "Contrary to Linux, it is not necessary to use airmon-ng to enable the monitor"
+ einfo "mode of your wireless card. So do not care about what the manpages say about"
+ einfo "airmon-ng, airodump-ng sets monitor mode automatically."
+ echo
+ einfo "To return from monitor mode, issue the following command:"
+ einfo " ifconfig \${INTERFACE} -mediaopt monitor"
+ einfo
+ einfo "For aireplay-ng you need FreeBSD >= 7.0."
+ fi
+}
diff --git a/net-wireless/aircrack-ng/files/aircrack-ng-9999-fix-labels.patch b/net-wireless/aircrack-ng/files/aircrack-ng-9999-fix-labels.patch
new file mode 100644
index 000000000000..d89f16ecc4d5
--- /dev/null
+++ b/net-wireless/aircrack-ng/files/aircrack-ng-9999-fix-labels.patch
@@ -0,0 +1,49 @@
+Fix build failure with gcc with -fstack-protector-all.
+
+> $ x86_64-pc-linux-gnu-gcc -Os -pipe -march=native -frecord-gcc-switches -ggdb -D_FILE_OFFSET_BITS=64 -D_REVISION=0 -I/usr/local/include -DHAVE_SQLITE -DCONFIG_LIBNL30 -I/usr/include/libnl3 -Wno-unused-but-set-variable -Wno-array-bounds -D_FILE_OFFSET_BITS=64 -D_REVISION=0 -I/usr/local/include -DHAVE_SQLITE -DCONFIG_LIBNL30 -I/usr/include/libnl3 -Wno-unused-but-set-variable -Wno-array-bounds -Iinclude -c -o aircrack-ptw-lib.o aircrack-ptw-lib.c
+> aircrack-ptw-lib.c: Assembler messages:
+> aircrack-ptw-lib.c:181: Error: symbol `.L7' is already defined
+
+Error gets triggered on vanilla toolchain when -fstack-protector-all is used.
+gcc emits labels around in start/end functions as follows (the canary check):
+
+> movq8(%rsp), %rcx
+> xorq%fs:40, %rcx
+> je.L7
+> call__stack_chk_fail
+>.LVL5:
+>.L7:
+> addq$24, %rsp
+> .cfi_def_cfa_offset 8
+
+and gets .L7 collision.
+Patch gives all .L\d names a bit nicer names to avoid collision and add readability.
+diff --git a/src/aircrack-ptw-lib.c b/src/aircrack-ptw-lib.c
+index 79268fb..5524053 100644
+--- a/src/aircrack-ptw-lib.c
++++ b/src/aircrack-ptw-lib.c
+@@ -168,10 +168,10 @@ static int rc4test_amd64_sse2(uint8_t *key, int keylen, uint8_t *iv, uint8_t *ke
+ "movdqa (%q3), %%xmm0 \n\t"
+ "cmpl $16, %k4 \n\t"
+ "movdqu %%xmm0, 3+"keybuf" \n\t"
+- "jng .L0 \n\t"
++ "jng .Lsmall_key1 \n\t"
+ "movdqa 16(%q3), %%xmm1 \n\t"
+ "movdqu %%xmm1,19+"keybuf" \n\t"
+- ".L0: \n\t"
++ ".Lsmall_key1: \n\t"
+
+ // key = keybuf
+ "lea "keybuf", %q3 \n\t"
+@@ -198,9 +198,9 @@ static int rc4test_amd64_sse2(uint8_t *key, int keylen, uint8_t *iv, uint8_t *ke
+ "movq %q4, %q8 \n\t"
+ "cmpq $16, %q8 \n\t"
+ "movq $15, %q4 \n\t"
+- "je .L7 \n\t"
++ "je .Lsmall_key2 \n\t"
+ "shrq $1, %q4 \n\t"
+- ".L7: \n\t"
++ ".Lsmall_key2: \n\t"
+
+ // init array with key
+ ".p2align 4 \n\t"