summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2003-02-08 03:23:17 +0000
committerPeter Johanson <latexer@gentoo.org>2003-02-08 03:23:17 +0000
commit9f3ed48f6a52f390111886ec2b390cee14f8fae9 (patch)
tree0a73809c65becd834a095535b78607172b31a4d8 /net-wireless
parentFixed stupid typo that reversed the order of output in einfo statements. (diff)
downloadgentoo-2-9f3ed48f6a52f390111886ec2b390cee14f8fae9.tar.gz
gentoo-2-9f3ed48f6a52f390111886ec2b390cee14f8fae9.tar.bz2
gentoo-2-9f3ed48f6a52f390111886ec2b390cee14f8fae9.zip
Moved hostap from sys-apps to net-wireless
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostap/ChangeLog11
-rw-r--r--net-wireless/hostap/files/digest-hostap-200210122
-rw-r--r--net-wireless/hostap/files/hostap-20021012-gentoo-patch.diff13
-rw-r--r--net-wireless/hostap/hostap-20021012.ebuild83
4 files changed, 109 insertions, 0 deletions
diff --git a/net-wireless/hostap/ChangeLog b/net-wireless/hostap/ChangeLog
new file mode 100644
index 000000000000..85511cefd2b6
--- /dev/null
+++ b/net-wireless/hostap/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-wireless/hostap
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/ChangeLog,v 1.1 2003/02/08 03:22:49 latexer Exp $
+
+*hostap-20021012 (07 Feb 2003)
+
+ 08 Feb 2003; Peter Johanson <latexer@gentoo.org> :
+ Moved from sys-apps to net-wireless.
+
+ 07 Feb 2003; Peter Johanson <latexer@gentoo.org> hostap-20021012 :
+ Initial import. Ebuild by me.
diff --git a/net-wireless/hostap/files/digest-hostap-20021012 b/net-wireless/hostap/files/digest-hostap-20021012
new file mode 100644
index 000000000000..1c66f06d19b0
--- /dev/null
+++ b/net-wireless/hostap/files/digest-hostap-20021012
@@ -0,0 +1,2 @@
+MD5 f5170147792a591120437dd33dbb106d hostap-2002-10-12.tar.gz 204390
+MD5 7e9f01a697d2e3e5164340d79474ea30 pcmcia-cs-3.2.1.tar.gz 1250413
diff --git a/net-wireless/hostap/files/hostap-20021012-gentoo-patch.diff b/net-wireless/hostap/files/hostap-20021012-gentoo-patch.diff
new file mode 100644
index 000000000000..4b80ab474ca0
--- /dev/null
+++ b/net-wireless/hostap/files/hostap-20021012-gentoo-patch.diff
@@ -0,0 +1,13 @@
+--- hostap-2002-10-12/hostapd/hostapd.h 2002-09-08 13:49:35.000000000 -0400
++++ hostapd.h.new 2003-02-06 19:03:47.000000000 -0500
+@@ -49,9 +49,8 @@
+ struct sta_info *sta_aid[MAX_AID_TABLE_SIZE];
+
+ enum { HOSTAPD_DEBUG_NO = 0, HOSTAPD_DEBUG_MINIMAL = 1,
+- HOSTAPD_DEBUG_MSGDUMPS = 2 };
++ HOSTAPD_DEBUG_MSGDUMPS = 2 } debug; /* debug verbosity level */
+
+- int debug; /* debug verbosity level */
+ char *dump_log_name; /* file name for state dump (SIGUSR1) */
+
+ int ieee802_1x; /* use IEEE 802.1X */
diff --git a/net-wireless/hostap/hostap-20021012.ebuild b/net-wireless/hostap/hostap-20021012.ebuild
new file mode 100644
index 000000000000..a27f80463946
--- /dev/null
+++ b/net-wireless/hostap/hostap-20021012.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/hostap-20021012.ebuild,v 1.1 2003/02/08 03:22:49 latexer Exp $
+
+inherit eutils
+
+DESCRIPTION="HostAP wireless drivers"
+HOMEPAGE="http://hostap.epitest.fi/"
+
+MY_PCMCIA="pcmcia-cs-3.2.1"
+SRC_URI="http://hostap.epitest.fi/releases/${PN}-2002-10-12.tar.gz
+ pcmcia? ( mirror://sourceforge/pcmcia-cs/${MY_PCMCIA}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="pcmcia pci plx"
+
+DEPEND="pcmcia? ( >=sys-apps/pcmcia-cs-3.2.1* )"
+
+S=${WORKDIR}/${PN}-2002-10-12
+LIB_PATH="/lib/modules/`uname -r`"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # This is a patch that has already been applied to the hostap
+ # cvs tree. It fixes hostapd compilation for gcc-3.2
+
+ epatch ${FILESDIR}/${P}-gentoo-patch.diff
+
+ cp Makefile ${T}
+ sed -e "s:^PCMCIA_PATH=:PCMCIA_PATH=${WORKDIR}/${MY_PCMCIA}:" \
+ -e "s:gcc:${CC}:" \
+ -e "s:-O2:${CFLAGS}:" \
+ -e "s:\$(EXTRA_CFLAGS):\$(EXTRA_CFLAGS) -DPRISM2_HOSTAPD:" \
+ ${T}/Makefile > Makefile
+
+ cd ${S}/hostapd
+ cp Makefile ${T}
+ sed -e "s:gcc:${CC}:" \
+ -e "s:-O2:${CFLAGS}:" \
+ ${T}/Makefile > Makefile
+}
+
+src_compile() {
+
+ HOSTAP_DRIVERS="pci plx"
+
+ use pcmcia && HOSTAP_DRIVERS="${HOSTAP_DRIVERS} pccard"
+
+ emake ${HOSTAP_DRIVERS} hostap crypt || die
+
+ cd ${S}/hostapd
+ emake || die
+}
+
+src_install() {
+ if [ -n "`use pcmcia`" ]; then
+ dodir ${LIB_PATH}/pcmcia
+ dodir /etc/pcmcia
+ cp ${S}/driver/modules/hostap_cs.o ${D}/${LIB_PATH}/pcmcia/
+ cp ${S}/driver/etc/hostap_cs.conf ${D}/etc/pcmcia/
+ if [ -r /etc/pcmcia/prism2.conf ]; then
+ einfo "You may need to remove /etc/pcmcia/prism2.conf"
+ fi
+ fi
+
+ dodir ${LIB_PATH}/net
+ cp ${S}/driver/modules/{hostap.o,hostap_crypt.o,hostap_crypt_wep.o}\
+ ${D}${LIB_PATH}/net/
+ cp ${S}/driver/modules/{hostap_pci.o,hostap_plx.o}\
+ ${D}${LIB_PATH}/net/
+
+ dodoc FAQ README README.prism2 ChangeLog
+
+ dosbin hostapd/hostapd
+}
+
+
+