summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-10-09 18:49:21 +0000
committerRick Farina <zerochaos@gentoo.org>2012-10-09 18:49:21 +0000
commit08a054cb08b0490ea1c4190b937032f2b5ae62fa (patch)
treeb315f7ab23147591ec9695da0c7d8582cd5b9ec0 /net-wireless
parentStable for amd64, wrt bug #437664 (diff)
downloadgentoo-2-08a054cb08b0490ea1c4190b937032f2b5ae62fa.tar.gz
gentoo-2-08a054cb08b0490ea1c4190b937032f2b5ae62fa.tar.bz2
gentoo-2-08a054cb08b0490ea1c4190b937032f2b5ae62fa.zip
bump, had to drop arm keywords for now but not forever
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/kismet-ubertooth/ChangeLog8
-rw-r--r--net-wireless/kismet-ubertooth/kismet-ubertooth-2012.10.1.ebuild56
-rw-r--r--net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild29
3 files changed, 78 insertions, 15 deletions
diff --git a/net-wireless/kismet-ubertooth/ChangeLog b/net-wireless/kismet-ubertooth/ChangeLog
index b27bec185f00..b5ab2956a8e3 100644
--- a/net-wireless/kismet-ubertooth/ChangeLog
+++ b/net-wireless/kismet-ubertooth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/kismet-ubertooth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet-ubertooth/ChangeLog,v 1.8 2012/08/30 23:18:08 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet-ubertooth/ChangeLog,v 1.9 2012/10/09 18:49:21 zerochaos Exp $
+
+*kismet-ubertooth-2012.10.1 (09 Oct 2012)
+
+ 09 Oct 2012; Rick Farina <zerochaos@gentoo.org>
+ +kismet-ubertooth-2012.10.1.ebuild, kismet-ubertooth-9999.ebuild:
+ bump, had to drop arm keywords for now but not forever
*kismet-ubertooth-0.0_p534-r1 (30 Aug 2012)
diff --git a/net-wireless/kismet-ubertooth/kismet-ubertooth-2012.10.1.ebuild b/net-wireless/kismet-ubertooth/kismet-ubertooth-2012.10.1.ebuild
new file mode 100644
index 000000000000..0152681314da
--- /dev/null
+++ b/net-wireless/kismet-ubertooth/kismet-ubertooth-2012.10.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet-ubertooth/kismet-ubertooth-2012.10.1.ebuild,v 1.1 2012/10/09 18:49:21 zerochaos Exp $
+
+EAPI="4"
+
+inherit multilib
+
+MY_PV=${PV/\./-}
+MY_PV=${MY_PV/./-R}
+S="${WORKDIR}/ubertooth-${MY_PV}"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://ubertooth.git.sourceforge.net/gitroot/ubertooth/ubertooth"
+ SRC_URI=""
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="mirror://sourceforge/ubertooth/ubertooth-${MY_PV}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Provides basic bluetooth support in kismet"
+HOMEPAGE="http://ubertooth.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=net-wireless/kismet-2011.03.2-r1 \
+ =net-wireless/ubertooth-${PV} \
+ =net-libs/libbtbb-${PV} \
+ virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if has_version =net-wireless/kismet-9999; then
+ cd "${S}/host/kismet/plugin-ubertooth-phyneutral" || die
+ else
+ cd "${S}/host/kismet/plugin-ubertooth" || die
+ fi
+ emake KIS_SRC_DIR="/usr/include/kismet/"
+}
+
+src_install() {
+ if has_version =net-wireless/kismet-9999; then
+ cd "${S}/host/kismet/plugin-ubertooth-phyneutral" || die
+ else
+ cd "${S}/host/kismet/plugin-ubertooth" || die
+ fi
+ emake DESTDIR="${ED}" LIBDIR="/$(get_libdir)" KIS_SRC_DIR="/usr/include/kismet/" install
+}
+
+pkg_postinst() {
+ ewarn "This package must be rebuilt every time kismet is rebuilt. Or else."
+}
diff --git a/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild b/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild
index 8504f8e2ec36..301644f67809 100644
--- a/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild
+++ b/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild
@@ -1,22 +1,23 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild,v 1.6 2012/08/30 23:18:08 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet-ubertooth/kismet-ubertooth-9999.ebuild,v 1.7 2012/10/09 18:49:21 zerochaos Exp $
EAPI="4"
inherit multilib
+MY_PV=${PV/\./-}
+MY_PV=${MY_PV/./-R}
+S="${WORKDIR}/ubertooth-${MY_PV}"
+
if [[ ${PV} == "9999" ]] ; then
- ESVN_REPO_URI="https://ubertooth.svn.sourceforge.net/svnroot/ubertooth/trunk/host"
+ EGIT_REPO_URI="git://ubertooth.git.sourceforge.net/gitroot/ubertooth/ubertooth"
SRC_URI=""
- inherit subversion
+ inherit git-2
KEYWORDS=""
else
- MY_PV="${PV/p/r}"
- MY_PV="${MY_PV/0.0_/}"
- SRC_URI="mirror://sourceforge/ubertooth/ubertooth-${MY_PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
- S="${WORKDIR}/ubertooth-${MY_PV}/host/"
+ SRC_URI="mirror://sourceforge/ubertooth/ubertooth-${MY_PV}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="Provides basic bluetooth support in kismet"
@@ -27,25 +28,25 @@ SLOT="0"
IUSE=""
DEPEND=">=net-wireless/kismet-2011.03.2-r1 \
- =net-wireless/ubertooth-9999 \
- =net-libs/libbtbb-9999 \
+ =net-wireless/ubertooth-${PV} \
+ =net-libs/libbtbb-${PV} \
virtual/libusb:1"
RDEPEND="${DEPEND}"
src_compile() {
if has_version =net-wireless/kismet-9999; then
- cd "${S}/kismet/plugin-ubertooth-phyneutral" || die
+ cd "${S}/host/kismet/plugin-ubertooth-phyneutral" || die
else
- cd "${S}/kismet/plugin-ubertooth" || die
+ cd "${S}/host/kismet/plugin-ubertooth" || die
fi
emake KIS_SRC_DIR="/usr/include/kismet/"
}
src_install() {
if has_version =net-wireless/kismet-9999; then
- cd "${S}/kismet/plugin-ubertooth-phyneutral" || die
+ cd "${S}/host/kismet/plugin-ubertooth-phyneutral" || die
else
- cd "${S}/kismet/plugin-ubertooth" || die
+ cd "${S}/host/kismet/plugin-ubertooth" || die
fi
emake DESTDIR="${ED}" LIBDIR="/$(get_libdir)" KIS_SRC_DIR="/usr/include/kismet/" install
}