summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2015-04-27 18:26:39 +0000
committerRick Farina <zerochaos@gentoo.org>2015-04-27 18:26:39 +0000
commite19fd654fb435536da49b38eae9e07ed35ca30fb (patch)
tree5dcb33931610e16b085fea0145dd5a38fb7ee751 /net-wireless/wpa_supplicant
parentLinux patch 3.18.12 (diff)
downloadgentoo-2-e19fd654fb435536da49b38eae9e07ed35ca30fb.tar.gz
gentoo-2-e19fd654fb435536da49b38eae9e07ed35ca30fb.tar.bz2
gentoo-2-e19fd654fb435536da49b38eae9e07ed35ca30fb.zip
add patch for bug #547492 while not loading arch teams working on bug #524928
(Portage version: 2.2.18/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless/wpa_supplicant')
-rw-r--r--net-wireless/wpa_supplicant/ChangeLog9
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_supplicant-2.4-cve-2015-1863.patch37
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-2.4-r1.ebuild (renamed from net-wireless/wpa_supplicant/wpa_supplicant-2.4.ebuild)4
3 files changed, 48 insertions, 2 deletions
diff --git a/net-wireless/wpa_supplicant/ChangeLog b/net-wireless/wpa_supplicant/ChangeLog
index f982897f118f..349bf59fc60f 100644
--- a/net-wireless/wpa_supplicant/ChangeLog
+++ b/net-wireless/wpa_supplicant/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-wireless/wpa_supplicant
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.234 2015/04/26 16:51:23 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.235 2015/04/27 18:26:39 zerochaos Exp $
+
+*wpa_supplicant-2.4-r1 (27 Apr 2015)
+
+ 27 Apr 2015; Rick Farina <zerochaos@gentoo.org>
+ +files/wpa_supplicant-2.4-cve-2015-1863.patch, +wpa_supplicant-2.4-r1.ebuild,
+ -wpa_supplicant-2.4.ebuild:
+ add patch for bug #547492 while not loading arch teams working on bug #524928
26 Apr 2015; Pacho Ramos <pacho@gentoo.org> wpa_supplicant-2.4.ebuild:
ppc stable wrt bug #524928
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant-2.4-cve-2015-1863.patch b/net-wireless/wpa_supplicant/files/wpa_supplicant-2.4-cve-2015-1863.patch
new file mode 100644
index 000000000000..e417bf22b3db
--- /dev/null
+++ b/net-wireless/wpa_supplicant/files/wpa_supplicant-2.4-cve-2015-1863.patch
@@ -0,0 +1,37 @@
+From 9ed4eee345f85e3025c33c6e20aa25696e341ccd Mon Sep 17 00:00:00 2001
+From: Jouni Malinen <jouni@qca.qualcomm.com>
+Date: Tue, 07 Apr 2015 08:32:11 +0000
+Subject: P2P: Validate SSID element length before copying it (CVE-2015-1863)
+
+This fixes a possible memcpy overflow for P2P dev->oper_ssid in
+p2p_add_device(). The length provided by the peer device (0..255 bytes)
+was used without proper bounds checking and that could have resulted in
+arbitrary data of up to 223 bytes being written beyond the end of the
+dev->oper_ssid[] array (of which about 150 bytes would be beyond the
+heap allocation) when processing a corrupted management frame for P2P
+peer discovery purposes.
+
+This could result in corrupted state in heap, unexpected program
+behavior due to corrupted P2P peer device information, denial of service
+due to process crash, exposure of memory contents during GO Negotiation,
+and potentially arbitrary code execution.
+
+Thanks to Google security team for reporting this issue and smart
+hardware research group of Alibaba security team for discovering it.
+
+Signed-off-by: Jouni Malinen <jouni@qca.qualcomm.com>
+---
+diff --git a/src/p2p/p2p.c b/src/p2p/p2p.c
+index f584fae..a45fe73 100644
+--- a/src/p2p/p2p.c
++++ b/src/p2p/p2p.c
+@@ -778,6 +778,7 @@ int p2p_add_device(struct p2p_data *p2p, const u8 *addr, int freq,
+ if (os_memcmp(addr, p2p_dev_addr, ETH_ALEN) != 0)
+ os_memcpy(dev->interface_addr, addr, ETH_ALEN);
+ if (msg.ssid &&
++ msg.ssid[1] <= sizeof(dev->oper_ssid) &&
+ (msg.ssid[1] != P2P_WILDCARD_SSID_LEN ||
+ os_memcmp(msg.ssid + 2, P2P_WILDCARD_SSID, P2P_WILDCARD_SSID_LEN)
+ != 0)) {
+--
+cgit v0.9.2
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-2.4.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-2.4-r1.ebuild
index a70a357b3ea6..036f266b2dca 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-2.4.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-2.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-2.4.ebuild,v 1.5 2015/04/26 16:51:23 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-2.4-r1.ebuild,v 1.1 2015/04/27 18:26:39 zerochaos Exp $
EAPI=5
@@ -114,6 +114,8 @@ src_prepare() {
# SO WOULD BE NICE TO JUST DROP IT, IF IT IS NOT NEEDED.
# bug (374089)
#epatch "${FILESDIR}/${P}-dbus-WPAIE-fix.patch"
+
+ epatch "${FILESDIR}"/wpa_supplicant-2.4-cve-2015-1863.patch
}
src_configure() {