summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-05-10 11:05:45 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-05-10 11:05:45 +0000
commit0e5b694d0b75c35ebde8479648150e038c031b0d (patch)
tree95aa08111fd80710bebbe0b60167c17943f0544d /net-wireless/orinoco-sn/orinoco-sn-0.13e_pre15.ebuild
parentStable on alpha wrt security #170977 (diff)
downloadgentoo-2-0e5b694d0b75c35ebde8479648150e038c031b0d.tar.gz
gentoo-2-0e5b694d0b75c35ebde8479648150e038c031b0d.tar.bz2
gentoo-2-0e5b694d0b75c35ebde8479648150e038c031b0d.zip
Add forked driver thanks to Marcin <pr0d1r2@gmail.com> in bug 172863 and a kernel 2.6.21 patch
(Portage version: 2.1.2.5)
Diffstat (limited to 'net-wireless/orinoco-sn/orinoco-sn-0.13e_pre15.ebuild')
-rw-r--r--net-wireless/orinoco-sn/orinoco-sn-0.13e_pre15.ebuild102
1 files changed, 102 insertions, 0 deletions
diff --git a/net-wireless/orinoco-sn/orinoco-sn-0.13e_pre15.ebuild b/net-wireless/orinoco-sn/orinoco-sn-0.13e_pre15.ebuild
new file mode 100644
index 000000000000..4c16bb8e28e2
--- /dev/null
+++ b/net-wireless/orinoco-sn/orinoco-sn-0.13e_pre15.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit linux-mod eutils
+
+MY_P=${P/-sn}
+MY_P=${MY_P/_pre/-SN-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORiNOCO WLAN drivers for PCMCIA and PCI with extended monitor mode and scanning support"
+HOMEPAGE="http://www.projectiwear.org/~plasmahh/orinoco.html"
+
+SRC_URI="http://www.projectiwear.org/~plasmahh/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 MPL-1.1"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+
+IUSE="pcmcia"
+DEPEND="!net-wireless/orinoco-usb"
+RDEPEND="net-wireless/wireless-tools"
+
+BUILD_TARGETS="all"
+MODULESD_ORINOCO_DOCS="README.orinoco"
+
+CONFIG_CHECK="~FW_LOADER !HERMES NET_RADIO"
+ERROR_HERMES="${P} requires Hermes chipset 802.11b support (Orinoco/Prism2/Symbol) (CONFIG_HERMES) to be DISABLED."
+ERROR_NET_RADIO="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_NET_RADIO)."
+MODULESD_ORINOCO_NORTEL_ENABLED="no"
+MODULESD_ORINOCO_PCI_ENABLED="no"
+MODULESD_ORINOCO_PLX_ENABLED="no"
+MODULESD_ORINOCO_TMD_ENABLED="no"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 11; then
+ eerror
+ eerror "${P} requires kernel 2.6.11 or above."
+ eerror
+ die "Kernel version too old."
+ fi
+
+ MODULE_NAMES="hermes(net/wireless:)
+ orinoco(net/wireless:)"
+
+ if linux_chkconfig_present PCI; then
+ MODULE_NAMES="${MODULE_NAMES}
+ orinoco_pci(net/wireless:)
+ orinoco_plx(net/wireless:)
+ orinoco_tmd(net/wireless:)"
+ fi
+
+ if linux_chkconfig_present PPC_PMAC; then
+ MODULE_NAMES="${MODULE_NAMES} airport(net/wireless:)"
+ fi
+
+ if use pcmcia && linux_chkconfig_present PCMCIA; then
+ MODULE_NAMES="${MODULE_NAMES} orinoco_cs(net/wireless:)"
+ fi
+
+ BUILD_PARAMS="KERNEL_PATH=${KV_OUT_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/orinoco-sn-2.6.21.patch
+}
+
+src_compile() {
+ linux-mod_src_compile
+
+ if use pcmcia; then
+ emake hermes.conf || die "emake hermes.conf failed"
+ fi
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc NEWS
+
+ if use pcmcia; then
+ insinto /etc/pcmcia
+ doins hermes.conf
+ fi
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ if [[ -e ${ROOT}/lib/modules/${KV_FULL}/pcmcia/orinoco.${KV_OBJ} ]]; then
+ ewarn
+ ewarn "The modules from this package conflicts with the modules installed"
+ ewarn "by the pcmcia-cs package. You will have to manually delete the"
+ ewarn "duplicate modules from the"
+ ewarn " ${ROOT}lib/modules/${KV_FULL}/pcmcia/"
+ ewarn "directory and manually run '/sbin/depmod -ae'"
+ ewarn
+ fi
+}