summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-07-29 08:37:41 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-07-29 08:37:41 +0000
commit876953532e9062fc52fc99f8dfd74e7a0cba60f3 (patch)
tree23e10a6029f06b7ab9b6ff32fe9646f1b5f6c674 /net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.2.ebuild
parentversion bump thanks to Conrad Kostecki <ConiKost@gmx.de> in bug 142043 (diff)
downloadgentoo-2-876953532e9062fc52fc99f8dfd74e7a0cba60f3.tar.gz
gentoo-2-876953532e9062fc52fc99f8dfd74e7a0cba60f3.tar.bz2
gentoo-2-876953532e9062fc52fc99f8dfd74e7a0cba60f3.zip
version bump thanks to Conrad Kostecki <ConiKost@gmx.de> in bug 142043
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.2.ebuild')
-rw-r--r--net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.2.ebuild b/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.2.ebuild
new file mode 100644
index 000000000000..7880da51a6bb
--- /dev/null
+++ b/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.2.ebuild,v 1.1 2006/07/29 08:37:41 genstef Exp $
+
+inherit toolchain-funcs
+
+MY_P=${PN/-ng-tools/}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Next Generation tools for configuration of Atheros based IEEE 802.11a/b/g wireless LAN cards"
+HOMEPAGE="http://www.madwifi.org/"
+SRC_URI="mirror://sourceforge/madwifi/madwifi-${PV}.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+DEPEND="virtual/libc"
+RDEPEND="!net-wireless/madwifi-old-tools
+ ${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ # format string fix from solar
+ #sed -i \
+# -e 's:err(1, ifr.ifr_name);:err(1, "%s", ifr.ifr_name);:g' \
+# ${S}/tools/athstats.c || die
+
+einfo "S=$S"
+einfo "PV=$PV"
+
+ sed -i \
+ -e "s:CC =.*:CC = $(tc-getCC):" \
+ -e "s:CFLAGS=:CFLAGS+=:" \
+ -e "s:LDFLAGS=:LDFLAGS+=:" \
+ ${S}/tools/Makefile || die
+}
+
+src_compile() {
+ emake tools || die "emake tools failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" BINDIR=/usr/bin MANDIR=/usr/share/man STRIP=echo \
+ install-tools || die "make install-tools failed"
+
+ dodir /sbin
+ mv "${D}"/usr/bin/wlanconfig "${D}"/sbin
+}
+
+pkg_postinst() {
+ if [ -e "${ROOT}"/etc/udev/rules.d/65-madwifi.rules ]; then
+ ewarn
+ ewarn "The udev rules for creating interfaces (athX) are no longer needed."
+ ewarn
+ ewarn "You should manually remove the /etc/udev/rules.d/65-madwifi.rules file"
+ ewarn "and either run 'udevstart' or reboot for the changes to take effect."
+ ewarn
+ fi
+}