summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-04-23 18:35:25 +0000
committerAlin Năstac <mrness@gentoo.org>2006-04-23 18:35:25 +0000
commit5a250a2b6920464bb2262ddafb6c43180a6c2c33 (patch)
tree8e393d1d33970c50625b2c73b11265b1f07d006e /net-wireless/kdebluetooth/kdebluetooth-1.0_beta1-r2.ebuild
parentAdded install of rdf data. Thanks to Paul Winkler <stuff@slinkp.com>. Closes ... (diff)
downloadgentoo-2-5a250a2b6920464bb2262ddafb6c43180a6c2c33.tar.gz
gentoo-2-5a250a2b6920464bb2262ddafb6c43180a6c2c33.tar.bz2
gentoo-2-5a250a2b6920464bb2262ddafb6c43180a6c2c33.zip
Fix configure error when build against >=dev-libs/openobex-1.1 (#122262).
(Portage version: 2.0.54)
Diffstat (limited to 'net-wireless/kdebluetooth/kdebluetooth-1.0_beta1-r2.ebuild')
-rw-r--r--net-wireless/kdebluetooth/kdebluetooth-1.0_beta1-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-wireless/kdebluetooth/kdebluetooth-1.0_beta1-r2.ebuild b/net-wireless/kdebluetooth/kdebluetooth-1.0_beta1-r2.ebuild
new file mode 100644
index 000000000000..300e7178c987
--- /dev/null
+++ b/net-wireless/kdebluetooth/kdebluetooth-1.0_beta1-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/kdebluetooth/kdebluetooth-1.0_beta1-r2.ebuild,v 1.1 2006/04/23 18:35:25 mrness Exp $
+
+inherit kde autotools
+
+MY_PV=${PV}
+MY_P=${PN}-${MY_PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="KDE Bluetooth Framework"
+HOMEPAGE="http://kde-bluetooth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kde-bluetooth/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="xmms irmc"
+
+DEPEND=">=dev-libs/openobex-1
+ >=net-wireless/bluez-libs-2.15
+ >=media-libs/libvorbis-1.0
+ xmms? ( >=media-sound/xmms-1.2.10 )
+ irmc? ( || ( >=kde-base/kitchensync-3.4_beta1 >=kde-base/kdepim-3.4_beta1 ) )"
+
+RDEPEND="|| ( ( kde-base/kdialog kde-base/konqueror ) kde-base/kdebase )
+ net-wireless/bluez-utils"
+
+PATCHES="${FILESDIR}/${P}-gcc41.patch
+ ${FILESDIR}/${P}-kde3.5.2.patch
+ ${FILESDIR}/${P}-openobex-1.1.patch"
+
+need-kde 3
+
+src_unpack() {
+ kde_src_unpack
+
+ eaclocal && eautoconf || die "autotools failed"
+}
+
+src_compile() {
+ # Change defaults to match our bluez-utils setup
+ sed -i -e 's,/etc/init\.d/bluez-utils,/etc/init\.d/bluetooth,' \
+ "${S}/kdebluetooth/kbluetoothd/kcm_btpaired/pairedtab.cpp" || die
+
+ local myconf="$(use_with xmms) $(use_enable irmc irmcsynckonnector)"
+
+ kde_src_compile
+}
+
+pkg_postinst() {
+ einfo 'This new version of kde-bluetooth provides a replacement for the'
+ einfo 'standard bluepin program "kbluepin". If you want to use this version,'
+ einfo 'you have to edit "/etc/bluetooth/hcid.conf" and change the line'
+ einfo '"pin_helper oldbluepin;" to "pin_helper /usr/lib/kdebluetooth/kbluepin;".'
+ einfo 'Then restart hcid to make the change take effect.'
+ einfo ''
+ einfo 'The bemused server (avaible with the "xmms" USE flag enabled) only works with'
+ einfo 'Symbian OS phones'
+}