summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-07-18 12:30:57 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-07-18 12:30:57 +0000
commit5637bda1c8f884ca829ee6f3699cf56f8898fbc2 (patch)
tree0d745bafdc1367991636f6d53b3ab0252b091bfc /net-wireless/hostap-driver
parentBump to 1.2.2 (bug #130696). (diff)
downloadgentoo-2-5637bda1c8f884ca829ee6f3699cf56f8898fbc2.tar.gz
gentoo-2-5637bda1c8f884ca829ee6f3699cf56f8898fbc2.tar.bz2
gentoo-2-5637bda1c8f884ca829ee6f3699cf56f8898fbc2.zip
Move pcmcia functions from the eclass, bug 140116
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'net-wireless/hostap-driver')
-rw-r--r--net-wireless/hostap-driver/ChangeLog6
-rw-r--r--net-wireless/hostap-driver/files/digest-hostap-driver-0.4.92
-rw-r--r--net-wireless/hostap-driver/hostap-driver-0.4.7.ebuild33
-rw-r--r--net-wireless/hostap-driver/hostap-driver-0.4.9.ebuild33
4 files changed, 69 insertions, 5 deletions
diff --git a/net-wireless/hostap-driver/ChangeLog b/net-wireless/hostap-driver/ChangeLog
index 78db5e9dc74d..dd090db6684c 100644
--- a/net-wireless/hostap-driver/ChangeLog
+++ b/net-wireless/hostap-driver/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/hostap-driver
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/ChangeLog,v 1.55 2006/06/26 22:09:46 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/ChangeLog,v 1.56 2006/07/18 12:30:57 genstef Exp $
+
+ 18 Jul 2006; Stefan Schweizer <genstef@gentoo.org>
+ hostap-driver-0.4.7.ebuild, hostap-driver-0.4.9.ebuild:
+ Move pcmcia functions from the eclass, bug 140116
26 Jun 2006; Henrik Brix Andersen <brix@gentoo.org>
hostap-driver-0.4.9.ebuild:
diff --git a/net-wireless/hostap-driver/files/digest-hostap-driver-0.4.9 b/net-wireless/hostap-driver/files/digest-hostap-driver-0.4.9
index 397918c176be..385ec8984906 100644
--- a/net-wireless/hostap-driver/files/digest-hostap-driver-0.4.9
+++ b/net-wireless/hostap-driver/files/digest-hostap-driver-0.4.9
@@ -1 +1,3 @@
MD5 c7534dc040ab90218257a78488ecd378 hostap-driver-0.4.9.tar.gz 202959
+RMD160 5fd9801f69f5da8ca0f5beb9d2a5155cfcf7bdaf hostap-driver-0.4.9.tar.gz 202959
+SHA256 4c419410f080ab01eb7edf7feed6b9971599e4ca02fe3f40fd87e6f9d7bf9783 hostap-driver-0.4.9.tar.gz 202959
diff --git a/net-wireless/hostap-driver/hostap-driver-0.4.7.ebuild b/net-wireless/hostap-driver/hostap-driver-0.4.7.ebuild
index 5cbc7f59dc70..fc9084548fe6 100644
--- a/net-wireless/hostap-driver/hostap-driver-0.4.7.ebuild
+++ b/net-wireless/hostap-driver/hostap-driver-0.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/hostap-driver-0.4.7.ebuild,v 1.4 2006/03/26 16:06:24 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/hostap-driver-0.4.7.ebuild,v 1.5 2006/07/18 12:30:57 genstef Exp $
inherit toolchain-funcs eutils linux-mod
@@ -13,7 +13,8 @@ KEYWORDS="~amd64 ppc x86"
IUSE="pcmcia"
SLOT="0"
-RDEPEND=">=net-wireless/wireless-tools-25"
+RDEPEND=">=net-wireless/wireless-tools-25
+ pcmcia? ( virtual/pcmcia )"
BUILD_TARGETS="all"
MODULESD_HOSTAP_DOCS="README"
@@ -25,6 +26,34 @@ CONFIG_CHECK="!HOSTAP NET_RADIO"
ERROR_HOSTAP="${P} requires the in-kernel version of the hostap driver to be disabled (CONFIG_HOSTAP)"
ERROR_NET_RADIO="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_NET_RADIO)."
+pcmcia_src_unpack() {
+ local pcmcia_tbz="${ROOT}/usr/src/pcmcia-cs/pcmcia-cs-build-env.tbz2"
+ local PCMCIA_SOURCE_DIR="${WORKDIR}/pcmcia-cs/"
+
+ # if the kernel has pcmcia support built in, then we just ignore all this.
+ if linux_chkconfig_present PCMCIA; then
+ einfo "Kernel based PCMCIA support has been detected."
+ else
+ if kernel_is 2 6; then
+ einfo "We have detected that you are running a 2.6 kernel"
+ einfo "but you are not using the built-in PCMCIA support."
+ einfo "We will assume you know what you are doing, but please"
+ einfo "consider using the built in PCMCIA support instead."
+ epause 10
+ fi
+
+ ebegin "Decompressing pcmcia-cs sources"
+ mkdir -p ${PCMCIA_SOURCE_DIR}
+ tar -xjf ${pcmcia_tbz} -C ${PCMCIA_SOURCE_DIR}
+ eend $?
+
+ if [[ -f ${PCMCIA_SOURCE_DIR}/pcmcia-cs-version ]]; then
+ PCMCIA_VERSION=$(cat ${PCMCIA_SOURCE_DIR}/pcmcia-cs-version)
+ einfo "Found pcmcia-cs-${PCMCIA_VERSION}"
+ fi
+ fi
+}
+
pkg_setup() {
linux-mod_pkg_setup
diff --git a/net-wireless/hostap-driver/hostap-driver-0.4.9.ebuild b/net-wireless/hostap-driver/hostap-driver-0.4.9.ebuild
index 5cffe5719cef..11a51f079a60 100644
--- a/net-wireless/hostap-driver/hostap-driver-0.4.9.ebuild
+++ b/net-wireless/hostap-driver/hostap-driver-0.4.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/hostap-driver-0.4.9.ebuild,v 1.2 2006/06/26 22:09:46 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/hostap-driver-0.4.9.ebuild,v 1.3 2006/07/18 12:30:57 genstef Exp $
inherit toolchain-funcs eutils linux-mod
@@ -13,7 +13,8 @@ KEYWORDS="~amd64 ~ppc x86"
IUSE="pcmcia"
SLOT="0"
-RDEPEND=">=net-wireless/wireless-tools-25"
+RDEPEND=">=net-wireless/wireless-tools-25
+ pcmcia? ( virtual/pcmcia )"
BUILD_TARGETS="all"
MODULESD_HOSTAP_DOCS="README"
@@ -25,6 +26,34 @@ CONFIG_CHECK="!HOSTAP NET_RADIO"
ERROR_HOSTAP="${P} requires the in-kernel version of the hostap driver to be disabled (CONFIG_HOSTAP)"
ERROR_NET_RADIO="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_NET_RADIO)."
+pcmcia_src_unpack() {
+ local pcmcia_tbz="${ROOT}/usr/src/pcmcia-cs/pcmcia-cs-build-env.tbz2"
+ local PCMCIA_SOURCE_DIR="${WORKDIR}/pcmcia-cs/"
+
+ # if the kernel has pcmcia support built in, then we just ignore all this.
+ if linux_chkconfig_present PCMCIA; then
+ einfo "Kernel based PCMCIA support has been detected."
+ else
+ if kernel_is 2 6; then
+ einfo "We have detected that you are running a 2.6 kernel"
+ einfo "but you are not using the built-in PCMCIA support."
+ einfo "We will assume you know what you are doing, but please"
+ einfo "consider using the built in PCMCIA support instead."
+ epause 10
+ fi
+
+ ebegin "Decompressing pcmcia-cs sources"
+ mkdir -p ${PCMCIA_SOURCE_DIR}
+ tar -xjf ${pcmcia_tbz} -C ${PCMCIA_SOURCE_DIR}
+ eend $?
+
+ if [[ -f ${PCMCIA_SOURCE_DIR}/pcmcia-cs-version ]]; then
+ PCMCIA_VERSION=$(cat ${PCMCIA_SOURCE_DIR}/pcmcia-cs-version)
+ einfo "Found pcmcia-cs-${PCMCIA_VERSION}"
+ fi
+ fi
+}
+
pkg_setup() {
linux-mod_pkg_setup