summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-04-19 14:05:47 +0000
committerRick Farina <zerochaos@gentoo.org>2013-04-19 14:05:47 +0000
commit9f0850cc7e7023e192edc46a49521ce4fa5463e5 (patch)
tree873ee98c566884058210ef385a655893f2c874fc /net-wireless/airpwn
parentmigration -> distutils-r1 (diff)
downloadgentoo-2-9f0850cc7e7023e192edc46a49521ce4fa5463e5.tar.gz
gentoo-2-9f0850cc7e7023e192edc46a49521ce4fa5463e5.tar.bz2
gentoo-2-9f0850cc7e7023e192edc46a49521ce4fa5463e5.zip
initial commit of airpwn, import/cleanup from pentoo repo
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless/airpwn')
-rw-r--r--net-wireless/airpwn/ChangeLog9
-rw-r--r--net-wireless/airpwn/airpwn-1.4-r1.ebuild45
-rw-r--r--net-wireless/airpwn/metadata.xml11
3 files changed, 65 insertions, 0 deletions
diff --git a/net-wireless/airpwn/ChangeLog b/net-wireless/airpwn/ChangeLog
new file mode 100644
index 000000000000..f578ac074159
--- /dev/null
+++ b/net-wireless/airpwn/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-wireless/airpwn
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/airpwn/ChangeLog,v 1.1 2013/04/19 14:05:47 zerochaos Exp $
+
+*airpwn-1.4-r1 (19 Apr 2013)
+
+ 19 Apr 2013; Rick Farina <zerochaos@gentoo.org> +airpwn-1.4-r1.ebuild,
+ +metadata.xml:
+ initial commit of airpwn, import/cleanup from pentoo repo
diff --git a/net-wireless/airpwn/airpwn-1.4-r1.ebuild b/net-wireless/airpwn/airpwn-1.4-r1.ebuild
new file mode 100644
index 000000000000..a7669f5987a0
--- /dev/null
+++ b/net-wireless/airpwn/airpwn-1.4-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/airpwn/airpwn-1.4-r1.ebuild,v 1.1 2013/04/19 14:05:47 zerochaos Exp $
+
+EAPI="5"
+
+PYTHON_DEPEND="2:2.4"
+
+inherit python flag-o-matic
+
+DESCRIPTION="a tool for generic packet injection on 802.11"
+HOMEPAGE="http://airpwn.sf.net"
+SRC_URI="mirror://sourceforge/airpwn/$P.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+examples"
+
+DEPEND=""
+RDEPEND="net-wireless/lorcon-old
+ net-libs/libnet
+ dev-lang/python"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ append-ldflags $(no-as-needed)
+ econf
+ # this is a huge mess...
+ sed -i "s/python2.4/python$(python_get_version)/g" conf.h || die "sed failed"
+ sed -i "s|-lssl -lorcon -lpthread -lpcre -lpcap -lnet|-lssl -lorcon -lpthread -lpcre -lpcap -lnet -lpython$(python_get_version)|g" Makefile || die "sed failed"
+}
+
+src_install() {
+ DESTDIR="${D}" emake install
+ dodoc README
+ if use examples; then
+ docinto sample-configs
+ dodoc conf/*
+ fi
+}
diff --git a/net-wireless/airpwn/metadata.xml b/net-wireless/airpwn/metadata.xml
new file mode 100644
index 000000000000..5fcbf8e1851a
--- /dev/null
+++ b/net-wireless/airpwn/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+