summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2006-10-20 02:24:29 +0000
committerDaniel Drake <dsd@gentoo.org>2006-10-20 02:24:29 +0000
commit9c94735670dd9e27949a0816ec0b3c08a7999219 (patch)
treedc043eb75aa48a968cb9e77c15712febfa8eeafd /net-wireless/acx
parentAdded www-apps/issue-tracker per bug #134759 (diff)
downloadgentoo-2-9c94735670dd9e27949a0816ec0b3c08a7999219.tar.gz
gentoo-2-9c94735670dd9e27949a0816ec0b3c08a7999219.tar.bz2
gentoo-2-9c94735670dd9e27949a0816ec0b3c08a7999219.zip
Fix compilation on 2.6.18 thanks to Fabio Erculiani in bug #148521
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'net-wireless/acx')
-rw-r--r--net-wireless/acx/ChangeLog7
-rw-r--r--net-wireless/acx/acx-0.3.35.ebuild5
-rw-r--r--net-wireless/acx/acx-0.3.35_p20060521.ebuild6
-rw-r--r--net-wireless/acx/files/acx-0.3.35-2.6.18.patch14
-rw-r--r--net-wireless/acx/files/acx-0.3.35_p20060521-2.6.18.patch14
5 files changed, 43 insertions, 3 deletions
diff --git a/net-wireless/acx/ChangeLog b/net-wireless/acx/ChangeLog
index 4abb3cfc29a6..64c68ef6c201 100644
--- a/net-wireless/acx/ChangeLog
+++ b/net-wireless/acx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/acx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/ChangeLog,v 1.8 2006/08/07 20:22:59 spb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/ChangeLog,v 1.9 2006/10/20 02:24:29 dsd Exp $
+
+ 20 Oct 2006; Daniel Drake <dsd@gentoo.org> +files/acx-0.3.35-2.6.18.patch,
+ +files/acx-0.3.35_p20060521-2.6.18.patch, acx-0.3.35.ebuild,
+ acx-0.3.35_p20060521.ebuild:
+ Fix compilation on 2.6.18 thanks to Fabio Erculiani in bug #148521
*acx-0.3.35_p20060521 (07 Aug 2006)
diff --git a/net-wireless/acx/acx-0.3.35.ebuild b/net-wireless/acx/acx-0.3.35.ebuild
index 34f8c74ee56a..1aef06e32d39 100644
--- a/net-wireless/acx/acx-0.3.35.ebuild
+++ b/net-wireless/acx/acx-0.3.35.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/acx-0.3.35.ebuild,v 1.3 2006/05/24 22:06:03 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/acx-0.3.35.ebuild,v 1.4 2006/10/20 02:24:29 dsd Exp $
inherit linux-mod
@@ -31,6 +31,9 @@ src_unpack() {
unpack ${A}
chmod ug+w . -R
sed -i 's:usr/share/acx:lib/firmware:' common.c || die "sed failed"
+
+ # fix 2.6.18 compilation
+ epatch ${FILESDIR}/${P}-2.6.18.patch
}
src_install() {
diff --git a/net-wireless/acx/acx-0.3.35_p20060521.ebuild b/net-wireless/acx/acx-0.3.35_p20060521.ebuild
index 0ca28539e5ed..3b1f5b6c7d2a 100644
--- a/net-wireless/acx/acx-0.3.35_p20060521.ebuild
+++ b/net-wireless/acx/acx-0.3.35_p20060521.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/acx-0.3.35_p20060521.ebuild,v 1.1 2006/08/07 20:22:59 spb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/acx-0.3.35_p20060521.ebuild,v 1.2 2006/10/20 02:24:29 dsd Exp $
inherit linux-mod
@@ -37,6 +37,10 @@ src_unpack() {
if ! use debug; then
sed -i '/^#define ACX_DEBUG/s/2/0/' acx_config.h || die "Failed to disable debug support"
fi
+
+
+ # fix 2.6.18 compilation
+ epatch ${FILESDIR}/${P}-2.6.18.patch
}
src_install() {
diff --git a/net-wireless/acx/files/acx-0.3.35-2.6.18.patch b/net-wireless/acx/files/acx-0.3.35-2.6.18.patch
new file mode 100644
index 000000000000..472036b2c0eb
--- /dev/null
+++ b/net-wireless/acx/files/acx-0.3.35-2.6.18.patch
@@ -0,0 +1,14 @@
+Index: work/pci.c
+===================================================================
+--- work.orig/pci.c
++++ work/pci.c
+@@ -50,6 +50,9 @@
+ #include <linux/pci.h>
+ #include <linux/pm.h>
+ #include <linux/vmalloc.h>
++#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,17)
++#include <linux/utsrelease.h>
++#endif
+
+ #include "acx.h"
+
diff --git a/net-wireless/acx/files/acx-0.3.35_p20060521-2.6.18.patch b/net-wireless/acx/files/acx-0.3.35_p20060521-2.6.18.patch
new file mode 100644
index 000000000000..922e74d26ff6
--- /dev/null
+++ b/net-wireless/acx/files/acx-0.3.35_p20060521-2.6.18.patch
@@ -0,0 +1,14 @@
+Index: work/pci.c
+===================================================================
+--- work.orig/pci.c
++++ work/pci.c
+@@ -51,6 +51,9 @@
+ #include <linux/pm.h>
+ #include <linux/vmalloc.h>
+ #include <linux/dma-mapping.h>
++#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,17)
++#include <linux/utsrelease.h>
++#endif
+
+ #include "acx.h"
+