summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-12-30 07:17:35 +0000
committerOlivier Crête <tester@gentoo.org>2008-12-30 07:17:35 +0000
commitd5997af5d67295a9730e576e643952fd9935a3f9 (patch)
tree524f32c6b213204b6c8200b63c92c3040eac140b /net-voip
parentBug #244450: Add patch from zmedico to fix portage deprecation warnings. Remo... (diff)
downloadgentoo-2-d5997af5d67295a9730e576e643952fd9935a3f9.tar.gz
gentoo-2-d5997af5d67295a9730e576e643952fd9935a3f9.tar.bz2
gentoo-2-d5997af5d67295a9730e576e643952fd9935a3f9.zip
Version bump
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r7 i686)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/telepathy-gabble/ChangeLog8
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.7.17.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/net-voip/telepathy-gabble/ChangeLog b/net-voip/telepathy-gabble/ChangeLog
index 7e365d1c8527..1a5d1f776841 100644
--- a/net-voip/telepathy-gabble/ChangeLog
+++ b/net-voip/telepathy-gabble/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-voip/telepathy-gabble
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.41 2008/12/24 10:05:19 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.42 2008/12/30 07:17:35 tester Exp $
+
+*telepathy-gabble-0.7.17 (30 Dec 2008)
+
+ 30 Dec 2008; Olivier Crête <tester@gentoo.org>
+ +telepathy-gabble-0.7.17.ebuild:
+ Version bump
24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
telepathy-gabble-0.7.16.ebuild:
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.7.17.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.7.17.ebuild
new file mode 100644
index 000000000000..7c78247f9b90
--- /dev/null
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.7.17.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.7.17.ebuild,v 1.1 2008/12/30 07:17:35 tester Exp $
+
+inherit eutils
+
+DESCRIPTION="A Jabber/XMPP connection manager, this handles single and multi user chats and voice calls."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE="debug test"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.78
+ >=net-libs/telepathy-glib-0.7.18
+ >=net-libs/loudmouth-1.3.2"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-lang/python
+ test? ( dev-python/twisted
+ dev-python/twisted-words )"
+
+pkg_setup() {
+ if ! built_with_use -o net-libs/loudmouth ssl gnutls ; then
+ eerror "${PN} needs net-libs/loudmouth built with"
+ eerror "USE='gnutls' or USE='ssl'."
+ die "No TLS support in net-libs/loudmouth"
+ fi
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable debug handle-leak-debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ emake -j1 check || die "Make check failed. See above for details."
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS NEWS ChangeLog
+}