summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-08-05 23:35:55 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-08-05 23:35:55 +0000
commitd0d21e74c01ca6e9b7a18bcd03868fbd0447f316 (patch)
tree05ac05d179aef9cfdb1867f36a8178acdaa2c397 /net-voip
parentRemove old (diff)
downloadgentoo-2-d0d21e74c01ca6e9b7a18bcd03868fbd0447f316.tar.gz
gentoo-2-d0d21e74c01ca6e9b7a18bcd03868fbd0447f316.tar.bz2
gentoo-2-d0d21e74c01ca6e9b7a18bcd03868fbd0447f316.zip
Version bump.Fix a bunch of crashers and bug with un/subscription.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/telepathy-gabble/ChangeLog8
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.7.31.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/net-voip/telepathy-gabble/ChangeLog b/net-voip/telepathy-gabble/ChangeLog
index 5da66d69ab5e..71563e6e139f 100644
--- a/net-voip/telepathy-gabble/ChangeLog
+++ b/net-voip/telepathy-gabble/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-voip/telepathy-gabble
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.47 2009/07/20 15:17:05 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.48 2009/08/05 23:35:55 eva Exp $
+
+*telepathy-gabble-0.7.31 (05 Aug 2009)
+
+ 05 Aug 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +telepathy-gabble-0.7.31.ebuild:
+ Version bump.Fix a bunch of crashers and bug with un/subscription.
*telepathy-gabble-0.7.30 (20 Jul 2009)
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.7.31.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.7.31.ebuild
new file mode 100644
index 000000000000..d7f738bfb41d
--- /dev/null
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.7.31.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.7.31.ebuild,v 1.1 2009/08/05 23:35:55 eva Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A Jabber/XMPP connection manager, this handles single and multi user chats and voice calls."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE="debug test"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.78
+ >=net-libs/telepathy-glib-0.7.31
+ >=net-libs/loudmouth-1.3.2[ssl]"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-lang/python-2.5
+ test? ( dev-python/twisted
+ dev-python/twisted-words
+ >=dev-python/dbus-python-0.83 )"
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable debug handle-leak-debug)
+}
+
+src_test() {
+ emake -j1 check || die "Make check failed. See above for details."
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS NEWS ChangeLog README || die "dodoc failed"
+}