summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-08-20 20:22:42 +0000
committerMike Frysinger <vapier@gentoo.org>2007-08-20 20:22:42 +0000
commita4661e4084abffa70a5fb5b310196e968a685429 (patch)
tree9b9568c12e2de49eb8667f3dffe6deb50248dbcf /net-voip
parentFix compile warnings; bug #188963 (diff)
downloadgentoo-2-a4661e4084abffa70a5fb5b310196e968a685429.tar.gz
gentoo-2-a4661e4084abffa70a5fb5b310196e968a685429.tar.bz2
gentoo-2-a4661e4084abffa70a5fb5b310196e968a685429.zip
Remove autotool garbage, dont force gtk interface on everyone (USE=gtk), cleanup configure options, add support for USE=arts, and add some notes about oRTP/ffmpeg.
(Portage version: 2.1.3.6)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/linphone/ChangeLog11
-rw-r--r--net-voip/linphone/files/digest-linphone-1.7.1-r13
-rw-r--r--net-voip/linphone/linphone-1.7.1-r1.ebuild80
3 files changed, 92 insertions, 2 deletions
diff --git a/net-voip/linphone/ChangeLog b/net-voip/linphone/ChangeLog
index 1f1596193e85..2b8476f2ef9e 100644
--- a/net-voip/linphone/ChangeLog
+++ b/net-voip/linphone/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-voip/linphone
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/ChangeLog,v 1.3 2007/04/25 09:02:48 genstef Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/ChangeLog,v 1.4 2007/08/20 20:22:42 vapier Exp $
+
+*linphone-1.7.1-r1 (20 Aug 2007)
+
+ 20 Aug 2007; Mike Frysinger <vapier@gentoo.org> +linphone-1.7.1-r1.ebuild:
+ Remove autotool garbage, dont force gtk interface on everyone (USE=gtk),
+ cleanup configure options, add support for USE=arts, and add some notes
+ about oRTP/ffmpeg.
*linphone-1.7.1 (25 Apr 2007)
diff --git a/net-voip/linphone/files/digest-linphone-1.7.1-r1 b/net-voip/linphone/files/digest-linphone-1.7.1-r1
new file mode 100644
index 000000000000..fb5baadcbc6e
--- /dev/null
+++ b/net-voip/linphone/files/digest-linphone-1.7.1-r1
@@ -0,0 +1,3 @@
+MD5 6fe246d072fad2f4a9533317ab7e9060 linphone-1.7.1.tar.gz 7537415
+RMD160 da5959e3b79c0eeb48b72481b1390e98e7cdadfd linphone-1.7.1.tar.gz 7537415
+SHA256 3a3c606e2313f9871f07e41dfbeb87f6edb404f7927f7737fc22ab1a59a59e48 linphone-1.7.1.tar.gz 7537415
diff --git a/net-voip/linphone/linphone-1.7.1-r1.ebuild b/net-voip/linphone/linphone-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..301914dddb07
--- /dev/null
+++ b/net-voip/linphone/linphone-1.7.1-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/linphone-1.7.1-r1.ebuild,v 1.1 2007/08/20 20:22:42 vapier Exp $
+
+# Note: video support in linphone relies on swscaler being disabled
+# in ffmpeg. this is because the video code in linphone is old
+# and uses the old interface. solution: fix linphone's video
+# code. workaround: build ffmpeg w/out --enable-swscaler.
+
+inherit eutils
+
+MY_DPV="${PV%.*}.x"
+
+DESCRIPTION="Voice Over IP phone (internet phone which uses SIP)"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="http://download.savannah.nongnu.org/releases/${PN}/${MY_DPV}/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa arts console gtk ilbc ipv6 novideo xv"
+
+DEPEND="dev-libs/glib
+ dev-perl/XML-Parser
+ net-dns/bind-tools
+ >=net-libs/libosip-2.2.0
+ >=media-libs/speex-1.1.12
+ x86? ( xv? ( dev-lang/nasm ) )
+ gtk? (
+ >=x11-libs/gtk+-2
+ gnome-base/libglade
+ )
+ alsa? ( media-libs/alsa-lib )
+ arts? ( kde-base/arts )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ !novideo? (
+ >=media-libs/libsdl-1.2.9
+ media-video/ffmpeg
+ >=media-libs/libtheora-1.0_alpha7
+ )"
+# use the bundled ortp until newer versions leave package.mask
+# >=net-libs/ortp-0.9.0
+# portaudio? ( >=media-libs/portaudio-19_pre )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/linphone-1.6.0-call.patch
+ sed -i -e 's:wall_werror=yes:wall_werror=no:' mediastreamer2/configure
+}
+
+src_compile() {
+ econf \
+ --libdir=/usr/$(get_libdir)/linphone \
+ $(use_enable console console_ui) \
+ $(use_enable gtk gtk_ui) \
+ $(use_with ilbc) \
+ $(use_enable ipv6) \
+ $(use_enable alsa) \
+ $(use_enable arts artsc) \
+ $(use_enable !novideo video) \
+ --disable-portaudio \
+ $(use_enable x86 truespeech) \
+ || die "Unable to configure"
+ #--enable-external-ortp \
+ #$(use_enable portaudio)
+ emake || die "Unable to make"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README README.arm TODO
+
+ # don't install ortp includes, docs and pkgconfig files
+ # to avoid conflicts with net-libs/ortp
+ rm -rf "${D}"/usr/include/ortp
+ rm -rf "${D}"/usr/share/gtk-doc/html/ortp
+ rm -rf "${D}"/usr/$(get_libdir)/linphone/pkgconfig
+ rm -rf "${D}"/ortp
+}