summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-11-03 21:18:56 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-11-03 21:18:56 +0000
commit88e98e6c60debace5d57801415d91f4454ffd880 (patch)
treef8e22e4f094e4ef1f2261614ee696d102c762cce /net-voip/telepathy-sofiasip
parentVersion bump. (diff)
downloadgentoo-2-88e98e6c60debace5d57801415d91f4454ffd880.tar.gz
gentoo-2-88e98e6c60debace5d57801415d91f4454ffd880.tar.bz2
gentoo-2-88e98e6c60debace5d57801415d91f4454ffd880.zip
Don't let USE=debug control --enable-debug - this is only enables conditionally enabled code to get debugging output (which upstream needs to actually debug any issues remotely).
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'net-voip/telepathy-sofiasip')
-rw-r--r--net-voip/telepathy-sofiasip/ChangeLog10
-rw-r--r--net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.4-r1.ebuild30
2 files changed, 39 insertions, 1 deletions
diff --git a/net-voip/telepathy-sofiasip/ChangeLog b/net-voip/telepathy-sofiasip/ChangeLog
index ebfc70c488f0..5c788f239aee 100644
--- a/net-voip/telepathy-sofiasip/ChangeLog
+++ b/net-voip/telepathy-sofiasip/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-voip/telepathy-sofiasip
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-sofiasip/ChangeLog,v 1.17 2010/09/29 18:52:11 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-sofiasip/ChangeLog,v 1.18 2010/11/03 21:18:56 ford_prefect Exp $
+
+*telepathy-sofiasip-0.6.4-r1 (03 Nov 2010)
+
+ 03 Nov 2010; Arun Raghavan <ford_prefect@gentoo.org>
+ +telepathy-sofiasip-0.6.4-r1.ebuild:
+ Don't let USE=debug control --enable-debug - this is only enables
+ conditionally enabled code to get debugging output (which upstream needs
+ to actually debug any issues remotely).
*telepathy-sofiasip-0.6.4 (29 Sep 2010)
diff --git a/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.4-r1.ebuild b/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..527bfc223ce2
--- /dev/null
+++ b/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.4-r1.ebuild,v 1.1 2010/11/03 21:18:56 ford_prefect Exp $
+
+EAPI="2"
+
+DESCRIPTION="A SIP connection manager for Telepathy based around the Sofia-SIP library."
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=">=net-libs/sofia-sip-1.12.10
+ >=net-libs/telepathy-glib-0.8.0
+ >=dev-libs/glib-2.16
+ sys-apps/dbus
+ dev-libs/dbus-glib"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-lang/python
+ test? ( dev-python/twisted )"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+}