summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-05-30 19:08:15 +0000
committerPacho Ramos <pacho@gentoo.org>2013-05-30 19:08:15 +0000
commit8c30ed74975499acf7956ed264a1669f2b7978d6 (patch)
treed89daaa5e88b8c747dac278ebb6377b99a515179 /net-voip/telepathy-gabble
parentVersion bump, drop ree18. (diff)
downloadgentoo-2-8c30ed74975499acf7956ed264a1669f2b7978d6.tar.gz
gentoo-2-8c30ed74975499acf7956ed264a1669f2b7978d6.tar.bz2
gentoo-2-8c30ed74975499acf7956ed264a1669f2b7978d6.zip
Version bump, drop shebangs conversion because functions starting by _ are meant to be internal and python-any-r1.eclass users shouldn't need it (and looks to not be needed in this case), if needs to be readded and _ function is used, please add a comment explaining the issue.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-voip/telepathy-gabble')
-rw-r--r--net-voip/telepathy-gabble/ChangeLog10
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.16.6.ebuild71
2 files changed, 80 insertions, 1 deletions
diff --git a/net-voip/telepathy-gabble/ChangeLog b/net-voip/telepathy-gabble/ChangeLog
index bf5338803bc1..0473d399fbbc 100644
--- a/net-voip/telepathy-gabble/ChangeLog
+++ b/net-voip/telepathy-gabble/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-voip/telepathy-gabble
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.115 2013/05/10 22:07:47 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.116 2013/05/30 19:08:15 pacho Exp $
+
+*telepathy-gabble-0.16.6 (30 May 2013)
+
+ 30 May 2013; Pacho Ramos <pacho@gentoo.org> +telepathy-gabble-0.16.6.ebuild:
+ Version bump, drop shebangs conversion because functions starting by _ are
+ meant to be internal and python-any-r1.eclass users shouldn't need it (and
+ looks to not be needed in this case), if needs to be readded and _ function is
+ used, please add a comment explaining the issue.
10 May 2013; Gilles Dartiguelongue <eva@gentoo.org>
-telepathy-gabble-0.16.1.ebuild, telepathy-gabble-0.16.4.ebuild:
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.16.6.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.16.6.ebuild
new file mode 100644
index 000000000000..78d248162255
--- /dev/null
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.16.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.16.6.ebuild,v 1.1 2013/05/30 19:08:15 pacho Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+inherit eutils python-any-r1
+
+DESCRIPTION="A Jabber/XMPP connection manager, with handling of single and multi user chats and voice calls"
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="gnutls +jingle test"
+
+# FIXME: missing sasl-2 for tests ? (automagic)
+# missing libiphb for wocky ?
+RDEPEND="
+ >=dev-libs/glib-2.30:2
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.82
+ >=net-libs/telepathy-glib-0.18
+
+ dev-db/sqlite:3
+ dev-libs/libxml2
+
+ gnutls? ( >=net-libs/gnutls-2.10.2 )
+ !gnutls? ( >=dev-libs/openssl-0.9.8g[-bindist] )
+ jingle? ( || ( net-libs/libsoup:2.4[ssl]
+ >=net-libs/libsoup-2.33.1 )
+ >=net-libs/libnice-0.0.11 )
+
+ !<net-im/telepathy-mission-control-5.5.0
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/gtk-doc-am-1.17
+ dev-libs/libxslt
+ test? ( >=dev-python/twisted-0.8.2
+ >=dev-python/twisted-words-0.8.2
+ >=dev-python/dbus-python-0.83 )
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --disable-coding-style-checks \
+ --disable-static \
+ --disable-Werror \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --enable-file-transfer \
+ $(use_enable jingle voip) \
+ $(use_enable jingle google-relay) \
+ --with-tls=$(usex gnutls gnutls openssl)
+}
+
+src_test() {
+ # Twisted tests fail, upstream bug #30565
+ emake -C tests check-TESTS
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}