summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2015-05-15 09:34:25 +0000
committerChristian Ruppert <idl0r@gentoo.org>2015-05-15 09:34:25 +0000
commitf4cb790107cb34c06e4994639bf9d4d9cb17d69b (patch)
tree532abf889b4bea2b3a7b2a0c82fb3d2404276b5e /net-proxy
parentdocument the patch (diff)
downloadgentoo-2-f4cb790107cb34c06e4994639bf9d4d9cb17d69b.tar.gz
gentoo-2-f4cb790107cb34c06e4994639bf9d4d9cb17d69b.tar.bz2
gentoo-2-f4cb790107cb34c06e4994639bf9d4d9cb17d69b.zip
Version bumps, bug 549316. Cleanup.
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/ChangeLog9
-rw-r--r--net-proxy/haproxy/haproxy-1.4.26.ebuild89
-rw-r--r--net-proxy/haproxy/haproxy-1.5.12.ebuild (renamed from net-proxy/haproxy/haproxy-1.5.10.ebuild)4
-rw-r--r--net-proxy/haproxy/haproxy-9999.ebuild6
4 files changed, 102 insertions, 6 deletions
diff --git a/net-proxy/haproxy/ChangeLog b/net-proxy/haproxy/ChangeLog
index 46f275082365..df2e6ef2689e 100644
--- a/net-proxy/haproxy/ChangeLog
+++ b/net-proxy/haproxy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-proxy/haproxy
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.114 2015/02/07 14:59:03 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.115 2015/05/15 09:34:25 idl0r Exp $
+
+*haproxy-1.5.12 (15 May 2015)
+*haproxy-1.4.26 (15 May 2015)
+
+ 15 May 2015; <c.ruppert@gentoo.org> +haproxy-1.4.26.ebuild,
+ -haproxy-1.5.10.ebuild, +haproxy-1.5.12.ebuild, haproxy-9999.ebuild:
+ Version bumps, bug 549316. Cleanup.
*haproxy-1.5.11 (07 Feb 2015)
diff --git a/net-proxy/haproxy/haproxy-1.4.26.ebuild b/net-proxy/haproxy/haproxy-1.4.26.ebuild
new file mode 100644
index 000000000000..85092cb4d152
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.4.26.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.4.26.ebuild,v 1.1 2015/05/15 09:34:25 idl0r Exp $
+
+EAPI="5"
+
+inherit user versionator toolchain-funcs flag-o-matic
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+crypt examples +pcre vim-syntax"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+}
+
+src_compile() {
+ local args="TARGET=linux2628"
+
+ if use pcre; then
+ args="${args} USE_PCRE=1"
+ else
+ args="${args} USE_PCRE="
+ fi
+
+# if use kernel_linux; then
+# args="${args} USE_LINUX_SPLICE=1 USE_LINUX_TPROXY=1"
+# else
+# args="${args} USE_LINUX_SPLICE= USE_LINUX_TPROXY="
+# fi
+
+ if use crypt; then
+ args="${args} USE_LIBCRYPT=1"
+ else
+ args="${args} USE_LIBCRYPT="
+ fi
+
+ # For now, until the strict-aliasing breakage will be fixed
+# append-cflags -fno-strict-aliasing
+
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args} || die
+}
+
+src_install() {
+ dobin haproxy || die
+
+ newinitd "${FILESDIR}/haproxy.initd-r2" haproxy || die
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP doc/{configuration,haproxy-en}.txt
+ doman doc/haproxy.1
+
+ if use examples;
+ then
+ docinto examples
+ dodoc examples/*.cfg || die
+ fi
+
+ if use vim-syntax;
+ then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/haproxy.vim || die
+ fi
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}
diff --git a/net-proxy/haproxy/haproxy-1.5.10.ebuild b/net-proxy/haproxy/haproxy-1.5.12.ebuild
index bc517953cffe..e7340914048c 100644
--- a/net-proxy/haproxy/haproxy-1.5.10.ebuild
+++ b/net-proxy/haproxy/haproxy-1.5.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.5.10.ebuild,v 1.1 2015/01/12 22:12:09 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.5.12.ebuild,v 1.1 2015/05/15 09:34:25 idl0r Exp $
EAPI="5"
@@ -20,7 +20,7 @@ IUSE="+crypt examples +pcre pcre-jit ssl tools vim-syntax +zlib"
DEPEND="pcre? ( dev-libs/libpcre
pcre-jit? ( dev-libs/libpcre[jit] )
)
- ssl? ( dev-libs/openssl[zlib?] )
+ ssl? ( dev-libs/openssl:0[zlib?] )
zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}"
diff --git a/net-proxy/haproxy/haproxy-9999.ebuild b/net-proxy/haproxy/haproxy-9999.ebuild
index 6b9b8540e8b1..786257daf043 100644
--- a/net-proxy/haproxy/haproxy-9999.ebuild
+++ b/net-proxy/haproxy/haproxy-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-9999.ebuild,v 1.3 2014/10/30 21:37:30 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-9999.ebuild,v 1.4 2015/05/15 09:34:25 idl0r Exp $
EAPI="5"
@@ -20,7 +20,7 @@ IUSE="+crypt examples +pcre pcre-jit ssl tools vim-syntax +zlib"
DEPEND="pcre? ( dev-libs/libpcre
pcre-jit? ( dev-libs/libpcre[jit] )
)
- ssl? ( dev-libs/openssl[zlib?] )
+ ssl? ( dev-libs/openssl:0[zlib?] )
zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}"