summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-08 18:41:25 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-08 18:41:25 +0000
commitf117a8a7970ae2e2336c5f2dff45a2a72d117b91 (patch)
treec8e615f8bafe2c44e3a1cb146a4852778b47b6f4 /net-proxy
parentMask wifi and crashreporter also on www-client/firefox (diff)
downloadgentoo-2-f117a8a7970ae2e2336c5f2dff45a2a72d117b91.tar.gz
gentoo-2-f117a8a7970ae2e2336c5f2dff45a2a72d117b91.tar.bz2
gentoo-2-f117a8a7970ae2e2336c5f2dff45a2a72d117b91.zip
Patch to suppress warning messages about symbols not found in shared library
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/torsocks/ChangeLog6
-rw-r--r--net-proxy/torsocks/files/suppress-warning-msgs.patch15
-rw-r--r--net-proxy/torsocks/torsocks-1.2-r2.ebuild41
3 files changed, 62 insertions, 0 deletions
diff --git a/net-proxy/torsocks/ChangeLog b/net-proxy/torsocks/ChangeLog
index 1a8290a24d3c..5c8028add9b7 100644
--- a/net-proxy/torsocks/ChangeLog
+++ b/net-proxy/torsocks/ChangeLog
@@ -1,5 +1,11 @@
+*torsocks-1.2-r2 (08 Mar 2012)
+
+ 08 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +torsocks-1.2-r2.ebuild,
+ +files/suppress-false-error-msgs.patch:
+ Patch to suppress warning messages about symbols not found in shared library
+
27 Dec 2011; Anthony G. Basile <blueness@gentoo.org> torsocks-1.2-r1.ebuild:
Added README TODO INSTALL ChangeLog to docs
diff --git a/net-proxy/torsocks/files/suppress-warning-msgs.patch b/net-proxy/torsocks/files/suppress-warning-msgs.patch
new file mode 100644
index 000000000000..7470b9fa7f4b
--- /dev/null
+++ b/net-proxy/torsocks/files/suppress-warning-msgs.patch
@@ -0,0 +1,15 @@
+--- torsocks-1.2.orig/src/torsocks.c 2011-10-25 17:49:50.000000000 -0400
++++ torsocks-1.2/src/torsocks.c 2012-02-21 11:09:20.000000000 -0500
+@@ -124,9 +124,9 @@
+ #define LOAD_ERROR(s,l) { \
+ const char *error; \
+ error = dlerror(); \
+- show_msg(l, "The symbol %s() was not found in any shared " \
+- "library. The error reported was: %s!\n", s, \
+- (error)?error:"not found"); \
++ if (error) \
++ show_msg(l, "The symbol %s() was not found in any shared " \
++ "library. The error reported was: %s!\n", s, error); \
+ dlerror(); \
+ }
+ pthread_mutex_lock(&torsocks_init_mutex);
diff --git a/net-proxy/torsocks/torsocks-1.2-r2.ebuild b/net-proxy/torsocks/torsocks-1.2-r2.ebuild
new file mode 100644
index 000000000000..c9e213d9edde
--- /dev/null
+++ b/net-proxy/torsocks/torsocks-1.2-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/torsocks/torsocks-1.2-r2.ebuild,v 1.1 2012/03/08 18:41:25 blueness Exp $
+
+EAPI="4"
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Use most socks-friendly applications with Tor."
+HOMEPAGE="http://code.google.com/p/torsocks"
+SRC_URI="http://${PN}.googlecode.com/files/${PN}-1.2.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+# We do not depend on tor which might be running on a different box
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/suppress-warning-msgs.patch
+ epatch "${FILESDIR}"/fix-docdir.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF} \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc README TODO INSTALL ChangeLog
+
+ #Remove libtool .la files
+ cd "${D}"/usr/$(get_libdir)/torsocks
+ rm -f *.la
+}