summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-08-18 03:08:27 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-08-18 03:08:27 +0000
commitbee63249ab281c8428b26f99ef38b51f3b62f256 (patch)
tree49e3179a8b0b9ef8e784ffd3abcef5a6d91f3a2f /net-proxy
parentVersion bump. Don't install sqlite3 and _sqlite3 modules with USE="-sqlite" (... (diff)
downloadgentoo-2-bee63249ab281c8428b26f99ef38b51f3b62f256.tar.gz
gentoo-2-bee63249ab281c8428b26f99ef38b51f3b62f256.tar.bz2
gentoo-2-bee63249ab281c8428b26f99ef38b51f3b62f256.zip
Enable support for the Linux kernel splice() feature to massively boost some performance (being used for forums.g.o).
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/ChangeLog9
-rw-r--r--net-proxy/haproxy/haproxy-1.3.20-r1.ebuild56
2 files changed, 64 insertions, 1 deletions
diff --git a/net-proxy/haproxy/ChangeLog b/net-proxy/haproxy/ChangeLog
index b35f5d446608..d3d2ce822a2e 100644
--- a/net-proxy/haproxy/ChangeLog
+++ b/net-proxy/haproxy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-proxy/haproxy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.30 2009/08/15 22:59:49 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.31 2009/08/18 03:08:27 robbat2 Exp $
+
+*haproxy-1.3.20-r1 (18 Aug 2009)
+
+ 18 Aug 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +haproxy-1.3.20-r1.ebuild:
+ Enable support for the Linux kernel splice() feature to massively boost
+ some performance (being used for forums.g.o).
*haproxy-1.3.20 (15 Aug 2009)
diff --git a/net-proxy/haproxy/haproxy-1.3.20-r1.ebuild b/net-proxy/haproxy/haproxy-1.3.20-r1.ebuild
new file mode 100644
index 000000000000..f44b12e7e89b
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.3.20-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.20-r1.ebuild,v 1.1 2009/08/18 03:08:27 robbat2 Exp $
+
+inherit versionator eutils
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+}
+
+src_compile() {
+ local ARGS="TARGET=linux26"
+ use pcre && ARGS="${ARGS} USE_PCRE=1"
+ use kernel_linux && ARGS="${ARGS} USE_LINUX_SPLICE=1"
+ emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${ARGS}
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe haproxy
+ newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/*.txt
+ docinto examples
+ dodoc examples/*.cfg
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}