summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-04-11 12:56:08 +0000
committerAlin Năstac <mrness@gentoo.org>2007-04-11 12:56:08 +0000
commita4851ca796e5e7e260a783c6137df5bb5f0390a6 (patch)
treeed4f0fc5338c2cac3e93e149957d8da5058cfee3 /net-proxy
parentStable on amd64 wrt bug 172575 (diff)
downloadgentoo-2-a4851ca796e5e7e260a783c6137df5bb5f0390a6.tar.gz
gentoo-2-a4851ca796e5e7e260a783c6137df5bb5f0390a6.tar.bz2
gentoo-2-a4851ca796e5e7e260a783c6137df5bb5f0390a6.zip
Use correct printf format for pointers. Keep /var/cache/polipo directory. Stable on amd64.
(Portage version: 2.1.2.3)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/polipo/ChangeLog10
-rw-r--r--net-proxy/polipo/files/digest-polipo-0.9.12-r1 (renamed from net-proxy/polipo/files/digest-polipo-0.9.12)0
-rw-r--r--net-proxy/polipo/files/polipo-0.9.12-printf-ptr.patch161
-rw-r--r--net-proxy/polipo/polipo-0.9.12-r1.ebuild (renamed from net-proxy/polipo/polipo-0.9.12.ebuild)7
4 files changed, 174 insertions, 4 deletions
diff --git a/net-proxy/polipo/ChangeLog b/net-proxy/polipo/ChangeLog
index e2ff3f01520d..125c74ecda47 100644
--- a/net-proxy/polipo/ChangeLog
+++ b/net-proxy/polipo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-proxy/polipo
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/polipo/ChangeLog,v 1.13 2007/02/12 11:13:22 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/polipo/ChangeLog,v 1.14 2007/04/11 12:56:08 mrness Exp $
+
+*polipo-0.9.12-r1 (11 Apr 2007)
+
+ 11 Apr 2007; Alin Năstac <mrness@gentoo.org>
+ +files/polipo-0.9.12-printf-ptr.patch, -polipo-0.9.12.ebuild,
+ +polipo-0.9.12-r1.ebuild:
+ Use correct printf format for pointers. Keep /var/cache/polipo directory.
+ Stable on amd64.
12 Feb 2007; Alin Nastac <mrness@gentoo.org> files/polipo.initd:
Check configuration at service startup.
diff --git a/net-proxy/polipo/files/digest-polipo-0.9.12 b/net-proxy/polipo/files/digest-polipo-0.9.12-r1
index 45f975f7d814..45f975f7d814 100644
--- a/net-proxy/polipo/files/digest-polipo-0.9.12
+++ b/net-proxy/polipo/files/digest-polipo-0.9.12-r1
diff --git a/net-proxy/polipo/files/polipo-0.9.12-printf-ptr.patch b/net-proxy/polipo/files/polipo-0.9.12-printf-ptr.patch
new file mode 100644
index 000000000000..bf7a582afa5a
--- /dev/null
+++ b/net-proxy/polipo/files/polipo-0.9.12-printf-ptr.patch
@@ -0,0 +1,161 @@
+diff -Nru polipo-0.9.12.orig/atom.c polipo-0.9.12/atom.c
+--- polipo-0.9.12.orig/atom.c 2007-02-06 23:17:39.000000000 +0200
++++ polipo-0.9.12/atom.c 2007-04-11 15:42:05.000000000 +0300
+@@ -72,7 +72,7 @@
+ atomHashTable[h] = atom;
+ used_atoms++;
+ }
+- do_log(D_ATOM_REFCOUNT, "A 0x%x %d++\n", (unsigned)atom, atom->refcount);
++ do_log(D_ATOM_REFCOUNT, "A %p %d++\n", atom, atom->refcount);
+ atom->refcount++;
+ return atom;
+ }
+@@ -132,7 +132,7 @@
+ if(atom == NULL)
+ return NULL;
+
+- do_log(D_ATOM_REFCOUNT, "A 0x%x %d++\n", (unsigned)atom, atom->refcount);
++ do_log(D_ATOM_REFCOUNT, "A %p %d++\n", atom, atom->refcount);
+ assert(atom->refcount >= 1 && atom->refcount < 50000);
+ atom->refcount++;
+ return atom;
+@@ -144,7 +144,7 @@
+ if(atom == NULL)
+ return;
+
+- do_log(D_ATOM_REFCOUNT, "A 0x%x %d--\n", (unsigned)atom, atom->refcount);
++ do_log(D_ATOM_REFCOUNT, "A %p %d--\n", atom, atom->refcount);
+ assert(atom->refcount >= 1 && atom->refcount < 50000);
+
+ atom->refcount--;
+diff -Nru polipo-0.9.12.orig/client.c polipo-0.9.12/client.c
+--- polipo-0.9.12.orig/client.c 2007-02-06 23:17:39.000000000 +0200
++++ polipo-0.9.12/client.c 2007-04-11 15:46:42.000000000 +0300
+@@ -105,8 +105,8 @@
+ connection->fd = fd;
+ connection->timeout = timeout;
+
+- do_log(D_CLIENT_CONN, "Accepted client connection 0x%x\n",
+- (unsigned)connection);
++ do_log(D_CLIENT_CONN, "Accepted client connection %p\n",
++ connection);
+
+ connection->flags = CONN_READER;
+
+@@ -236,8 +236,8 @@
+ return;
+ }
+
+- do_log(D_CLIENT_CONN, "Closing client connection 0x%x\n",
+- (unsigned)connection);
++ do_log(D_CLIENT_CONN, "Closing client connection %p\n",
++ connection);
+
+ if(connection->flags & CONN_READER) {
+ httpSetTimeout(connection, 10);
+@@ -1714,8 +1714,8 @@
+
+ connection->offset = request->from;
+ httpSetTimeout(connection, 120);
+- do_log(D_CLIENT_DATA, "Serving on 0x%x for 0x%x: offset %d len %d\n",
+- (unsigned)connection, (unsigned)object,
++ do_log(D_CLIENT_DATA, "Serving on %p for %p: offset %d len %d\n",
++ connection, object,
+ connection->offset, len);
+ do_stream_h(IO_WRITE |
+ (connection->te == TE_CHUNKED && len > 0 ? IO_CHUNKED : 0),
+@@ -1894,8 +1894,8 @@
+ if(len2 == 0) {
+ httpSetTimeout(connection, 120);
+ do_log(D_CLIENT_DATA,
+- "Serving on 0x%x for 0x%x: offset %d len %d\n",
+- (unsigned)connection, (unsigned)object,
++ "Serving on %p for %p: offset %d len %d\n",
++ connection, object,
+ connection->offset, len);
+ /* IO_NOTNOW in order to give other clients a chance to run. */
+ do_stream(IO_WRITE | IO_NOTNOW |
+@@ -1907,8 +1907,8 @@
+ } else {
+ httpSetTimeout(connection, 120);
+ do_log(D_CLIENT_DATA,
+- "Serving on 0x%x for 0x%x: offset %d len %d + %d\n",
+- (unsigned)connection, (unsigned)object,
++ "Serving on %p for %p: offset %d len %d + %d\n",
++ connection, object,
+ connection->offset, len, len2);
+ do_stream_2(IO_WRITE | IO_NOTNOW |
+ (connection->te == TE_CHUNKED ? IO_CHUNKED : 0) |
+diff -Nru polipo-0.9.12.orig/http.c polipo-0.9.12/http.c
+--- polipo-0.9.12.orig/http.c 2007-02-06 23:17:39.000000000 +0200
++++ polipo-0.9.12/http.c 2007-04-11 15:44:58.000000000 +0300
+@@ -199,8 +199,8 @@
+ new = scheduleTimeEvent(secs, httpTimeoutHandler,
+ sizeof(connection), &connection);
+ if(!new) {
+- do_log(L_ERROR, "Couldn't schedule timeout for connection 0x%x\n",
+- (unsigned)connection);
++ do_log(L_ERROR, "Couldn't schedule timeout for connection %p\n",
++ connection);
+ return -1;
+ }
+ } else {
+diff -Nru polipo-0.9.12.orig/object.c polipo-0.9.12/object.c
+--- polipo-0.9.12.orig/object.c 2007-02-06 23:17:39.000000000 +0200
++++ polipo-0.9.12/object.c 2007-04-11 15:44:18.000000000 +0300
+@@ -268,7 +268,7 @@
+ ObjectPtr
+ retainObject(ObjectPtr object)
+ {
+- do_log(D_REFCOUNT, "O 0x%x %d++\n", (unsigned)object, object->refcount);
++ do_log(D_REFCOUNT, "O %p %d++\n", object, object->refcount);
+ object->refcount++;
+ return object;
+ }
+@@ -276,7 +276,7 @@
+ void
+ releaseObject(ObjectPtr object)
+ {
+- do_log(D_REFCOUNT, "O 0x%x %d--\n", (unsigned)object, object->refcount);
++ do_log(D_REFCOUNT, "O %p %d--\n", object, object->refcount);
+ object->refcount--;
+ if(object->refcount == 0) {
+ assert(!object->handlers && !(object->flags & OBJECT_INPROGRESS));
+@@ -288,7 +288,7 @@
+ void
+ releaseNotifyObject(ObjectPtr object)
+ {
+- do_log(D_REFCOUNT, "O 0x%x %d--\n", (unsigned)object, object->refcount);
++ do_log(D_REFCOUNT, "O %p %d--\n", object, object->refcount);
+ object->refcount--;
+ if(object->refcount > 0) {
+ notifyObject(object);
+@@ -302,7 +302,7 @@
+ void
+ lockChunk(ObjectPtr object, int i)
+ {
+- do_log(D_LOCK, "Lock 0x%x[%d]: ", (unsigned)object, i);
++ do_log(D_LOCK, "Lock %p[%d]: ", object, i);
+ assert(i >= 0);
+ if(i >= object->numchunks)
+ objectSetChunks(object, i + 1);
+@@ -313,7 +313,7 @@
+ void
+ unlockChunk(ObjectPtr object, int i)
+ {
+- do_log(D_LOCK, "Unlock 0x%x[%d]: ", (unsigned)object, i);
++ do_log(D_LOCK, "Unlock %p[%d]: ", object, i);
+ assert(i >= 0 && i < object->numchunks);
+ assert(object->chunks[i].locked > 0);
+ object->chunks[i].locked--;
+@@ -467,8 +467,8 @@
+ {
+ int rc;
+
+- do_log(D_OBJECT_DATA, "Adding data to 0x%x (%d) at %d: %d bytes\n",
+- (unsigned)object, object->length, offset, len);
++ do_log(D_OBJECT_DATA, "Adding data to %p (%d) at %d: %d bytes\n",
++ object, object->length, offset, len);
+
+ if(len == 0)
+ return 1;
diff --git a/net-proxy/polipo/polipo-0.9.12.ebuild b/net-proxy/polipo/polipo-0.9.12-r1.ebuild
index cda26fd6e4af..47b497de8cbb 100644
--- a/net-proxy/polipo/polipo-0.9.12.ebuild
+++ b/net-proxy/polipo/polipo-0.9.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/polipo/polipo-0.9.12.ebuild,v 1.1 2007/02/08 09:40:10 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/polipo/polipo-0.9.12-r1.ebuild,v 1.1 2007/04/11 12:56:08 mrness Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.pps.jussieu.fr/~jch/software/files/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
IUSE=""
DEPEND="sys-apps/texinfo"
@@ -24,6 +24,7 @@ src_unpack() {
unpack ${A}
epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-printf-ptr.patch"
}
src_compile() {
@@ -41,7 +42,7 @@ src_install() {
exeinto /etc/cron.daily ; newexe "${FILESDIR}/polipo.crond" polipo.sh
diropts -m0750 -o polipo -g polipo
- dodir /var/cache/polipo
+ keepdir /var/cache/polipo
}
pkg_preinst() {