summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-12-16 07:38:24 +0000
committerAlin Năstac <mrness@gentoo.org>2008-12-16 07:38:24 +0000
commit8a184b2790d44be171f2f1ebf567d9c7026822f8 (patch)
treee1a57239d7ebdfa60e761071b1306cd33fa11d15 /net-proxy
parentBump (diff)
downloadgentoo-2-8a184b2790d44be171f2f1ebf567d9c7026822f8.tar.gz
gentoo-2-8a184b2790d44be171f2f1ebf567d9c7026822f8.tar.bz2
gentoo-2-8a184b2790d44be171f2f1ebf567d9c7026822f8.zip
Apply upstream patch 20080718 correctly (#247607).
(Portage version: 2.1.4.5, RepoMan options: --force)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/squidguard/ChangeLog9
-rw-r--r--net-proxy/squidguard/files/squidguard-1.3-nolog.patch (renamed from net-proxy/squidguard/files/squidguard-1.3-bison.patch)23
-rw-r--r--net-proxy/squidguard/squidguard-1.3-r4.ebuild (renamed from net-proxy/squidguard/squidguard-1.3-r3.ebuild)4
3 files changed, 32 insertions, 4 deletions
diff --git a/net-proxy/squidguard/ChangeLog b/net-proxy/squidguard/ChangeLog
index ea5b6c1d61a1..01c405595df9 100644
--- a/net-proxy/squidguard/ChangeLog
+++ b/net-proxy/squidguard/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-proxy/squidguard
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/ChangeLog,v 1.27 2008/10/12 07:58:25 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/ChangeLog,v 1.28 2008/12/16 07:38:24 mrness Exp $
+
+*squidguard-1.3-r4 (16 Dec 2008)
+
+ 16 Dec 2008; Alin Năstac <mrness@gentoo.org>
+ -files/squidguard-1.3-bison.patch, +files/squidguard-1.3-nolog.patch,
+ -squidguard-1.3-r3.ebuild, +squidguard-1.3-r4.ebuild:
+ Apply upstream patch 20080718 correctly (#247607).
12 Oct 2008; Alin Năstac <mrness@gentoo.org>
-files/squidguard-1.2.1-gentoo.patch,
diff --git a/net-proxy/squidguard/files/squidguard-1.3-bison.patch b/net-proxy/squidguard/files/squidguard-1.3-nolog.patch
index 1c2fee88515f..04746c992f42 100644
--- a/net-proxy/squidguard/files/squidguard-1.3-bison.patch
+++ b/net-proxy/squidguard/files/squidguard-1.3-nolog.patch
@@ -6,7 +6,7 @@ diff -Nru squidGuard-1.3.orig/configure.in squidGuard-1.3/configure.in
AC_SUBST(BLACKLISTS)
-AC_OUTPUT(Makefile src/Makefile src/sg.h doc/Makefile test/Makefile test/test1.conf test/test2.conf samples/Makefile samples/sample.conf samples/squidGuard.cgi samples/squidGuard-simple.cgi contrib/Makefile contrib/squidGuardRobot/squidGuardRobot contrib/sgclean/sgclean contrib/hostbyname/hostbyname)
-+AC_OUTPUT(Makefile src/Makefile src/sg.h src/sg.y doc/Makefile test/Makefile test/test1.conf test/test2.conf samples/Makefile samples/sample.conf samples/squidGuard.cgi samples/squidGuard-simple.cgi contrib/Makefile contrib/squidGuardRobot/squidGuardRobot contrib/sgclean/sgclean contrib/hostbyname/hostbyname)
++AC_OUTPUT(Makefile src/Makefile src/sg.h src/sg.y src/sgDiv.c doc/Makefile test/Makefile test/test1.conf test/test2.conf samples/Makefile samples/sample.conf samples/squidGuard.cgi samples/squidGuard-simple.cgi contrib/Makefile contrib/squidGuardRobot/squidGuardRobot contrib/sgclean/sgclean contrib/hostbyname/hostbyname)
diff -Nru squidGuard-1.3.orig/src/sg.y.in squidGuard-1.3/src/sg.y.in
--- squidGuard-1.3/src/sg.y.in 2007-11-03 18:59:49.000000000 +0500
+++ squidGuard-1.3/src/sg.y.in 2008-07-06 15:35:08.000000000 +0600
@@ -92,3 +92,24 @@ diff -Nru squidGuard-1.3.orig/src/sg.y.in squidGuard-1.3/src/sg.y.in
ldap_unbind(ld);
ldap_free_urldesc(lud);
+diff -Nru squidGuard-1.3.orig/src/sgDiv.c.in squidGuard-1.3/src/sgDiv.c.in
+--- squidGuard-1.3.orig/src/sgDiv.c.in 2008-12-16 07:26:28.000000000 +0000
++++ squidGuard-1.3/src/sgDiv.c.in 2008-12-16 07:31:50.000000000 +0000
+@@ -145,7 +145,7 @@
+ strncpy(p+ndx,p+ndx+1, sz);
+ p[ndx+sz] = '\0';
+ if(1 == report_once) {
+- @NOLOG1@ sgLogError("Warning: Possible bypass attempt. Found multiple slashes where only one is expected: %s", s->orig); @NOLOG2@
++ sgLogError("Warning: Possible bypass attempt. Found multiple slashes where only one is expected: %s", s->orig);
+ report_once--;
+ }
+ }
+@@ -157,7 +157,7 @@
+ size_t sz = strlen(p+ndx+1);
+ strncpy(p+ndx,p+ndx+1, sz);
+ p[ndx+sz] = '\0';
+- @NOLOG1@ sgLogError("Warning: Possible bypass attempt. Found a trailing dot in the domain name: %s", s->orig); @NOLOG2@
++ sgLogError("Warning: Possible bypass attempt. Found a trailing dot in the domain name: %s", s->orig);
+ }
+ else
+ {
diff --git a/net-proxy/squidguard/squidguard-1.3-r3.ebuild b/net-proxy/squidguard/squidguard-1.3-r4.ebuild
index a34faee29c5c..ca6c248b640b 100644
--- a/net-proxy/squidguard/squidguard-1.3-r3.ebuild
+++ b/net-proxy/squidguard/squidguard-1.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/squidguard-1.3-r3.ebuild,v 1.2 2008/10/12 07:58:25 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/squidguard-1.3-r4.ebuild,v 1.1 2008/12/16 07:38:24 mrness Exp $
WANT_AUTOMAKE=none
@@ -34,7 +34,7 @@ src_unpack() {
cp ../squidGuard-${PV}-patch-20080714/src/sgDiv.c.in src/ || die "failed to replace sgDiv.c.in"
epatch "${FILESDIR}/${P}-gentoo.patch"
epatch "${FILESDIR}/${P}-autoheader.patch"
- epatch "${FILESDIR}/${P}-bison.patch"
+ epatch "${FILESDIR}/${P}-nolog.patch"
eautoreconf
}