summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-06-17 15:59:01 +0000
committerAlin Năstac <mrness@gentoo.org>2007-06-17 15:59:01 +0000
commit62463f9e2ba0ff09c1f58e2d170aa5b1ff1580cd (patch)
tree808a5aa2a6cc79ec797f7f22d8b7286583b8d501 /net-proxy
parentbump (diff)
downloadgentoo-2-62463f9e2ba0ff09c1f58e2d170aa5b1ff1580cd.tar.gz
gentoo-2-62463f9e2ba0ff09c1f58e2d170aa5b1ff1580cd.tar.bz2
gentoo-2-62463f9e2ba0ff09c1f58e2d170aa5b1ff1580cd.zip
Version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/squidguard/ChangeLog9
-rw-r--r--net-proxy/squidguard/files/digest-squidguard-1.2.13
-rw-r--r--net-proxy/squidguard/files/squidguard-1.2.1-db4.patch54
-rw-r--r--net-proxy/squidguard/files/squidguard-1.2.1-makefile.patch40
-rw-r--r--net-proxy/squidguard/files/squidguard-1.2.1-tests.patch74
-rw-r--r--net-proxy/squidguard/squidguard-1.2.1.ebuild67
6 files changed, 246 insertions, 1 deletions
diff --git a/net-proxy/squidguard/ChangeLog b/net-proxy/squidguard/ChangeLog
index 9f9da8730a2b..8d325ec86120 100644
--- a/net-proxy/squidguard/ChangeLog
+++ b/net-proxy/squidguard/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-proxy/squidguard
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/ChangeLog,v 1.8 2007/04/11 13:41:55 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/ChangeLog,v 1.9 2007/06/17 15:59:01 mrness Exp $
+
+*squidguard-1.2.1 (17 Jun 2007)
+
+ 17 Jun 2007; Alin Năstac <mrness@gentoo.org>
+ +files/squidguard-1.2.1-db4.patch, +files/squidguard-1.2.1-makefile.patch,
+ +files/squidguard-1.2.1-tests.patch, +squidguard-1.2.1.ebuild:
+ Version bump.
11 Apr 2007; Alin Năstac <mrness@gentoo.org> squidguard-1.2.0-r1.ebuild:
Simplify postinst info messages.
diff --git a/net-proxy/squidguard/files/digest-squidguard-1.2.1 b/net-proxy/squidguard/files/digest-squidguard-1.2.1
new file mode 100644
index 000000000000..b8df36f399bf
--- /dev/null
+++ b/net-proxy/squidguard/files/digest-squidguard-1.2.1
@@ -0,0 +1,3 @@
+MD5 b6700f59c48fde5ad4d12f871acba93a squidGuard-1.2.1.tar.gz 1947273
+RMD160 0b998792a3612db28adb795c9fb0ea9b70118af3 squidGuard-1.2.1.tar.gz 1947273
+SHA256 bc658e9bbadde5d5424caddc6a592c6fcd3346230269b0233092985e4b773592 squidGuard-1.2.1.tar.gz 1947273
diff --git a/net-proxy/squidguard/files/squidguard-1.2.1-db4.patch b/net-proxy/squidguard/files/squidguard-1.2.1-db4.patch
new file mode 100644
index 000000000000..25cb495bca42
--- /dev/null
+++ b/net-proxy/squidguard/files/squidguard-1.2.1-db4.patch
@@ -0,0 +1,54 @@
+diff -Nru squidGuard-1.2.1.orig/configure.in squidGuard-1.2.1/configure.in
+--- squidGuard-1.2.1.orig/configure.in 2007-06-17 11:24:29.000000000 +0300
++++ squidGuard-1.2.1/configure.in 2007-06-17 11:24:55.000000000 +0300
+@@ -85,7 +85,7 @@
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS(db.h regex.h unistd.h)
+
+-+AC_CHECK_HEADER(db.h,,[
++AC_CHECK_HEADER(db.h,,[
+ echo
+ echo "** No db.h found"
+ echo " The Berkley DB library is required for squidGuard"
+@@ -141,15 +141,7 @@
+ ])
+
+ dnl Check DB
+-AC_CHECK_LIB(db,db_version,,[
+- echo
+- echo "** The Berkley DB library is required for squidGuard"
+- echo " to compile. Get it from http://www.sleepycat.com"
+- echo " use --with-db=DIR or --with-db-lib=DIR to specify"
+- echo " its location. (default is $dbprefix/BerkeleyDB)"
+- echo
+- exit 1
+- ])
++LIBS="$LIBS -ldb"
+ AC_RUN_IFELSE([
+ #include <db.h>
+ int main()
+diff -Nru squidGuard-1.2.1.orig/src/sgDb.c squidGuard-1.2.1/src/sgDb.c
+--- squidGuard-1.2.1.orig/src/sgDb.c 2007-06-17 11:24:29.000000000 +0300
++++ squidGuard-1.2.1/src/sgDb.c 2007-06-17 11:15:27.000000000 +0300
+@@ -101,13 +101,21 @@
+ if(createdb)
+ flag = flag | DB_TRUNCATE;
+ if ((ret =
++#if DB_VERSION_MAJOR > 4 || (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)
++ Db->dbp->open(Db->dbp, NULL, dbfile, NULL, DB_BTREE, flag, 0664)) != 0) {
++#else
+ Db->dbp->open(Db->dbp, dbfile, NULL, DB_BTREE, flag, 0664)) != 0) {
++#endif
+ (void) Db->dbp->close(Db->dbp, 0);
+ sgLogFatalError("Error db_open: %s", strerror(ret));
+ }
+ } else {
+ if ((ret =
++#if DB_VERSION_MAJOR > 4 || (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)
++ Db->dbp->open(Db->dbp, NULL, dbfile, NULL, DB_BTREE, DB_CREATE, 0664)) != 0) {
++#else
+ Db->dbp->open(Db->dbp, dbfile, NULL, DB_BTREE, DB_CREATE, 0664)) != 0) {
++#endif
+ sgLogFatalError("Error db_open: %s", strerror(ret));
+ }
+ }
diff --git a/net-proxy/squidguard/files/squidguard-1.2.1-makefile.patch b/net-proxy/squidguard/files/squidguard-1.2.1-makefile.patch
new file mode 100644
index 000000000000..9ffa99971bef
--- /dev/null
+++ b/net-proxy/squidguard/files/squidguard-1.2.1-makefile.patch
@@ -0,0 +1,40 @@
+diff -Nru squidGuard-1.2.1.orig/Makefile.in squidGuard-1.2.1/Makefile.in
+--- squidGuard-1.2.1.orig/Makefile.in 2006-12-29 11:03:53.000000000 +0200
++++ squidGuard-1.2.1/Makefile.in 2007-06-17 18:47:13.000000000 +0300
+@@ -40,7 +40,7 @@
+ # Dependencies for installing
+ #
+
+-install: install-build install-conf
++install: install-build
+
+ install-conf:
+ @echo Installing configuration file
+@@ -67,10 +67,10 @@
+
+ install-build:
+ @echo Installing squidGuard
+- @if [ ! -d $(bindir) ]; then \
+- $(MKINSTALLDIRS) $(bindir) ; \
++ @if [ ! -d "$(INSTDIR)"/$(bindir) ]; then \
++ $(MKINSTALLDIRS) "$(INSTDIR)"/$(bindir) ; \
+ fi ; \
+- cp src/squidGuard $(bindir) || exit 1 ; \
++ cp src/squidGuard "$(INSTDIR)"/$(bindir) || exit 1 ; \
+ echo Done. ;
+
+ clean::
+diff -Nru squidGuard-1.2.1.orig/src/Makefile.in squidGuard-1.2.1/src/Makefile.in
+--- squidGuard-1.2.1.orig/src/Makefile.in 2007-03-16 17:58:37.000000000 +0200
++++ squidGuard-1.2.1/src/Makefile.in 2007-06-17 18:41:35.000000000 +0300
+@@ -103,8 +103,8 @@
+
+ install.bin:: squidGuard
+ @echo making $@ in `basename \`pwd\``
+- @$(MKDIR) $(bindir) $(logdir) $(cfgdir)
+- $(INSTALL_PROGRAM) squidGuard $(bindir)/squidGuard
++ @$(MKDIR) "$(INSTDIR)"/$(bindir) "$(INSTDIR)"/$(logdir) "$(INSTDIR)"/$(cfgdir)
++ $(INSTALL_PROGRAM) squidGuard "$(INSTDIR)"/$(bindir)/squidGuard
+
+ uninstall.bin::
+ @echo making $@ in `basename \`pwd\``
diff --git a/net-proxy/squidguard/files/squidguard-1.2.1-tests.patch b/net-proxy/squidguard/files/squidguard-1.2.1-tests.patch
new file mode 100644
index 000000000000..28cf378cb81a
--- /dev/null
+++ b/net-proxy/squidguard/files/squidguard-1.2.1-tests.patch
@@ -0,0 +1,74 @@
+diff -Nru squidGuard-1.2.1.orig/test/requests squidGuard-1.2.1/test/requests
+--- squidGuard-1.2.1.orig/test/requests 1999-08-09 15:20:06.000000000 +0300
++++ squidGuard-1.2.1/test/requests 2007-06-17 11:51:48.000000000 +0300
+@@ -954,7 +954,7 @@
+ http://www.oslo-energi.no/gifs/nav5off.gif 10.0.5.15/- - GET
+ http://www.oslo-energi.no/gifs/tittel_1_fade.gif 10.0.5.15/- - GET
+ http://www.fotball.no/_img/toppframe_bg.gif 10.0.3.125/- gurr GET
+-http://c1.thecounter.com/id=118474&size=800&colors=8&referer=http%3a//www.uib.no/guide/index.html&java=true 10.0.3.144/- - GET
++http://c1.thecounter.com/id=118474&size=800&colors=8&referer=http://www.uib.no/guide/index.html&java=true 10.0.3.144/- - GET
+ http://www.pornodungeon.com/pics/samp27.jpg 10.0.3.174/- foo GET
+ http://www.sportnews.gr/_img/polo/image2223.jpg 10.0.2.130/- - GET
+ http://www.sol.no/no/www.sol.no/graphics/partner/cnn_norge.gif 10.0.3.144/- - GET
+diff -Nru squidGuard-1.2.1.orig/test/test1.expected squidGuard-1.2.1/test/test1.expected
+--- squidGuard-1.2.1.orig/test/test1.expected 2000-03-27 14:08:14.000000000 +0300
++++ squidGuard-1.2.1/test/test1.expected 2007-06-17 11:52:40.000000000 +0300
+@@ -954,7 +954,7 @@
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.5.15&clientname=&clientuser=&clientgroup=default&targetgroup=none&url=http://www.oslo-energi.no/gifs/nav5off.gif 10.0.5.15/- - GET
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.5.15&clientname=&clientuser=&clientgroup=default&targetgroup=none&url=http://www.oslo-energi.no/gifs/tittel_1_fade.gif 10.0.5.15/- - GET
+
+-http://info.foo.bar/cgi/blocked?clientaddr=10.0.3.144&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://c1.thecounter.com/id=118474&size=800&colors=8&referer=http%3a//www.uib.no/guide/index.html&java=true 10.0.3.144/- - GET
++http://info.foo.bar/cgi/blocked?clientaddr=10.0.3.144&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://c1.thecounter.com/id=118474&size=800&colors=8&referer=http://www.uib.no/guide/index.html&java=true 10.0.3.144/- - GET
+
+
+
+diff -Nru squidGuard-1.2.1.orig/test/test2.expected squidGuard-1.2.1/test/test2.expected
+--- squidGuard-1.2.1.orig/test/test2.expected 2000-03-27 14:09:17.000000000 +0300
++++ squidGuard-1.2.1/test/test2.expected 2007-06-17 11:53:08.000000000 +0300
+@@ -6,8 +6,8 @@
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.1.23&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://www.book-mark.net/Mark.gif 10.0.1.23/- - GET
+
+
+-http://info.foo.bar/cgi/blocked?clientaddr=10.0.1.23&clientname=&clientuser=gurr&clientgroup=kids&targetgroup=blacklist&url=http://www.angrydragon.com/sexing/sex/tn_316_jpg.jpg 10.0.1.23/- gurr GET
+-http://info.foo.bar/cgi/blocked?clientaddr=10.0.1.23&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://www.angrydragon.com/sexing/sex/phc057.gif 10.0.1.23/- - GET
++
++
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.1.23&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://www.freesexsites.net/book-mark/22/tn_09.jpg 10.0.1.23/- - GET
+
+
+@@ -251,7 +251,7 @@
+
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.0.64&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://counter10.sextracker.com/c5/id/0/109497 10.0.0.64/- - GET
+
+-http://info.foo.bar/cgi/blocked?clientaddr=10.0.0.64&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://www.angrydragon.com/sexing/sex/tn_536_jpg.jpg 10.0.0.64/- - GET
++
+
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.0.64&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://www.freesexsites.net/book-mark/tartban2.gif 10.0.0.64/- - GET
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.0.64&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://the-strip.porncity.net/866/fritz/buttons/germ.gif 10.0.0.64/- - GET
+@@ -261,7 +261,7 @@
+
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.0.64&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://www.ultrasexe.com/image/tnoire6.jpg 10.0.0.64/- - GET
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.0.64&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://artemis.porntrack.com/0/20807/? 10.0.0.64/- - GET
+-http://info.foo.bar/cgi/blocked?clientaddr=10.0.0.64&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://www.amateur-space.com/aec/images/hardcore/tn_sunshine35_jpg.jpg 10.0.0.64/- - GET
++
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.0.64&clientname=&clientuser=gurr&clientgroup=kids&targetgroup=blacklist&url=http://amateur.freepictures.com/amateur/images/tn_fpcheer017_jpg.jpg 10.0.0.64/- gurr GET
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.0.64&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://amateur.freepictures.com/amateur/images/fpcheer018.jpg 10.0.0.64/- - GET
+
+@@ -330,7 +330,7 @@
+
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.1.39&clientname=&clientuser=gurr&clientgroup=kids&targetgroup=blacklist&url=http://c1.xxxcounter.com/c7/id/16/44847/0/ 10.0.1.39/- gurr GET
+
+-http://info.foo.bar/cgi/blocked?clientaddr=10.0.1.39&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://www.pinkswap.com/teen/folder.gif 10.0.1.39/- - GET
++
+
+
+
+@@ -954,7 +954,7 @@
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.5.15&clientname=&clientuser=&clientgroup=default&targetgroup=none&url=http://www.oslo-energi.no/gifs/nav5off.gif 10.0.5.15/- - GET
+ http://info.foo.bar/cgi/blocked?clientaddr=10.0.5.15&clientname=&clientuser=&clientgroup=default&targetgroup=none&url=http://www.oslo-energi.no/gifs/tittel_1_fade.gif 10.0.5.15/- - GET
+
+-http://info.foo.bar/cgi/blocked?clientaddr=10.0.3.144&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://c1.thecounter.com/id=118474&size=800&colors=8&referer=http%3a//www.uib.no/guide/index.html&java=true 10.0.3.144/- - GET
++http://info.foo.bar/cgi/blocked?clientaddr=10.0.3.144&clientname=&clientuser=&clientgroup=kids&targetgroup=blacklist&url=http://c1.thecounter.com/id=118474&size=800&colors=8&referer=http://www.uib.no/guide/index.html&java=true 10.0.3.144/- - GET
+
+
+
diff --git a/net-proxy/squidguard/squidguard-1.2.1.ebuild b/net-proxy/squidguard/squidguard-1.2.1.ebuild
new file mode 100644
index 000000000000..4dd625ce1ff9
--- /dev/null
+++ b/net-proxy/squidguard/squidguard-1.2.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidguard/squidguard-1.2.1.ebuild,v 1.1 2007/06/17 15:59:01 mrness Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Combined filter, redirector and access controller plugin for Squid."
+HOMEPAGE="http://www.squidguard.org"
+SRC_URI="http://www.squidguard.org/Downloads/squidGuard-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="net-proxy/squid
+ >=sys-libs/db-2"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+S="${WORKDIR}/squidGuard-${PV}"
+
+src_unpack() {
+ unpack ${A} || die "unpack problem"
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-db4.patch"
+ epatch "${FILESDIR}/${P}-tests.patch"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+ eautoconf
+}
+
+src_compile() {
+ econf \
+ --with-sg-config=/etc/squidGuard/squidGuard.conf \
+ --with-sg-logdir=/var/log/squidGuard \
+ || die "configure has failed"
+
+ emake || die "make has failed"
+}
+
+src_install() {
+ make prefix="/usr" INSTDIR="${D}" install || die "make install has failed"
+
+ keepdir /var/log/squidGuard
+ fowners squid:squid /var/log/squidGuard
+
+ insinto /etc/squidGuard/sample
+ doins "${FILESDIR}"/squidGuard.conf.*
+ insinto /etc/squidGuard/sample/db
+ doins "${FILESDIR}"/blockedsites
+
+ dodoc ANNOUNCE CHANGELOG README
+ dohtml doc/*.html
+ docinto text
+ dodoc doc/*.txt
+}
+
+pkg_postinst() {
+ einfo "To enable squidGuard, add the following lines to /etc/squid/squid.conf:"
+ einfo " url_rewrite_program /usr/bin/squidGuard"
+ einfo " url_rewrite_children 10"
+ einfo ""
+ einfo "Remember to edit /etc/squidGuard/squidGuard.conf first!"
+ einfo "Examples can be found in /etc/squidGuard/sample/"
+}