summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-05-25 20:46:50 +0000
committerAlin Năstac <mrness@gentoo.org>2008-05-25 20:46:50 +0000
commit5e3072cef1e995bb4ed424b2728bcf2c555b3958 (patch)
treed09e8ba91f6da760c934464c600b6fa87d829927 /net-proxy
parentAdd DNOTIFY support. (diff)
downloadgentoo-2-5e3072cef1e995bb4ed424b2728bcf2c555b3958.tar.gz
gentoo-2-5e3072cef1e995bb4ed424b2728bcf2c555b3958.tar.bz2
gentoo-2-5e3072cef1e995bb4ed424b2728bcf2c555b3958.zip
Version bump (#223041)
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/squid/ChangeLog8
-rw-r--r--net-proxy/squid/files/squid-3.0.6-gentoo.patch210
-rw-r--r--net-proxy/squid/squid-3.0.6.ebuild177
3 files changed, 394 insertions, 1 deletions
diff --git a/net-proxy/squid/ChangeLog b/net-proxy/squid/ChangeLog
index f46f05e38258..8d5a875822eb 100644
--- a/net-proxy/squid/ChangeLog
+++ b/net-proxy/squid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/squid
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/ChangeLog,v 1.188 2008/05/25 18:27:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/ChangeLog,v 1.189 2008/05/25 20:46:50 mrness Exp $
+
+*squid-3.0.6 (25 May 2008)
+
+ 25 May 2008; Alin Năstac <mrness@gentoo.org>
+ +files/squid-3.0.6-gentoo.patch, +squid-3.0.6.ebuild:
+ Version bump (#223041).
25 May 2008; Jeroen Roovers <jer@gentoo.org> squid-2.6.19-r1.ebuild:
Stable for HPPA (bug #223029).
diff --git a/net-proxy/squid/files/squid-3.0.6-gentoo.patch b/net-proxy/squid/files/squid-3.0.6-gentoo.patch
new file mode 100644
index 000000000000..43a61ccda1ec
--- /dev/null
+++ b/net-proxy/squid/files/squid-3.0.6-gentoo.patch
@@ -0,0 +1,210 @@
+diff -Nru squid-3.0.STABLE6.orig/helpers/basic_auth/MSNT/confload.c squid-3.0.STABLE6/helpers/basic_auth/MSNT/confload.c
+--- squid-3.0.STABLE6.orig/helpers/basic_auth/MSNT/confload.c 2008-05-20 18:01:10.000000000 +0300
++++ squid-3.0.STABLE6/helpers/basic_auth/MSNT/confload.c 2008-05-25 23:26:04.000000000 +0300
+@@ -24,7 +24,7 @@
+
+ /* Path to configuration file */
+ #ifndef SYSCONFDIR
+-#define SYSCONFDIR "/usr/local/squid/etc"
++#define SYSCONFDIR "/etc/squid"
+ #endif
+ #define CONFIGFILE SYSCONFDIR "/msntauth.conf"
+
+diff -Nru squid-3.0.STABLE6.orig/helpers/basic_auth/MSNT/msntauth.conf.default squid-3.0.STABLE6/helpers/basic_auth/MSNT/msntauth.conf.default
+--- squid-3.0.STABLE6.orig/helpers/basic_auth/MSNT/msntauth.conf.default 2008-05-20 18:01:10.000000000 +0300
++++ squid-3.0.STABLE6/helpers/basic_auth/MSNT/msntauth.conf.default 2008-05-25 23:26:04.000000000 +0300
+@@ -8,6 +8,6 @@
+ server other_PDC other_BDC otherdomain
+
+ # Denied and allowed users. Comment these if not needed.
+-#denyusers /usr/local/squid/etc/msntauth.denyusers
+-#allowusers /usr/local/squid/etc/msntauth.allowusers
++#denyusers /etc/squid/msntauth.denyusers
++#allowusers /etc/squid/msntauth.allowusers
+
+diff -Nru squid-3.0.STABLE6.orig/helpers/basic_auth/SMB/Makefile.am squid-3.0.STABLE6/helpers/basic_auth/SMB/Makefile.am
+--- squid-3.0.STABLE6.orig/helpers/basic_auth/SMB/Makefile.am 2008-05-20 18:01:11.000000000 +0300
++++ squid-3.0.STABLE6/helpers/basic_auth/SMB/Makefile.am 2008-05-25 23:26:04.000000000 +0300
+@@ -14,7 +14,7 @@
+ ## FIXME: autoconf should test for the samba path.
+
+ SMB_AUTH_HELPER = smb_auth.sh
+-SAMBAPREFIX=/usr/local/samba
++SAMBAPREFIX=/usr
+ SMB_AUTH_HELPER_PATH = $(libexecdir)/$(SMB_AUTH_HELPER)
+
+ libexec_SCRIPTS = $(SMB_AUTH_HELPER)
+diff -Nru squid-3.0.STABLE6.orig/helpers/basic_auth/SMB/smb_auth.sh squid-3.0.STABLE6/helpers/basic_auth/SMB/smb_auth.sh
+--- squid-3.0.STABLE6.orig/helpers/basic_auth/SMB/smb_auth.sh 2008-05-20 18:01:11.000000000 +0300
++++ squid-3.0.STABLE6/helpers/basic_auth/SMB/smb_auth.sh 2008-05-25 23:26:04.000000000 +0300
+@@ -24,7 +24,7 @@
+ read AUTHSHARE
+ read AUTHFILE
+ read SMBUSER
+-read SMBPASS
++read -r SMBPASS
+
+ # Find domain controller
+ echo "Domain name: $DOMAINNAME"
+@@ -47,7 +47,7 @@
+ addropt=""
+ fi
+ echo "Query address options: $addropt"
+-dcip=`$SAMBAPREFIX/bin/nmblookup $addropt "$PASSTHROUGH#1c" | awk '/^[0-9.]+ / { print $1 ; exit }'`
++dcip=`$SAMBAPREFIX/bin/nmblookup $addropt "$PASSTHROUGH#1c" | awk '/^[0-9.]+\..+ / { print $1 ; exit }'`
+ echo "Domain controller IP address: $dcip"
+ [ -n "$dcip" ] || exit 1
+
+diff -Nru squid-3.0.STABLE6.orig/helpers/external_acl/session/squid_session.8 squid-3.0.STABLE6/helpers/external_acl/session/squid_session.8
+--- squid-3.0.STABLE6.orig/helpers/external_acl/session/squid_session.8 2008-05-20 18:01:11.000000000 +0300
++++ squid-3.0.STABLE6/helpers/external_acl/session/squid_session.8 2008-05-25 23:26:04.000000000 +0300
+@@ -35,7 +35,7 @@
+ .P
+ Configuration example using the default automatic mode
+ .IP
+-external_acl_type session ttl=300 negative_ttl=0 children=1 concurrency=200 %LOGIN /usr/local/squid/libexec/squid_session
++external_acl_type session ttl=300 negative_ttl=0 children=1 concurrency=200 %LOGIN /usr/libexec/squid/squid_session
+ .IP
+ acl session external session
+ .IP
+diff -Nru squid-3.0.STABLE6.orig/helpers/external_acl/unix_group/squid_unix_group.8 squid-3.0.STABLE6/helpers/external_acl/unix_group/squid_unix_group.8
+--- squid-3.0.STABLE6.orig/helpers/external_acl/unix_group/squid_unix_group.8 2008-05-20 18:01:11.000000000 +0300
++++ squid-3.0.STABLE6/helpers/external_acl/unix_group/squid_unix_group.8 2008-05-25 23:26:04.000000000 +0300
+@@ -27,7 +27,7 @@
+ This squid.conf example defines two Squid acls. usergroup1 matches users in group1, and usergroup2
+ matches users in group2 or group3
+ .IP
+-external_acl_type unix_group %LOGIN /usr/local/squid/libexec/squid_unix_group -p
++external_acl_type unix_group %LOGIN /usr/libexec/squid/squid_unix_group -p
+ .IP
+ acl usergroup1 external unix_group group1
+ .IP
+diff -Nru squid-3.0.STABLE6.orig/src/cf.data.pre squid-3.0.STABLE6/src/cf.data.pre
+--- squid-3.0.STABLE6.orig/src/cf.data.pre 2008-05-20 18:01:14.000000000 +0300
++++ squid-3.0.STABLE6/src/cf.data.pre 2008-05-25 23:26:04.000000000 +0300
+@@ -638,6 +638,8 @@
+ acl Safe_ports port 488 # gss-http
+ acl Safe_ports port 591 # filemaker
+ acl Safe_ports port 777 # multiling http
++acl Safe_ports port 901 # SWAT
++acl purge method PURGE
+ acl CONNECT method CONNECT
+ NOCOMMENT_END
+ DOC_END
+@@ -671,6 +673,9 @@
+ # Only allow cachemgr access from localhost
+ http_access allow manager localhost
+ http_access deny manager
++# Only allow purge requests from localhost
++http_access allow purge localhost
++http_access deny purge
+ # Deny requests to unknown ports
+ http_access deny !Safe_ports
+ # Deny CONNECT to other than SSL ports
+@@ -688,6 +693,9 @@
+ # from where browsing should be allowed
+ http_access allow localnet
+
++# Allow the localhost to have access by default
++http_access allow localhost
++
+ # And finally deny all other access to this proxy
+ http_access deny all
+ NOCOMMENT_END
+@@ -3216,11 +3224,11 @@
+
+ NAME: cache_mgr
+ TYPE: string
+-DEFAULT: webmaster
++DEFAULT: root
+ LOC: Config.adminEmail
+ DOC_START
+ Email-address of local cache manager who will receive
+- mail if the cache dies. The default is "webmaster."
++ mail if the cache dies. The default is "root".
+ DOC_END
+
+ NAME: mail_from
+@@ -5168,6 +5176,9 @@
+ If you disable this, it will appear as
+
+ X-Forwarded-For: unknown
++NOCOMMENT_START
++forwarded_for off
++NOCOMMENT_END
+ DOC_END
+
+ NAME: cachemgr_passwd
+diff -Nru squid-3.0.STABLE6.orig/src/debug.cc squid-3.0.STABLE6/src/debug.cc
+--- squid-3.0.STABLE6.orig/src/debug.cc 2008-05-20 18:01:15.000000000 +0300
++++ squid-3.0.STABLE6/src/debug.cc 2008-05-25 23:26:04.000000000 +0300
+@@ -465,7 +465,7 @@
+ #if HAVE_SYSLOG && defined(LOG_LOCAL4)
+
+ if (opt_syslog_enable)
+- openlog(appname, LOG_PID | LOG_NDELAY | LOG_CONS, syslog_facility);
++ openlog(appname, LOG_PID | LOG_NDELAY, syslog_facility);
+
+ #endif /* HAVE_SYSLOG */
+
+diff -Nru squid-3.0.STABLE6.orig/src/defines.h squid-3.0.STABLE6/src/defines.h
+--- squid-3.0.STABLE6.orig/src/defines.h 2008-05-20 18:01:15.000000000 +0300
++++ squid-3.0.STABLE6/src/defines.h 2008-05-25 23:26:04.000000000 +0300
+@@ -219,7 +219,7 @@
+
+ /* were to look for errors if config path fails */
+ #ifndef DEFAULT_SQUID_ERROR_DIR
+-#define DEFAULT_SQUID_ERROR_DIR "/usr/local/squid/etc/errors"
++#define DEFAULT_SQUID_ERROR_DIR "/usr/share/squid/errors/English"
+ #endif
+
+ /* handy to determine the #elements in a static array */
+diff -Nru squid-3.0.STABLE6.orig/src/main.cc squid-3.0.STABLE6/src/main.cc
+--- squid-3.0.STABLE6.orig/src/main.cc 2008-05-20 18:01:15.000000000 +0300
++++ squid-3.0.STABLE6/src/main.cc 2008-05-25 23:26:04.000000000 +0300
+@@ -1482,7 +1482,7 @@
+ if (*(argv[0]) == '(')
+ return;
+
+- openlog(appname, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
++ openlog(appname, LOG_PID | LOG_NDELAY, LOG_DAEMON);
+
+ if ((pid = fork()) < 0)
+ syslog(LOG_ALERT, "fork failed: %s", xstrerror());
+@@ -1526,7 +1526,7 @@
+
+ if ((pid = fork()) == 0) {
+ /* child */
+- openlog(appname, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
++ openlog(appname, LOG_PID | LOG_NDELAY, LOG_DAEMON);
+ prog = xstrdup(argv[0]);
+ argv[0] = xstrdup("(squid)");
+ execvp(prog, argv);
+@@ -1534,7 +1534,7 @@
+ }
+
+ /* parent */
+- openlog(appname, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
++ openlog(appname, LOG_PID | LOG_NDELAY, LOG_DAEMON);
+
+ syslog(LOG_NOTICE, "Squid Parent: child process %d started", pid);
+
+diff -Nru squid-3.0.STABLE6.orig/src/Makefile.am squid-3.0.STABLE6/src/Makefile.am
+--- squid-3.0.STABLE6.orig/src/Makefile.am 2008-05-20 18:01:14.000000000 +0300
++++ squid-3.0.STABLE6/src/Makefile.am 2008-05-25 23:26:04.000000000 +0300
+@@ -988,12 +988,12 @@
+ DEFAULT_CONFIG_FILE = $(sysconfdir)/squid.conf
+ DEFAULT_MIME_TABLE = $(sysconfdir)/mime.conf
+ DEFAULT_DNSSERVER = $(libexecdir)/`echo dnsserver | sed '$(transform);s/$$/$(EXEEXT)/'`
+-DEFAULT_LOG_PREFIX = $(localstatedir)/logs
++DEFAULT_LOG_PREFIX = $(localstatedir)/log/squid
+ DEFAULT_CACHE_LOG = $(DEFAULT_LOG_PREFIX)/cache.log
+ DEFAULT_ACCESS_LOG = $(DEFAULT_LOG_PREFIX)/access.log
+ DEFAULT_STORE_LOG = $(DEFAULT_LOG_PREFIX)/store.log
+-DEFAULT_PID_FILE = $(DEFAULT_LOG_PREFIX)/squid.pid
+-DEFAULT_SWAP_DIR = $(localstatedir)/cache
++DEFAULT_PID_FILE = $(localstatedir)/run/squid.pid
++DEFAULT_SWAP_DIR = $(localstatedir)/cache/squid
+ DEFAULT_PINGER = $(libexecdir)/`echo pinger | sed '$(transform);s/$$/$(EXEEXT)/'`
+ DEFAULT_UNLINKD = $(libexecdir)/`echo unlinkd | sed '$(transform);s/$$/$(EXEEXT)/'`
+ DEFAULT_DISKD = $(libexecdir)/`echo diskd | sed '$(transform);s/$$/$(EXEEXT)/'`
diff --git a/net-proxy/squid/squid-3.0.6.ebuild b/net-proxy/squid/squid-3.0.6.ebuild
new file mode 100644
index 000000000000..ba183196c2ae
--- /dev/null
+++ b/net-proxy/squid/squid-3.0.6.ebuild
@@ -0,0 +1,177 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/squid-3.0.6.ebuild,v 1.1 2008/05/25 20:46:50 mrness Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils pam toolchain-funcs autotools linux-info
+
+# lame archive versioning scheme..
+S_PMV="${PV%%.*}"
+S_PV="${PV%.*}"
+S_PL="${PV##*.}"
+S_PP="${PN}-${S_PV}.STABLE${S_PL}"
+
+RESTRICT="test" # check if test works in next bump
+
+DESCRIPTION="A full-featured web proxy cache"
+HOMEPAGE="http://www.squid-cache.org/"
+SRC_URI="http://www.squid-cache.org/Versions/v${S_PMV}/${S_PV}/${S_PP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="pam ldap samba sasl nis radius ssl snmp selinux icap-client logrotate \
+ pf-transparent ipf-transparent \
+ elibc_uclibc kernel_linux"
+
+DEPEND="pam? ( virtual/pam )
+ ldap? ( net-nds/openldap )
+ ssl? ( dev-libs/openssl )
+ sasl? ( dev-libs/cyrus-sasl )
+ selinux? ( sec-policy/selinux-squid )
+ !x86-fbsd? ( logrotate? ( app-admin/logrotate ) )
+ >=sys-libs/db-4
+ dev-lang/perl"
+RDEPEND="${DEPEND}
+ samba? ( net-fs/samba )"
+
+S="${WORKDIR}/${S_PP}"
+
+pkg_setup() {
+ if hasq qos ${USE} || hasq zero-penalty-hit ${USE} ; then
+ eerror "qos and zero-penalty-hit useflags are not supported by squid-3."
+ eerror "Please remove them from your USE or use =net-proxy/squid-2.6* instead."
+ die "unsupported USE flags detected"
+ fi
+ enewgroup squid 31
+ enewuser squid 31 -1 /var/cache/squid squid
+}
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd "${S}" || die "source dir not found"
+
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+
+ sed -i -e 's%LDFLAGS="-g"%LDFLAGS=""%' configure.in
+
+ eautoreconf
+}
+
+src_compile() {
+ local basic_modules="getpwnam,NCSA,MSNT"
+ use samba && basic_modules="SMB,multi-domain-NTLM,${basic_modules}"
+ use ldap && basic_modules="LDAP,${basic_modules}"
+ use pam && basic_modules="PAM,${basic_modules}"
+ use sasl && basic_modules="SASL,${basic_modules}"
+ use nis && ! use elibc_uclibc && basic_modules="YP,${basic_modules}"
+ use radius && basic_modules="squid_radius_auth,${basic_modules}"
+
+ local ext_helpers="ip_user,session,unix_group"
+ use samba && ext_helpers="wbinfo_group,${ext_helpers}"
+ use ldap && ext_helpers="ldap_group,${ext_helpers}"
+
+ local ntlm_helpers="fakeauth"
+ use samba && ntlm_helpers="SMB,${ntlm_helpers}"
+
+ local myconf=""
+
+ # Support for uclibc #61175
+ if use elibc_uclibc; then
+ myconf="${myconf} --enable-storeio=ufs,diskd,aufs,null"
+ else
+ myconf="${myconf} --enable-storeio=ufs,diskd,coss,aufs,null"
+ fi
+
+ if use kernel_linux; then
+ myconf="${myconf} --enable-linux-netfilter"
+ elif use kernel_FreeBSD || use kernel_OpenBSD || use kernel_NetBSD ; then
+ myconf="${myconf} --enable-kqueue"
+ if use pf-transparent; then
+ myconf="${myconf} --enable-pf-transparent"
+ elif use ipf-transparent; then
+ myconf="${myconf} --enable-ipf-transparent"
+ fi
+ fi
+
+ export CC=$(tc-getCC)
+
+ econf \
+ --sysconfdir=/etc/squid \
+ --libexecdir=/usr/libexec/squid \
+ --localstatedir=/var \
+ --datadir=/usr/share/squid \
+ --with-default-user=squid \
+ --enable-auth="basic,digest,negotiate,ntlm" \
+ --enable-removal-policies="lru,heap" \
+ --enable-digest-auth-helpers="password" \
+ --enable-basic-auth-helpers="${basic_modules}" \
+ --enable-external-acl-helpers="${ext_helpers}" \
+ --enable-ntlm-auth-helpers="${ntlm_helpers}" \
+ --enable-useragent-log \
+ --enable-cache-digests \
+ --enable-delay-pools \
+ --enable-referer-log \
+ --enable-arp-acl \
+ --with-large-files \
+ --with-filedescriptors=8192 \
+ $(use_enable snmp) \
+ $(use_enable ssl) \
+ $(use_enable icap-client) \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # need suid root for looking into /etc/shadow
+ fowners root:squid /usr/libexec/squid/ncsa_auth
+ fowners root:squid /usr/libexec/squid/pam_auth
+ fperms 4750 /usr/libexec/squid/ncsa_auth
+ fperms 4750 /usr/libexec/squid/pam_auth
+
+ # some cleanups
+ rm -f "${D}"/usr/bin/Run*
+
+ dodoc CONTRIBUTORS CREDITS ChangeLog QUICKSTART SPONSORS doc/*.txt \
+ helpers/ntlm_auth/no_check/README.no_check_ntlm_auth
+ newdoc helpers/basic_auth/SMB/README README.auth_smb
+ dohtml helpers/basic_auth/MSNT/README.html RELEASENOTES.html
+ newdoc helpers/basic_auth/LDAP/README README.auth_ldap
+ doman helpers/basic_auth/LDAP/*.8
+ dodoc helpers/basic_auth/SASL/squid_sasl_auth*
+
+ newpamd "${FILESDIR}/squid.pam" squid
+ newconfd "${FILESDIR}/squid.confd" squid
+ if use logrotate; then
+ newinitd "${FILESDIR}/squid.initd-logrotate" squid
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/squid.logrotate" squid
+ else
+ newinitd "${FILESDIR}/squid.initd" squid
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}/squid.cron" squid.cron
+ fi
+
+ rm -rf "${D}"/var
+ diropts -m0755 -o squid -g squid
+ keepdir /var/cache/squid /var/log/squid
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Squid authentication helpers have been installed suid root."
+ ewarn "This allows shadow based authentication (see bug #52977 for more)."
+ echo
+ ewarn "Be careful what type of cache_dir you select!"
+ ewarn " 'diskd' is optimized for high levels of traffic, but it might seem slow"
+ ewarn "when there isn't sufficient traffic to keep squid reasonably busy."
+ ewarn " If your traffic level is low to moderate, use 'aufs' or 'ufs'."
+ echo
+ ewarn "Squid can be configured to run in transparent mode like this:"
+ ewarn " ${HILITE}http_port internal-addr:3128 transparent${NORMAL}"
+}