summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-22 07:09:26 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-22 07:09:26 +0000
commit4cfdd2240f7f6c9f1ffb26adf71f8c13ca237fbc (patch)
tree9bb031f272f2fcf77a9d0081fcc9ddfca6dfbc22 /net-proxy
parentVersion bump. (diff)
downloadgentoo-2-4cfdd2240f7f6c9f1ffb26adf71f8c13ca237fbc.tar.gz
gentoo-2-4cfdd2240f7f6c9f1ffb26adf71f8c13ca237fbc.tar.bz2
gentoo-2-4cfdd2240f7f6c9f1ffb26adf71f8c13ca237fbc.zip
Drop shadow or sudo dep (bug #498152).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/sshuttle/ChangeLog9
-rw-r--r--net-proxy/sshuttle/sshuttle-0.61-r1.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/net-proxy/sshuttle/ChangeLog b/net-proxy/sshuttle/ChangeLog
index 98fdb711ba11..79f0aaa55362 100644
--- a/net-proxy/sshuttle/ChangeLog
+++ b/net-proxy/sshuttle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/sshuttle
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/sshuttle/ChangeLog,v 1.14 2012/12/13 21:02:37 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/sshuttle/ChangeLog,v 1.15 2014/01/22 07:09:26 radhermit Exp $
+
+*sshuttle-0.61-r1 (22 Jan 2014)
+
+ 22 Jan 2014; Tim Harder <radhermit@gentoo.org> +sshuttle-0.61-r1.ebuild:
+ Drop shadow or sudo dep (bug #498152).
13 Dec 2012; Tim Harder <radhermit@gentoo.org> -sshuttle-0.60.ebuild:
Remove old.
diff --git a/net-proxy/sshuttle/sshuttle-0.61-r1.ebuild b/net-proxy/sshuttle/sshuttle-0.61-r1.ebuild
new file mode 100644
index 000000000000..3f6ee5ae5c17
--- /dev/null
+++ b/net-proxy/sshuttle/sshuttle-0.61-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/sshuttle/sshuttle-0.61-r1.ebuild,v 1.1 2014/01/22 07:09:26 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit python linux-info
+
+DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
+HOMEPAGE="https://github.com/apenwarr/sshuttle/"
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="net-firewall/iptables"
+
+CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~NF_NAT"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python_pkg_setup
+}
+
+src_compile() { :; }
+
+src_install() {
+ rm stresstest.py || die
+ insinto "$(python_get_sitedir)"/${PN}
+ doins -r *.py compat
+
+ exeinto "$(python_get_sitedir)"/${PN}
+ doexe ${PN}
+ dosym "$(python_get_sitedir)"/${PN}/${PN} /usr/bin/${PN}
+
+ dodoc README.md
+ doman Documentation/${PN}.8
+}