summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-04-15 14:47:04 +0000
committerJustin Lecher <jlec@gentoo.org>2015-04-15 14:47:04 +0000
commit40e1b0e1d0ab826331d2f71276a92fb403c61d4a (patch)
tree49f047e6a0a7c76b3f62572550e3419066752e09 /net-proxy
parentDev channel bump. Drop unneeded dependency on libgcrypt. Remove old. (diff)
downloadgentoo-2-40e1b0e1d0ab826331d2f71276a92fb403c61d4a.tar.gz
gentoo-2-40e1b0e1d0ab826331d2f71276a92fb403c61d4a.tar.bz2
gentoo-2-40e1b0e1d0ab826331d2f71276a92fb403c61d4a.zip
Bump EAPI and python eclasses
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/sshuttle/ChangeLog10
-rw-r--r--net-proxy/sshuttle/metadata.xml10
-rw-r--r--net-proxy/sshuttle/sshuttle-0.61-r2.ebuild41
3 files changed, 54 insertions, 7 deletions
diff --git a/net-proxy/sshuttle/ChangeLog b/net-proxy/sshuttle/ChangeLog
index d1f4c071a5e2..aacce1fc307d 100644
--- a/net-proxy/sshuttle/ChangeLog
+++ b/net-proxy/sshuttle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/sshuttle
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/sshuttle/ChangeLog,v 1.18 2014/07/01 06:18:41 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/sshuttle/ChangeLog,v 1.19 2015/04/15 14:47:04 jlec Exp $
+
+*sshuttle-0.61-r2 (15 Apr 2015)
+
+ 15 Apr 2015; Justin Lecher <jlec@gentoo.org> +sshuttle-0.61-r2.ebuild,
+ metadata.xml:
+ Bump EAPI and python eclasses
01 Jul 2014; Tim Harder <radhermit@gentoo.org> -sshuttle-0.61.ebuild:
Remove old.
diff --git a/net-proxy/sshuttle/metadata.xml b/net-proxy/sshuttle/metadata.xml
index efa5eb0078f3..5443fcb1c131 100644
--- a/net-proxy/sshuttle/metadata.xml
+++ b/net-proxy/sshuttle/metadata.xml
@@ -1,8 +1,8 @@
-<?xml version = '1.0' encoding = 'UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>radhermit@gentoo.org</email>
- <name>Tim Harder</name>
- </maintainer>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
</pkgmetadata>
diff --git a/net-proxy/sshuttle/sshuttle-0.61-r2.ebuild b/net-proxy/sshuttle/sshuttle-0.61-r2.ebuild
new file mode 100644
index 000000000000..37498e1cd903
--- /dev/null
+++ b/net-proxy/sshuttle/sshuttle-0.61-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/sshuttle/sshuttle-0.61-r2.ebuild,v 1.1 2015/04/15 14:47:04 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit linux-info python-single-r1
+
+DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
+HOMEPAGE="https://github.com/apenwarr/sshuttle/"
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="net-firewall/iptables"
+
+CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~NF_NAT"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_compile() { :; }
+
+src_install() {
+ rm stresstest.py || die
+ python_moduleinto ${PN}
+ python_domodule *.py compat
+ python_optimize
+
+ make_wrapper ${PN} "${EPYTHON} $(python_get_sitedir)/${PN}/main.py"
+
+ dodoc README.md
+ doman Documentation/${PN}.8
+}