summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-05-02 18:39:03 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-05-02 18:39:03 +0000
commitaba5bff900ecdb29abf045db08cb62ffa7eaf9e0 (patch)
tree597fc659e21ef53e51711d6ff8498636d0452beb /net-proxy/swiftiply
parentCleanup. (diff)
downloadgentoo-2-aba5bff900ecdb29abf045db08cb62ffa7eaf9e0.tar.gz
gentoo-2-aba5bff900ecdb29abf045db08cb62ffa7eaf9e0.tar.bz2
gentoo-2-aba5bff900ecdb29abf045db08cb62ffa7eaf9e0.zip
Fixed a test failure, there are still random failures left where the HTTP headers return in a different order.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'net-proxy/swiftiply')
-rw-r--r--net-proxy/swiftiply/ChangeLog7
-rw-r--r--net-proxy/swiftiply/files/swiftiply-0.6.4-cache-base-mixin-fix.patch11
-rw-r--r--net-proxy/swiftiply/swiftiply-0.6.4.ebuild6
3 files changed, 21 insertions, 3 deletions
diff --git a/net-proxy/swiftiply/ChangeLog b/net-proxy/swiftiply/ChangeLog
index 69c1538b9a47..b337d0740cd4 100644
--- a/net-proxy/swiftiply/ChangeLog
+++ b/net-proxy/swiftiply/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/swiftiply
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/swiftiply/ChangeLog,v 1.3 2013/04/19 20:19:44 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/swiftiply/ChangeLog,v 1.4 2013/05/02 18:39:03 tomwij Exp $
+
+ 02 May 2013; Tom Wijsman <TomWij@gentoo.org>
+ +files/swiftiply-0.6.4-cache-base-mixin-fix.patch, swiftiply-0.6.4.ebuild:
+ Fixed a test failure, there are still random failures left where the HTTP
+ headers return in a different order.
*swiftiply-0.6.4 (19 Apr 2013)
diff --git a/net-proxy/swiftiply/files/swiftiply-0.6.4-cache-base-mixin-fix.patch b/net-proxy/swiftiply/files/swiftiply-0.6.4-cache-base-mixin-fix.patch
new file mode 100644
index 000000000000..96e3d616b316
--- /dev/null
+++ b/net-proxy/swiftiply/files/swiftiply-0.6.4-cache-base-mixin-fix.patch
@@ -0,0 +1,11 @@
+--- a/src/swiftcore/Swiftiply/cache_base_mixin.rb 2013-05-02 20:08:19.737222826 +0200
++++ b/src/swiftcore/Swiftiply/cache_base_mixin.rb 2013-05-02 20:08:27.217222164 +0200
+@@ -33,7 +33,7 @@
+ if l == 0
+ @vw / 2
+ else
+- wait_time = (@vwtl * count) / (l * rt)
++ wait_time = (@vw * @tl * count) / (l * rt)
+ wait_time < rt ? rt * 2.0 : wait_time > @vw ? @vw : wait_time
+ end
+ end
diff --git a/net-proxy/swiftiply/swiftiply-0.6.4.ebuild b/net-proxy/swiftiply/swiftiply-0.6.4.ebuild
index e01e08788730..8fc02f2bd81a 100644
--- a/net-proxy/swiftiply/swiftiply-0.6.4.ebuild
+++ b/net-proxy/swiftiply/swiftiply-0.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/swiftiply/swiftiply-0.6.4.ebuild,v 1.1 2013/04/19 20:19:44 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/swiftiply/swiftiply-0.6.4.ebuild,v 1.2 2013/05/02 18:39:03 tomwij Exp $
EAPI="5"
@@ -18,7 +18,9 @@ KEYWORDS="~amd64 ~x86"
RDEPEND=">=dev-ruby/eventmachine-0.9.0"
RUBY_FAKEGEM_EXTRAINSTALL="src"
-RUBY_PATCHES=( "${FILESDIR}/${P}-test-deque-fix.patch" )
+RUBY_PATCHES=(
+ "${FILESDIR}/${P}-test-deque-fix.patch"
+ "${FILESDIR}/${P}-cache-base-mixin-fix.patch")
QA_PRESTRIPPED="usr/lib/fastfilereaderext.so
usr/lib32/fastfilereaderext.so