summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-01-15 23:22:18 +0000
committerTim Harder <radhermit@gentoo.org>2012-01-15 23:22:18 +0000
commit7e77192e7f136eb5a29d945292ce0ebdd67a3938 (patch)
tree44d8ce9596f18e5d77e986c70c57c09c888b0342 /net-proxy/sshuttle
parentFix working directory handling, bug 396127; drop old (diff)
downloadgentoo-2-7e77192e7f136eb5a29d945292ce0ebdd67a3938.tar.gz
gentoo-2-7e77192e7f136eb5a29d945292ce0ebdd67a3938.tar.bz2
gentoo-2-7e77192e7f136eb5a29d945292ce0ebdd67a3938.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/sshuttle')
-rw-r--r--net-proxy/sshuttle/ChangeLog9
-rw-r--r--net-proxy/sshuttle/sshuttle-0.60.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/net-proxy/sshuttle/ChangeLog b/net-proxy/sshuttle/ChangeLog
index 52f169d2ad4e..9d48b801f8f8 100644
--- a/net-proxy/sshuttle/ChangeLog
+++ b/net-proxy/sshuttle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/sshuttle
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/sshuttle/ChangeLog,v 1.5 2011/11/02 14:50:26 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/sshuttle/ChangeLog,v 1.6 2012/01/15 23:22:18 radhermit Exp $
+
+*sshuttle-0.60 (15 Jan 2012)
+
+ 15 Jan 2012; Tim Harder <radhermit@gentoo.org> +sshuttle-0.60.ebuild:
+ Version bump.
02 Nov 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> sshuttle-0.54.ebuild:
x86 stable wrt bug #388387
diff --git a/net-proxy/sshuttle/sshuttle-0.60.ebuild b/net-proxy/sshuttle/sshuttle-0.60.ebuild
new file mode 100644
index 000000000000..7add8c0484fe
--- /dev/null
+++ b/net-proxy/sshuttle/sshuttle-0.60.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/sshuttle/sshuttle-0.60.ebuild,v 1.1 2012/01/15 23:22:18 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit python linux-info
+
+DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
+HOMEPAGE="https://github.com/apenwarr/sshuttle/"
+SRC_URI="http://dev.gentoo.org/~radhermit/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="net-firewall/iptables
+ || ( app-admin/sudo sys-apps/shadow )"
+
+CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~NF_NAT"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python_pkg_setup
+}
+
+src_compile() { :; }
+
+src_install() {
+ rm -f stresstest.py
+ insinto "$(python_get_sitedir)"/${PN}
+ doins -r *.py compat
+
+ exeinto "$(python_get_sitedir)"/${PN}
+ doexe ${PN}
+ dosym "$(python_get_sitedir)"/${PN}/${PN} /usr/bin/${PN}
+
+ dodoc README.md
+ doman Documentation/${PN}.8
+}