summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-05-19 19:01:15 +0000
committerAlin Năstac <mrness@gentoo.org>2005-05-19 19:01:15 +0000
commitb54a293694b604c54b4cc5c3763e98709132e49f (patch)
treef3ad1d034362f408c949c64dc6d47f5911d3d23c /net-proxy/squidclam
parentstable on hppa (diff)
downloadgentoo-2-b54a293694b604c54b4cc5c3763e98709132e49f.tar.gz
gentoo-2-b54a293694b604c54b4cc5c3763e98709132e49f.tar.bz2
gentoo-2-b54a293694b604c54b4cc5c3763e98709132e49f.zip
initial import from #93150
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-proxy/squidclam')
-rw-r--r--net-proxy/squidclam/ChangeLog10
-rw-r--r--net-proxy/squidclam/Manifest3
-rw-r--r--net-proxy/squidclam/files/digest-squidclam-0.111
-rw-r--r--net-proxy/squidclam/metadata.xml6
-rw-r--r--net-proxy/squidclam/squidclam-0.11.ebuild52
5 files changed, 72 insertions, 0 deletions
diff --git a/net-proxy/squidclam/ChangeLog b/net-proxy/squidclam/ChangeLog
new file mode 100644
index 000000000000..0093d486a41d
--- /dev/null
+++ b/net-proxy/squidclam/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-proxy/squidclam
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclam/ChangeLog,v 1.1 2005/05/19 19:01:15 mrness Exp $
+
+*squidclam-0.11 (19 May 2005)
+
+ 19 May 2005; Alin Nastac <mrness@gentoo.org> +metadata.xml,
+ +squidclam-0.11.ebuild:
+ Initial import from bug #93150.
+
diff --git a/net-proxy/squidclam/Manifest b/net-proxy/squidclam/Manifest
new file mode 100644
index 000000000000..cd31e3ec1d80
--- /dev/null
+++ b/net-proxy/squidclam/Manifest
@@ -0,0 +1,3 @@
+MD5 20fcb2e783314bdc12ac8b29ade2bbac squidclam-0.11.ebuild 1516
+MD5 0fcd3e06211b4df6185d71e97e6ff23f metadata.xml 296
+MD5 4385df4221997c40aa3875292ebadfce files/digest-squidclam-0.11 65
diff --git a/net-proxy/squidclam/files/digest-squidclam-0.11 b/net-proxy/squidclam/files/digest-squidclam-0.11
new file mode 100644
index 000000000000..3f13ef3cc908
--- /dev/null
+++ b/net-proxy/squidclam/files/digest-squidclam-0.11
@@ -0,0 +1 @@
+MD5 a15a1f1d61f79c7f6b7830b9a45906b7 squidclam-0.11.tar.gz 10495
diff --git a/net-proxy/squidclam/metadata.xml b/net-proxy/squidclam/metadata.xml
new file mode 100644
index 000000000000..16d7641f053d
--- /dev/null
+++ b/net-proxy/squidclam/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-proxy</herd>
+<longdescription>Squidclam is a replacement for SquidClamAV-Redirector.py written in C using libclamav and libcurl.</longdescription>
+</pkgmetadata>
diff --git a/net-proxy/squidclam/squidclam-0.11.ebuild b/net-proxy/squidclam/squidclam-0.11.ebuild
new file mode 100644
index 000000000000..80159f58dce4
--- /dev/null
+++ b/net-proxy/squidclam/squidclam-0.11.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclam/squidclam-0.11.ebuild,v 1.1 2005/05/19 19:01:15 mrness Exp $
+
+DESCRIPTION="A redirector for Squid which scans accessed URLs for viruses, using Clam Anti-Virus"
+HOMEPAGE="http://squidclam.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="net-misc/curl
+ app-antivirus/clamav"
+RDEPEND="${DEPEND}
+ net-proxy/squid"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e "s:/tmpdata/:/tmp/:" ${S}/sample.conf
+}
+
+src_compile() {
+ ./configure || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin squidclam
+ insinto /etc
+ newins sample.conf squidclam.conf
+ dodoc antivir.php README Changelog TODO sample.conf
+}
+
+pkg_postinst() {
+ ewarn "THIS PACKAGE IS IN ITS EARLY DEVELOPMENT STAGE!"
+ ewarn "See ${HOMEPAGE} for more info.
+ echo
+ einfo "Add following lines to your squid.conf:"
+ einfo "${HILITE} redirect_program /usr/bin/squidclam ${NORMAL}"
+ einfo "${HILITE} redirect_children 15 ${NORMAL} # make a wise choice"
+ einfo "and this line to your acl list to prevent loops:"
+ einfo "${HILITE} redirector_access deny localhost ${NORMAL}"
+ echo
+ ewarn "Squid doesn't pass complete ssl urls to the redirector!"
+ ewarn "Therefore scanning them is pretty useless."
+ ewarn "Add something like the following to avoid this and save bandwidth:"
+ einfo "${HILITE} acl SSL_ports port 443 563 ${NORMAL}"
+ einfo "${HILITE} redirector_access deny SSL_ports ${NORMAL}"
+ echo
+}