summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-05-08 11:00:50 +0000
committerTorsten Veller <tove@gentoo.org>2010-05-08 11:00:50 +0000
commit1b427c7ce82d5d3e54a680900621da8117196777 (patch)
tree04d5b6339c8668b6e396a6b5b5a6ff9879469621 /net-proxy/privoxy/privoxy-3.0.16.ebuild
parentamd64 stable, bug 315275 (diff)
downloadgentoo-2-1b427c7ce82d5d3e54a680900621da8117196777.tar.gz
gentoo-2-1b427c7ce82d5d3e54a680900621da8117196777.tar.bz2
gentoo-2-1b427c7ce82d5d3e54a680900621da8117196777.zip
Version bump (#308615). Fix docdir and logdir (#297206)
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/privoxy/privoxy-3.0.16.ebuild')
-rw-r--r--net-proxy/privoxy/privoxy-3.0.16.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/net-proxy/privoxy/privoxy-3.0.16.ebuild b/net-proxy/privoxy/privoxy-3.0.16.ebuild
new file mode 100644
index 000000000000..319967b90a46
--- /dev/null
+++ b/net-proxy/privoxy/privoxy-3.0.16.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/privoxy/privoxy-3.0.16.ebuild,v 1.1 2010/05/08 11:00:50 tove Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs autotools
+
+[ "${PV##*_}" = "beta" ] &&
+ PRIVOXY_STATUS="beta" ||
+ PRIVOXY_STATUS="stable"
+
+HOMEPAGE="http://www.privoxy.org
+ http://sourceforge.net/projects/ijbswa/"
+DESCRIPTION="A web proxy with advanced filtering capabilities for protecting privacy against Internet junk"
+SRC_URI="mirror://sourceforge/ijbswa/${P%_*}-${PRIVOXY_STATUS}-src.tar.gz"
+
+IUSE="selinux threads zlib"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+
+DEPEND="dev-libs/libpcre
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-privoxy )"
+
+S="${WORKDIR}/${P%_*}-${PRIVOXY_STATUS}"
+
+pkg_setup() {
+ enewgroup privoxy
+ enewuser privoxy -1 -1 /etc/privoxy privoxy
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ # autoreconf needs to be called even if we don't modify any autotools source files
+ # See main makefile
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_configure() {
+ export CC=$(tc-getCC)
+ econf \
+ $(use_enable zlib) \
+ $(use_enable threads pthread) \
+ --enable-dynamic-pcre \
+ --with-user=privoxy \
+ --with-group=privoxy \
+ --sysconfdir=/etc/privoxy \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}/privoxy.initd" privoxy
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/privoxy.logrotate" privoxy
+
+ diropts -m 0750 -g privoxy -o privoxy
+ keepdir /var/log/privoxy
+}