summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavlos Ratis <dastergon@gentoo.org>2012-12-10 21:52:31 +0000
committerPavlos Ratis <dastergon@gentoo.org>2012-12-10 21:52:31 +0000
commit84feb87e7c9628a64eb4eaa33e036f68d782f45e (patch)
treed1b9fe6d3626f008c234977e77bb64e8a129c6e4 /net-proxy/pingtunnel
parentMinor simplifications related to opencl support. (diff)
downloadgentoo-2-84feb87e7c9628a64eb4eaa33e036f68d782f45e.tar.gz
gentoo-2-84feb87e7c9628a64eb4eaa33e036f68d782f45e.tar.bz2
gentoo-2-84feb87e7c9628a64eb4eaa33e036f68d782f45e.zip
fixed automagic deps and updated to eapi 5
(Portage version: 2.2.0_alpha147/cvs/Linux x86_64, signed Manifest commit with key 0x3A051746)
Diffstat (limited to 'net-proxy/pingtunnel')
-rw-r--r--net-proxy/pingtunnel/ChangeLog7
-rw-r--r--net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch60
-rw-r--r--net-proxy/pingtunnel/pingtunnel-0.72.ebuild32
3 files changed, 80 insertions, 19 deletions
diff --git a/net-proxy/pingtunnel/ChangeLog b/net-proxy/pingtunnel/ChangeLog
index 8f5b21c6f485..24aa12587512 100644
--- a/net-proxy/pingtunnel/ChangeLog
+++ b/net-proxy/pingtunnel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-proxy/pingtunnel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/pingtunnel/ChangeLog,v 1.6 2012/03/06 12:39:56 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/pingtunnel/ChangeLog,v 1.7 2012/12/10 21:52:31 dastergon Exp $
+
+ 10 Dec 2012; Pavlos Ratis <dastergon@gentoo.org>
+ +files/pingtunnel-0.72_makefile.patch, pingtunnel-0.72.ebuild:
+ fixed automagic deps and updated to eapi 5
06 Mar 2012; Tim Harder <radhermit@gentoo.org> -pingtunnel-0.61.ebuild,
-pingtunnel-0.71.ebuild:
@@ -28,4 +32,3 @@
16 Jul 2005; Alin Nastac <mrness@gentoo.org> +metadata.xml,
+pingtunnel-0.61.ebuild:
Initial import from bug #98294.
-
diff --git a/net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch b/net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch
new file mode 100644
index 000000000000..9dce0992cbda
--- /dev/null
+++ b/net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch
@@ -0,0 +1,60 @@
+--- Makefile
++++ Makefile
+@@ -2,11 +2,26 @@
+ # (c) 2004-2009 Daniel Stoedle, daniels@cs.uit.no
+ # ptunnel.exe target added by Mike Miller, mike@mikeage.net
+
+-CC = gcc
+-CFLAGS = -Wall -g
+-LDOPTS = -lpthread -lpcap
++# set to 1 to enable debug symbols
++DEBUG=0
++
++# set to 1 to enable selinux support
++SELINUX=0
++
++CC ?= gcc
++CFLAGS += -Wall
++LIBS += -lpthread -lpcap
+ PT_OBJS = ptunnel.o md5.o
+
++ifeq ($(DEBUG),1)
++CFLAGS += -g
++endif
++
++ifeq ($(SELINUX),1)
++CPPFLAGS += -DHAVE_SELINUX
++LIBS += -lselinux
++endif
++
+ WIN32_CC = mingw32-gcc
+ WIN32_CFLAGS = -g -Wall -DWIN32 -I"c:\Program Files\WpdPack\Include"
+ WIN32_LDOPTS = -lwpcap -lwsock32 -L"c:\Program Files\WpdPack\Lib"
+@@ -26,13 +41,13 @@
+
+
+ install: ptunnel
+- install -d $(bindir)/
+- install -d $(mandir)/
+- install ./ptunnel $(bindir)/ptunnel
+- install ./ptunnel.8 $(mandir)/ptunnel.8
++ install -d "$(DESTDIR)/$(bindir)/"
++ install -d "$(DESTDIR)/$(mandir)/"
++ install -m755 ./ptunnel "$(DESTDIR)/$(bindir)/ptunnel"
++ install -m644 ./ptunnel.8 "$(DESTDIR)/$(mandir)/ptunnel.8"
+
+ ptunnel: $(PT_OBJS)
+- $(CC) -o $@ $^ $(LDOPTS) `[ -e /usr/include/selinux/selinux.h ] && echo -lselinux`
++ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) $(LIBS)
+
+ ptunnel.exe: $(WIN32_PT_OBJS)
+ $(CC) -o $@ $^ $(WIN32_LDOPTS)
+@@ -47,7 +62,7 @@
+ $(CC) $(CFLAGS) -MM *.c > $@
+
+ %.o:%.c
+- $(CC) $(CFLAGS) `[ -e /usr/include/selinux/selinux.h ] && echo -DHAVE_SELINUX` -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ %.obj:%.c
+ $(WIN32_CC) $(WIN32_CFLAGS) -c -o $@ $<
diff --git a/net-proxy/pingtunnel/pingtunnel-0.72.ebuild b/net-proxy/pingtunnel/pingtunnel-0.72.ebuild
index e3dd1a994c86..aa460eb59346 100644
--- a/net-proxy/pingtunnel/pingtunnel-0.72.ebuild
+++ b/net-proxy/pingtunnel/pingtunnel-0.72.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/pingtunnel/pingtunnel-0.72.ebuild,v 1.1 2011/09/05 20:08:46 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/pingtunnel/pingtunnel-0.72.ebuild,v 1.2 2012/12/10 21:52:31 dastergon Exp $
-EAPI="4"
+EAPI=5
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="Tunnel TCP over ICMP"
HOMEPAGE="http://www.cs.uit.no/~daniels/PingTunnel"
@@ -13,28 +13,26 @@ SRC_URI="http://www.cs.uit.no/~daniels/PingTunnel/PingTunnel-${PV}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~sh ~x86"
-IUSE="doc"
+IUSE="doc selinux"
-DEPEND="net-libs/libpcap"
+DEPEND="
+ net-libs/libpcap
+ selinux? ( sys-libs/libselinux )
+"
RDEPEND="${DEPEND}"
S="${WORKDIR}"/PingTunnel
-src_prepare() {
- sed -r -i \
- -e '/^CFLAGS/s:=.*:+= -Wall -fno-strict-aliasing:' \
- -e '/^LDOPTS/s:$: $(LDFLAGS):' \
- Makefile
+src_prepare(){
+ epatch "${FILESDIR}"/${P}_makefile.patch
}
src_compile() {
- emake CC="$(tc-getCC)"
+ tc-export CC
+ emake $(usex selinux "SELINUX=1" "SELINUX=0")
}
src_install() {
- emake prefix="${D}/usr" install
- dodoc CHANGELOG README
- if use doc ; then
- dohtml web/*
- fi
+ default
+ use doc && dohtml web/*
}