summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2009-03-23 19:07:00 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2009-03-23 19:07:00 +0000
commit87e0bd5e30ffe29025ef6db8c005da937127ddc5 (patch)
treedc51c5036247b94da00ce43cce9fceb1468c6626 /net-proxy/http-replicator
parentVersion bump (diff)
downloadgentoo-2-87e0bd5e30ffe29025ef6db8c005da937127ddc5.tar.gz
gentoo-2-87e0bd5e30ffe29025ef6db8c005da937127ddc5.tar.bz2
gentoo-2-87e0bd5e30ffe29025ef6db8c005da937127ddc5.zip
Make net-proxy/http-replicator install later version of repcacheman to prevent portage deprecation warnings.
(Portage version: 2.1.6.8/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/http-replicator')
-rw-r--r--net-proxy/http-replicator/ChangeLog9
-rw-r--r--net-proxy/http-replicator/http-replicator-3.0-r2.ebuild65
2 files changed, 73 insertions, 1 deletions
diff --git a/net-proxy/http-replicator/ChangeLog b/net-proxy/http-replicator/ChangeLog
index 04aca91158b6..68476b490a09 100644
--- a/net-proxy/http-replicator/ChangeLog
+++ b/net-proxy/http-replicator/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-proxy/http-replicator
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/ChangeLog,v 1.25 2009/01/20 19:54:07 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/ChangeLog,v 1.26 2009/03/23 19:07:00 griffon26 Exp $
+
+*http-replicator-3.0-r2 (23 Mar 2009)
+
+ 23 Mar 2009; Maurice van der Pot <griffon26@gentoo.org>
+ +http-replicator-3.0-r2.ebuild:
+ Install repcacheman that uses new portage API for portage 2.1.6.4 and up
+ instead of only for 2.2_rc6 and up. Gets rid of some deprecation notices.
20 Jan 2009; Maurice van der Pot <griffon26@gentoo.org>
http-replicator-3.0-r1.ebuild:
diff --git a/net-proxy/http-replicator/http-replicator-3.0-r2.ebuild b/net-proxy/http-replicator/http-replicator-3.0-r2.ebuild
new file mode 100644
index 000000000000..2cf93c5d479b
--- /dev/null
+++ b/net-proxy/http-replicator/http-replicator-3.0-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/http-replicator-3.0-r2.ebuild,v 1.1 2009/03/23 19:07:00 griffon26 Exp $
+
+inherit eutils
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Proxy cache for Gentoo packages"
+HOMEPAGE="http://sourceforge.net/projects/http-replicator"
+SRC_URI="mirror://sourceforge/http-replicator/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ epatch "${FILESDIR}/http-replicator-3.0-sighup.patch"
+ einfo "No compilation necessary"
+}
+
+src_install(){
+ # Daemon and repcacheman into /usr/bin
+ exeinto /usr/bin
+ doexe http-replicator
+ newexe "${FILESDIR}/http-replicator-3.0-callrepcacheman-0.1" repcacheman
+ if has_version '>=sys-apps/portage-2.1.6.4'; then
+ newexe "${FILESDIR}/http-replicator-3.0-repcacheman-0.44-r1" repcacheman.py
+ else
+ newexe "${FILESDIR}/http-replicator-3.0-repcacheman-0.44" repcacheman.py
+ fi
+
+ # init.d scripts
+ newinitd "${FILESDIR}/http-replicator-3.0.init" http-replicator
+ newconfd "${FILESDIR}/http-replicator-3.0.conf" http-replicator
+
+ # Docs
+ dodoc README debian/changelog
+
+ # Man Page - Not Gentooified yet
+ doman http-replicator.1
+
+ insinto /etc/logrotate.d
+ newins debian/logrotate http-replicator
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Before starting http-replicator, please follow the next few steps:"
+ einfo "- modify /etc/conf.d/http-replicator if required"
+ einfo "- run /usr/bin/repcacheman to set up the cache"
+ einfo "- add http_proxy=\"http://serveraddress:8080\" to make.conf on"
+ einfo " the server as well as on the client machines"
+ einfo "- make sure GENTOO_MIRRORS in /etc/make.conf starts with several"
+ einfo " good http mirrors"
+ einfo
+ einfo "For more information please refer to the following forum thread:"
+ einfo " http://forums.gentoo.org/viewtopic-t-173226.html"
+ einfo
+}