summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-07-11 10:03:28 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-07-11 10:03:28 +0000
commitfb4513b64c5e173c066a841c282f6a5ad9afb94c (patch)
treef8c15c883bd20abe25f63d0c10dd2e9e541bfb8f /net-print
parentmoved from dev-lisp/gauche to dev-lang/gauche. (diff)
downloadgentoo-2-fb4513b64c5e173c066a841c282f6a5ad9afb94c.tar.gz
gentoo-2-fb4513b64c5e173c066a841c282f6a5ad9afb94c.tar.bz2
gentoo-2-fb4513b64c5e173c066a841c282f6a5ad9afb94c.zip
version bump, bug #52170
Diffstat (limited to 'net-print')
-rw-r--r--net-print/omni/ChangeLog5
-rw-r--r--net-print/omni/Manifest3
-rw-r--r--net-print/omni/files/digest-omni-0.9.11
-rw-r--r--net-print/omni/omni-0.9.1.ebuild53
4 files changed, 61 insertions, 1 deletions
diff --git a/net-print/omni/ChangeLog b/net-print/omni/ChangeLog
index 7fd43884b49f..ed6f7e0241ef 100644
--- a/net-print/omni/ChangeLog
+++ b/net-print/omni/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-print/omni
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/omni/ChangeLog,v 1.6 2004/06/25 00:40:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/omni/ChangeLog,v 1.7 2004/07/11 10:03:28 lanius Exp $
+
+ 11 Jul 2004; Heinrich Wendel <lanius@gentoo.org> :
+ version bump, bug #52170
14 Jun 2004; Aron Griffis <agriffis@gentoo.org> omni-0.9.0.ebuild:
Fix use invocation, make use of use_enable, clean up ebuild
diff --git a/net-print/omni/Manifest b/net-print/omni/Manifest
index 80b6ec4ba88f..bbab0fc0b508 100644
--- a/net-print/omni/Manifest
+++ b/net-print/omni/Manifest
@@ -1,4 +1,7 @@
+MD5 8f5a0072b55f5c66022deeffcb25865e omni-0.9.1.ebuild 1373
+MD5 e096b6a87be7ba66d4d7792eb09ff28e .#Manifest.1.8 353
MD5 c60a08cba144da3856c3be78bca37788 omni-0.9.0.ebuild 1265
MD5 d02d84fc3384cc94f29a828a78f9acdc ChangeLog 778
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
MD5 a0f001bbeec0ec15dff8fac7e9790527 files/digest-omni-0.9.0 63
+MD5 b4fb01c3394f59f16ff3ecffb7457ec1 files/digest-omni-0.9.1 63
diff --git a/net-print/omni/files/digest-omni-0.9.1 b/net-print/omni/files/digest-omni-0.9.1
new file mode 100644
index 000000000000..656d770b1889
--- /dev/null
+++ b/net-print/omni/files/digest-omni-0.9.1
@@ -0,0 +1 @@
+MD5 bb0aa05e60bdbe7aa3753ce8369d1a05 Omni-0.9.1.tar.gz 4354960
diff --git a/net-print/omni/omni-0.9.1.ebuild b/net-print/omni/omni-0.9.1.ebuild
new file mode 100644
index 000000000000..3659cefcebbe
--- /dev/null
+++ b/net-print/omni/omni-0.9.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/omni/omni-0.9.1.ebuild,v 1.1 2004/07/11 10:03:28 lanius Exp $
+
+DESCRIPTION="Omni provides support for many printers with a pluggable framework (easy to add devices)"
+HOMEPAGE="http://sourceforge.net/projects/omniprint"
+SRC_URI="mirror://sourceforge/omniprint/${P/o/O}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND=""
+RDEPEND="virtual/ghostscript
+ >=dev-libs/libxml-1.8.6
+ dev-libs/glib
+ cups? ( >=net-print/cups-1.1.14 )
+ X? ( >=dev-cpp/gtkmm-1.2.5 )
+ >=dev-libs/libsigc++-1.01
+ foomaticdb? ( net-print/foomatic-db-engine )"
+
+S="${WORKDIR}/Omni"
+
+IUSE="cups X ppds foomaticdb static"
+
+src_compile() {
+ local myconf=" \
+ $(use_enable X jobdialog) \
+ $(use_enable cups) \
+ $(use_enable static)"
+
+ export WANT_AUTOMAKE="1.6"
+ export WANT_AUTOCONF="2.5"
+
+ LANG="" ./setupOmni ${myconf} || die
+
+ if use ppds && use cups; then
+ sed -i -e "s/model\/foomatic/model\/omni/g" CUPS/Makefile \
+ || die 'sed failed'
+ make -C CUPS generateBuildPPDs || die
+ fi
+
+ if use foomaticdb; then
+ make -C Foomatic generateFoomaticData || die
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ if use foomaticdb; then
+ make -C Foomatic DESTDIR=${D} localInstall || die
+ fi
+ dodoc docs/* # never forget this! ;-)
+}
+