summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-03-29 10:04:40 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-03-29 10:04:40 +0000
commitf1543126b2e4fbf33585c395b769acaf51c751e6 (patch)
tree51c44dd2ca522fc0609cb6f320d31fe4074ec842 /net-print
parentStable on amd64 wrt bug #356967 (diff)
downloadgentoo-2-f1543126b2e4fbf33585c395b769acaf51c751e6.tar.gz
gentoo-2-f1543126b2e4fbf33585c395b769acaf51c751e6.tar.bz2
gentoo-2-f1543126b2e4fbf33585c395b769acaf51c751e6.zip
Update to a snapshot version, adds support for a series of newer printer and other fixes, fixes bug #359823
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/splix/ChangeLog9
-rw-r--r--net-print/splix/splix-2.0.0_p20110219.ebuild61
2 files changed, 69 insertions, 1 deletions
diff --git a/net-print/splix/ChangeLog b/net-print/splix/ChangeLog
index 57c69789bb2e..1c9ae30303f0 100644
--- a/net-print/splix/ChangeLog
+++ b/net-print/splix/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/splix
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/splix/ChangeLog,v 1.17 2011/03/28 17:32:00 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/splix/ChangeLog,v 1.18 2011/03/29 10:04:40 voyageur Exp $
+
+*splix-2.0.0_p20110219 (29 Mar 2011)
+
+ 29 Mar 2011; Bernard Cafarelli <voyageur@gentoo.org>
+ +splix-2.0.0_p20110219.ebuild:
+ Update to a snapshot version, adds support for a series of newer printer and
+ other fixes, fixes bug #359823
28 Mar 2011; Christoph Mende <angelos@gentoo.org> splix-2.0.0.ebuild:
Stable on amd64 wrt bug #360567
diff --git a/net-print/splix/splix-2.0.0_p20110219.ebuild b/net-print/splix/splix-2.0.0_p20110219.ebuild
new file mode 100644
index 000000000000..197833d93b1e
--- /dev/null
+++ b/net-print/splix/splix-2.0.0_p20110219.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/splix/splix-2.0.0_p20110219.ebuild,v 1.1 2011/03/29 10:04:40 voyageur Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A set of CUPS printer drivers for SPL (Samsung Printer Language) printers"
+HOMEPAGE="http://splix.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.bz2
+ http://splix.ap2c.org/samsung_cms.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+jbig"
+
+DEPEND="|| ( >=net-print/cups-1.4.0 net-print/cupsddk )
+ jbig? ( media-libs/jbigkit )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # Honor LDFLAGS
+ sed -e "/[a-z]_LDFLAGS/s/:=.*/:= $\{LDFLAGS\}/" -i module.mk \
+ || die "module.mk sed failed"
+ # Correct link comand, do not strip on install
+ sed -e "s/g++/$\{LINKER\}/" -e "/install/s/-s //" -i rules.mk \
+ || die "rules.mk sed failed"
+}
+
+src_compile() {
+ local options="MODE=optimized"
+ use jbig || options="${options} DISABLE_JBIG=1"
+ emake ${options} CXX="$(tc-getCXX)" \
+ OPTIM_CFLAGS="${CFLAGS}" OPTIM_CXXFLAGS="${CXXFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ gzip "${D}"/$(cups-config --datadir)/model/*/*.ppd || die "ppd gzip failed"
+
+ insinto $(cups-config --datadir)/model/samsung
+ doins -r "${WORKDIR}"/cms
+}
+
+pkg_postinst() {
+ ewarn "You *MUST* make sure that the PPD files that CUPS is using"
+ ewarn "for actually installed printers are updated if you upgraded"
+ ewarn "from a previous version of splix!"
+ ewarn "Otherwise you will be unable to print (your printer might"
+ ewarn "spit out blank pages etc.)."
+ ewarn "To do that, simply delete the corresponding PPD file in"
+ ewarn "/etc/cups/ppd/, click on 'Modify Printer' belonging to the"
+ ewarn "corresponding printer in the CUPS webinterface (usually"
+ ewarn "reachable via http://localhost:631/) and choose the correct"
+ ewarn "printer make and model, for example:"
+ ewarn "'Samsung' -> 'Samsung ML-1610, 1.0 (en)'"
+}