summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-08-19 01:38:48 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-08-19 01:38:48 +0000
commitce5a75eede99358369541a3a0b527c99ce9a14b7 (patch)
treea9c4a61dca3abac0a49fd8a6f1ce3211a3f6a8d5 /net-print
parentStable on alpha wrt Bug #144183. (diff)
downloadgentoo-2-ce5a75eede99358369541a3a0b527c99ce9a14b7.tar.gz
gentoo-2-ce5a75eede99358369541a3a0b527c99ce9a14b7.tar.bz2
gentoo-2-ce5a75eede99358369541a3a0b527c99ce9a14b7.zip
gcc4 patch thanks to nattfodd and Vasileios P. Lourdas <lourdas_v@yahoo.gr> in bug 135191
(Portage version: 2.1.1_pre5-r2)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/xpp/ChangeLog7
-rw-r--r--net-print/xpp/files/digest-xpp-1.52
-rw-r--r--net-print/xpp/files/xpp-gcc4.patch11
-rw-r--r--net-print/xpp/xpp-1.5.ebuild8
4 files changed, 26 insertions, 2 deletions
diff --git a/net-print/xpp/ChangeLog b/net-print/xpp/ChangeLog
index e0b582556b69..022bbe8f8dbc 100644
--- a/net-print/xpp/ChangeLog
+++ b/net-print/xpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/xpp
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/xpp/ChangeLog,v 1.16 2006/01/19 20:10:41 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/xpp/ChangeLog,v 1.17 2006/08/19 01:38:48 genstef Exp $
+
+ 19 Aug 2006; Stefan Schweizer <genstef@gentoo.org> +files/xpp-gcc4.patch,
+ xpp-1.5.ebuild:
+ gcc4 patch thanks to nattfodd and Vasileios P. Lourdas <lourdas_v@yahoo.gr>
+ in bug 135191
19 Jan 2006; Stefan Schweizer <genstef@gentoo.org> xpp-1.5.ebuild:
modular deps
diff --git a/net-print/xpp/files/digest-xpp-1.5 b/net-print/xpp/files/digest-xpp-1.5
index a93c1a1f3281..5ec2e3d5f682 100644
--- a/net-print/xpp/files/digest-xpp-1.5
+++ b/net-print/xpp/files/digest-xpp-1.5
@@ -1 +1,3 @@
MD5 775fd69c464515da0c3295d04d0c747f xpp-1.5.tar.gz 107755
+RMD160 a64ec4c93013d1db08a6c9b6705b43850c36c337 xpp-1.5.tar.gz 107755
+SHA256 4d5b0c5467b10ababa4304c2fabf3f8cc7b715cc6a6a4844dc735bd7678a845d xpp-1.5.tar.gz 107755
diff --git a/net-print/xpp/files/xpp-gcc4.patch b/net-print/xpp/files/xpp-gcc4.patch
new file mode 100644
index 000000000000..619b2404c8b6
--- /dev/null
+++ b/net-print/xpp/files/xpp-gcc4.patch
@@ -0,0 +1,11 @@
+--- xpp-1.5/xpp.h.old 2006-06-12 22:11:28.000000000 +0200
++++ xpp-1.5/xpp.h 2006-06-12 22:11:36.000000000 +0200
+@@ -177,7 +177,7 @@
+ */
+
+ int /* O - index of the record of the given option in the array */
+- printFiles::getSpecialOptionIndex(int *num_special_opts_in_arr,
++ getSpecialOptionIndex(int *num_special_opts_in_arr,
+ /* number of options in the array */
+ special_opt_t **special_opts_arr,
+ /* array of numerical/string
diff --git a/net-print/xpp/xpp-1.5.ebuild b/net-print/xpp/xpp-1.5.ebuild
index ad9b8d5071f5..0e951309403a 100644
--- a/net-print/xpp/xpp-1.5.ebuild
+++ b/net-print/xpp/xpp-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/xpp/xpp-1.5.ebuild,v 1.4 2006/01/19 20:10:41 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/xpp/xpp-1.5.ebuild,v 1.5 2006/08/19 01:38:48 genstef Exp $
inherit eutils
@@ -26,6 +26,12 @@ DEPEND="virtual/libc
virtual/x11
)"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/xpp-gcc4.patch
+}
+
src_compile() {
export CXX=g++
export LDFLAGS="-L/usr/lib/fltk-1.1 -lfltk"