summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-01-15 05:15:22 +0000
committerMike Gilbert <floppym@gentoo.org>2015-01-15 05:15:22 +0000
commitb69f17d820b4f8e1be07432128b9ac72a7f38627 (patch)
treea8c30f519508643b3cd486d5bfa96d21f85f5fd2 /net-print
parentDrop static lib and la files. (diff)
downloadgentoo-2-b69f17d820b4f8e1be07432128b9ac72a7f38627.tar.gz
gentoo-2-b69f17d820b4f8e1be07432128b9ac72a7f38627.tar.bz2
gentoo-2-b69f17d820b4f8e1be07432128b9ac72a7f38627.zip
Fix compiler warnings.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/epson-inkjet-printer-escpr/ChangeLog6
-rw-r--r--net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.4.4.ebuild6
-rw-r--r--net-print/epson-inkjet-printer-escpr/files/1.4.4-warnings.patch43
3 files changed, 53 insertions, 2 deletions
diff --git a/net-print/epson-inkjet-printer-escpr/ChangeLog b/net-print/epson-inkjet-printer-escpr/ChangeLog
index 1fb9f5b8c6a6..6a87703a567e 100644
--- a/net-print/epson-inkjet-printer-escpr/ChangeLog
+++ b/net-print/epson-inkjet-printer-escpr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/epson-inkjet-printer-escpr
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/epson-inkjet-printer-escpr/ChangeLog,v 1.2 2015/01/15 04:50:33 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/epson-inkjet-printer-escpr/ChangeLog,v 1.3 2015/01/15 05:15:22 floppym Exp $
+
+ 15 Jan 2015; Mike Gilbert <floppym@gentoo.org> +files/1.4.4-warnings.patch,
+ epson-inkjet-printer-escpr-1.4.4.ebuild:
+ Fix compiler warnings.
15 Jan 2015; Mike Gilbert <floppym@gentoo.org>
epson-inkjet-printer-escpr-1.4.4.ebuild:
diff --git a/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.4.4.ebuild b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.4.4.ebuild
index d96f20261e74..2388af965e6d 100644
--- a/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.4.4.ebuild
+++ b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.4.4.ebuild,v 1.2 2015/01/15 04:50:33 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.4.4.ebuild,v 1.3 2015/01/15 05:15:22 floppym Exp $
EAPI=5
@@ -18,6 +18,10 @@ IUSE=""
DEPEND="net-print/cups"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}/1.4.4-warnings.patch"
+}
+
src_configure() {
econf --disable-static
}
diff --git a/net-print/epson-inkjet-printer-escpr/files/1.4.4-warnings.patch b/net-print/epson-inkjet-printer-escpr/files/1.4.4-warnings.patch
new file mode 100644
index 000000000000..34ec1737d53b
--- /dev/null
+++ b/net-print/epson-inkjet-printer-escpr/files/1.4.4-warnings.patch
@@ -0,0 +1,43 @@
+--- a/lib/epson-escpage-mono.c
++++ b/lib/epson-escpage-mono.c
+@@ -885,7 +885,7 @@
+
+ EPS_LOG_FUNCIN;
+
+- memset(pBand, 0, sizeof(pBand));
++ memset(pBand, 0, sizeof(EPS_PAGE_BAND_M));
+
+ pBand->WidthInPixels = widthInPixels;
+ pBand->WidthInBytes = (pBand->WidthInPixels+7)/8;
+--- a/lib/epson-escpr-api.h
++++ b/lib/epson-escpr-api.h
+@@ -98,6 +98,9 @@
+ /*** -------------------------------------------------------------------------------*/
+ extern EPS_ERR_CODE epsMakeMainteCmd (EPS_INT32, EPS_UINT8*, EPS_UINT32* );
+
++extern EPS_ERR_CODE SetupJobAttrib (const EPS_JOB_ATTRIB* );
++extern EPS_ERR_CODE SendStartJob (EPS_BOOL );
++extern EPS_ERR_CODE PrintBand (const EPS_UINT8*, EPS_UINT32, EPS_UINT32* );
+ #ifdef __cplusplus
+ }
+ #endif
+--- a/src/filter.c
++++ b/src/filter.c
+@@ -38,6 +38,7 @@
+ #include "epson-escpr-api.h"
+ #include "epson-escpr-services.h"
+ #include "epson-escpr-mem.h"
++#include "epson-escpage.h"
+
+ #include "err.h"
+ #include "mem.h"
+--- a/src/mem.c
++++ b/src/mem.c
+@@ -23,6 +23,7 @@
+ #endif
+
+ #include <stdlib.h>
++#include "err.h"
+ #include "mem.h"
+
+ void *