summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-01-28 13:54:46 +0000
committerSimon Stelling <blubb@gentoo.org>2006-01-28 13:54:46 +0000
commit8b114c9b60af29732a412d7fb074b26ef007647d (patch)
tree3dd55aeecf5d5efb2b60e51aa82df11687848b4f /net-print
parentremove old versions (diff)
downloadgentoo-2-8b114c9b60af29732a412d7fb074b26ef007647d.tar.gz
gentoo-2-8b114c9b60af29732a412d7fb074b26ef007647d.tar.bz2
gentoo-2-8b114c9b60af29732a412d7fb074b26ef007647d.zip
no need to bzip a smallish patch
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hpoj/ChangeLog9
-rw-r--r--net-print/hpoj/files/hpoj-0.91-kernel26.patch86
-rw-r--r--net-print/hpoj/files/hpoj-0.91-kernel26.patch.bz2bin1191 -> 0 bytes
-rw-r--r--net-print/hpoj/hpoj-0.91-r3.ebuild6
4 files changed, 96 insertions, 5 deletions
diff --git a/net-print/hpoj/ChangeLog b/net-print/hpoj/ChangeLog
index c9c2fbbb83a9..9e2c5633c039 100644
--- a/net-print/hpoj/ChangeLog
+++ b/net-print/hpoj/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/hpoj
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hpoj/ChangeLog,v 1.22 2005/07/25 18:04:13 caleb Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hpoj/ChangeLog,v 1.23 2006/01/28 13:54:46 blubb Exp $
+
+ 28 Jan 2006; Simon Stelling <blubb@gentoo.org>
+ +files/hpoj-0.91-kernel26.patch, -files/hpoj-0.91-kernel26.patch.bz2,
+ hpoj-0.91-r3.ebuild:
+ no need to bzip a smallish patch
25 Jul 2005; Caleb Tennis <caleb@gentoo.org> hpoj-0.91-r3.ebuild:
Change qt dep per bug #100235
diff --git a/net-print/hpoj/files/hpoj-0.91-kernel26.patch b/net-print/hpoj/files/hpoj-0.91-kernel26.patch
new file mode 100644
index 000000000000..f86f003c44e8
--- /dev/null
+++ b/net-print/hpoj/files/hpoj-0.91-kernel26.patch
@@ -0,0 +1,86 @@
+--- scripts/ptal-init.in.orig 2004-02-26 03:29:54.319933782 +0100
++++ scripts/ptal-init.in 2004-02-26 03:30:47.143429439 +0100
+@@ -86,6 +86,11 @@
+ my $varLock="/var/lock";
+ my $varLockSubsys="$varLock/subsys";
+ my $osPlatform=`uname -s 2>/dev/null`;
++chomp $osPlatform;
++my $linuxVersion=($osPlatform eq 'Linux' ? `uname -r 2>/dev/null` : '');
++$linuxVersion=~s/^(\s*)(\d+\.\d+)(\..*)$/$2/;
++chomp $linuxVersion;
++my $usbprintermodule = ($linuxVersion eq '2.6' ? "usblp" : "printer");
+ my %devnames;
+ my %obsoleteDevnames;
+ my %configInfo;
+@@ -1218,12 +1223,12 @@
+ # undef -- skip USB probe
+ # 0 -- do nothing, proceed with USB probe
+ # >0 -- load printer.o
+-# <0 -- disable and unload printer.o
++# <0 -- disable and unload printer.o/usblp.o
+ sub linuxWhatShouldWeDoAboutUsbPrinterModule {
+ my $isSmp=&linuxIsSmp;
+ my $libusbSupported=&ptalMlcdSupportsLibusb;
+ my $usblpIsLoaded=&linuxUsblpIsLoaded;
+- my $printerIsLoaded=&linuxModuleIsLoaded("printer");
++ my $printerIsLoaded=&linuxModuleIsLoaded($usbprintermodule);
+
+ # non-SMP:
+ if (!$isSmp) {
+@@ -1257,9 +1262,10 @@
+ }
+ goto allowInsmodPrinter;
+
+- # SMP, libusb support, some sort of printer.c functionality loaded:
++ # SMP, libusb support, some sort of printer.c/usblp.c
++ # functionality loaded:
+ } elsif ($usblpIsLoaded) {
+- # printer.c compiled into the kernel:
++ # printer.c/usblp.c compiled into the kernel:
+ if (!$printerIsLoaded) {
+ if (!&askYN(
+ "\n".
+@@ -1276,7 +1282,7 @@
+ return undef;
+ }
+
+- # printer.c compiled and loaded as a module:
++ # printer.c/usblp.c compiled and loaded as a module:
+ } else {
+ promptDisableRmmodPrinter:
+ my $r=&askYN(
+@@ -1297,8 +1303,9 @@
+ }
+ }
+
+- # SMP, libusb support, printer.c enabled although not loaded:
+- } elsif (!&linuxModuleIsDisabled("printer")) {
++ # SMP, libusb support, printer.c/usblp.c enabled although not
++ # loaded:
++ } elsif (!&linuxModuleIsDisabled($usbprintermodule)) {
+ goto promptDisableRmmodPrinter;
+ }
+
+@@ -1322,11 +1329,11 @@
+ return 1;
+ }
+ if ($r<0) {
+- $r=&linuxDisableAndUnloadModule("printer",
++ $r=&linuxDisableAndUnloadModule($usbprintermodule,
+ "to prevent possible system instability due to SMP+USB");
+ } else {
+ linuxJustLoad:
+- $r=&linuxInsmod("printer",$quiet);
++ $r=&linuxInsmod($usbprintermodule,$quiet);
+ }
+ if (!$r && !$quiet &&
+ &askYN("\n*** Continue with the USB probe anyway".$msg,0)) {
+@@ -1597,7 +1604,7 @@
+
+ } else {
+ my $parModulesLoaded=0;
+- # Don't "modprobe printer" on SMP Linux with libusb support:
++ # Don't "modprobe printer/usblp" on SMP Linux with libusb support:
+ my $usbModulesLoaded=
+ (&ptalMlcdSupportsLibusb &&
+ $osPlatform=~/Linux/ && &linuxIsSmp);
diff --git a/net-print/hpoj/files/hpoj-0.91-kernel26.patch.bz2 b/net-print/hpoj/files/hpoj-0.91-kernel26.patch.bz2
deleted file mode 100644
index 36c339d9f3f7..000000000000
--- a/net-print/hpoj/files/hpoj-0.91-kernel26.patch.bz2
+++ /dev/null
Binary files differ
diff --git a/net-print/hpoj/hpoj-0.91-r3.ebuild b/net-print/hpoj/hpoj-0.91-r3.ebuild
index 0c6dcee4917b..c395a2accad1 100644
--- a/net-print/hpoj/hpoj-0.91-r3.ebuild
+++ b/net-print/hpoj/hpoj-0.91-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hpoj/hpoj-0.91-r3.ebuild,v 1.11 2005/07/25 18:04:13 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hpoj/hpoj-0.91-r3.ebuild,v 1.12 2006/01/28 13:54:46 blubb Exp $
inherit eutils qt3
@@ -22,7 +22,7 @@ DEPEND="qt? ( $(qt_min_version 3.1) )
src_compile() {
epatch ${FILESDIR}/udev.patch
- epatch ${FILESDIR}/${P}-kernel26.patch.bz2
+ epatch ${FILESDIR}/${P}-kernel26.patch
use snmp \
&& myconf="${myconf} --with-snmp=/usr" \