summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-03-14 16:29:03 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-03-14 16:29:03 +0000
commit534b7efc388e6ae40a263514f19bee1d300a8f1a (patch)
treeef2dad3817fdc6b6bf976cc0c69134ed5c603b36 /net-print
parentInstall menu entry, bug #159765 (diff)
downloadgentoo-2-534b7efc388e6ae40a263514f19bee1d300a8f1a.tar.gz
gentoo-2-534b7efc388e6ae40a263514f19bee1d300a8f1a.tar.bz2
gentoo-2-534b7efc388e6ae40a263514f19bee1d300a8f1a.zip
Version bump thanks to mark in bug 161442
(Portage version: 2.1.2-r12)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/pykota/ChangeLog9
-rw-r--r--net-print/pykota/files/digest-pykota-1.25_p24373
-rw-r--r--net-print/pykota/pykota-1.25_p2437.ebuild57
3 files changed, 67 insertions, 2 deletions
diff --git a/net-print/pykota/ChangeLog b/net-print/pykota/ChangeLog
index 8bed55b23496..8688942bd419 100644
--- a/net-print/pykota/ChangeLog
+++ b/net-print/pykota/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/pykota
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/ChangeLog,v 1.19 2006/12/11 11:11:48 aross Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/ChangeLog,v 1.20 2007/03/14 16:29:03 genstef Exp $
+
+*pykota-1.25_p2437 (14 Mar 2007)
+
+ 14 Mar 2007; <genstef@gentoo.org> +pykota-1.25_p2437.ebuild:
+ Version bump thanks to mark in bug 161442
11 Dec 2006; Andrew Ross <aross@gentoo.org> metadata.xml,
pykota-1.24_p2174.ebuild:
diff --git a/net-print/pykota/files/digest-pykota-1.25_p2437 b/net-print/pykota/files/digest-pykota-1.25_p2437
new file mode 100644
index 000000000000..f566bc932e97
--- /dev/null
+++ b/net-print/pykota/files/digest-pykota-1.25_p2437
@@ -0,0 +1,3 @@
+MD5 85d2b3f59199cda8fc6ef62ecc50883e pykota-1.25_p2437.tar.bz2 1704330
+RMD160 f11e46433bca09381018c301dd27e5e94672002b pykota-1.25_p2437.tar.bz2 1704330
+SHA256 b0d26ecaa2a0eaece67eb1040b0adcf4ab44f7a0d76380af20d4936afe7f7927 pykota-1.25_p2437.tar.bz2 1704330
diff --git a/net-print/pykota/pykota-1.25_p2437.ebuild b/net-print/pykota/pykota-1.25_p2437.ebuild
new file mode 100644
index 000000000000..d3cf932dbfe9
--- /dev/null
+++ b/net-print/pykota/pykota-1.25_p2437.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/pykota-1.25_p2437.ebuild,v 1.1 2007/03/14 16:29:03 genstef Exp $
+
+S=${WORKDIR}/${PN}
+
+inherit python eutils distutils
+
+DESCRIPTION="Flexible print quota and accounting package for use with CUPS and
+lpd."
+SRC_URI="http://scriptkitty.com/files/${P}.tar.bz2"
+HOMEPAGE="http://www.pykota.com"
+LICENSE="GPL-2"
+
+IUSE="ldap mysql postgres snmp sqlite snmp xml"
+
+DEPEND="dev-lang/python
+ dev-python/egenix-mx-base
+ net-print/pkpgcounter
+ ldap? ( dev-python/python-ldap )
+ mysql? ( dev-python/mysql-python )
+ postgres? ( dev-db/postgresql dev-db/pygresql )
+ sqlite? ( =dev-python/pysqlite-2* )
+ snmp? ( net-analyzer/net-snmp =dev-python/pysnmp-3.4.2 )
+ xml? ( dev-python/jaxml )"
+
+RDEPEND="${DEPEND}"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DOCS="README MANIFEST.in TODO SECURITY NEWS CREDITS FAQ"
+
+src_install() {
+ mkdir -p "${D}"/etc/${PN}
+ python_version
+ distutils_src_install
+ #cups backend ----------------------------------------------
+ mkdir -p "${D}"/usr/lib/cups/backend
+ dosym /usr/share/pykota/cupspykota /usr/lib/cups/backend/cupspykota
+ #extra docs: inits -----------------------------------------
+ init_dir=/usr/share/doc/${P}/initscripts
+ insinto ${init_dir}
+ cp -pPR initscripts/* "${D}"/${init_dir}
+
+ # Fixes permissions for bug 155865
+ chmod 700 "${D}"/usr/share/pykota/cupspykota
+
+ for doc in ${DOCS}; do
+ rm -f "${D}"/usr/share/doc/${PN}/${doc}
+ done
+
+ rm -f "${D}"/usr/share/doc/${PN}/{LICENSE,COPYING}
+ mv "${D}"/usr/share/doc/${PN}/* "${D}"/usr/share/doc/${P}
+ rmdir "${D}"/usr/share/doc/${PN}
+}
+