summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-08-18 22:27:38 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-08-18 22:27:38 +0000
commit3d32559d3807d8038b960de2cb2551b211ecb161 (patch)
tree35beb155421f26b8cdb56721b8412dd73e4e69fc /net-print
parentStable on amd64 wrt security Bug #131010. (diff)
downloadgentoo-2-3d32559d3807d8038b960de2cb2551b211ecb161.tar.gz
gentoo-2-3d32559d3807d8038b960de2cb2551b211ecb161.tar.bz2
gentoo-2-3d32559d3807d8038b960de2cb2551b211ecb161.zip
Fix ghostscript detection with gs-sp thanks to Sebastian Bergmann <sebastian@gentoo.org> in bug 144354
(Portage version: 2.1.1_pre5-r2)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups/ChangeLog7
-rw-r--r--net-print/cups/cups-1.1.23-r8.ebuild4
-rw-r--r--net-print/cups/cups-1.2.2.ebuild8
3 files changed, 12 insertions, 7 deletions
diff --git a/net-print/cups/ChangeLog b/net-print/cups/ChangeLog
index 7e2e4168c3a6..01c84b43fe62 100644
--- a/net-print/cups/ChangeLog
+++ b/net-print/cups/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/cups
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.194 2006/08/18 19:53:34 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.195 2006/08/18 22:27:38 genstef Exp $
+
+ 18 Aug 2006; Stefan Schweizer <genstef@gentoo.org> cups-1.1.23-r8.ebuild,
+ cups-1.2.2.ebuild:
+ Fix ghostscript detection with gs-sp thanks to Sebastian Bergmann
+ <sebastian@gentoo.org> in bug 144354
18 Aug 2006; Stefan Schweizer <genstef@gentoo.org> cups-1.2.2.ebuild:
Depend with X useflag on xdg-utils to select the browser thanks to Wiktor
diff --git a/net-print/cups/cups-1.1.23-r8.ebuild b/net-print/cups/cups-1.1.23-r8.ebuild
index cb5d0a337a64..927929c3f325 100644
--- a/net-print/cups/cups-1.1.23-r8.ebuild
+++ b/net-print/cups/cups-1.1.23-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.1.23-r8.ebuild,v 1.3 2006/08/17 23:59:44 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.1.23-r8.ebuild,v 1.4 2006/08/18 22:27:38 genstef Exp $
inherit eutils flag-o-matic pam autotools
@@ -169,7 +169,7 @@ pkg_postinst() {
local good_gs=false
for x in app-text/ghostscript-gpl app-text/ghostscript-gnu app-text/ghostscript-esp; do
- if built_with_use ${x} cups; then
+ if has_version ${x} && built_with_use ${x} cups; then
good_gs=true
break
fi
diff --git a/net-print/cups/cups-1.2.2.ebuild b/net-print/cups/cups-1.2.2.ebuild
index a676800125b4..afa4361d2480 100644
--- a/net-print/cups/cups-1.2.2.ebuild
+++ b/net-print/cups/cups-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.2.2.ebuild,v 1.3 2006/08/18 19:53:34 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.2.2.ebuild,v 1.4 2006/08/18 22:27:38 genstef Exp $
inherit autotools eutils flag-o-matic multilib pam
@@ -166,7 +166,7 @@ pkg_postinst() {
local good_gs=false
for x in app-text/ghostscript-gpl app-text/ghostscript-gnu app-text/ghostscript-esp; do
- if built_with_use ${x} cups; then
+ if has_version ${x} && built_with_use ${x} cups; then
good_gs=true
break
fi
@@ -189,8 +189,8 @@ pkg_postinst() {
ewarn "installed into /usr/lib/cups and /etc/cups, qfile is in portage-utils:"
ewarn "# FEATURES=-collision-protect emerge -va1 \$(qfile -qC /usr/lib/cups /etc/cups | sed \"s:net-print/cups$::\")"
ewarn
- einfo "FEATURES=-collision-protect is needed to overwrite the compatibility"
- einfo "symlinks installed by this package, it wont be needed on later merges."
+ ewarn "FEATURES=-collision-protect is needed to overwrite the compatibility"
+ ewarn "symlinks installed by this package, it wont be needed on later merges."
ewarn "You should also run revdep-rebuild"
# place symlinks to make the update smoothless