summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2005-12-14 20:01:19 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2005-12-14 20:01:19 +0000
commit008a3e3a9a825098ac4401f48c1519eec74b244b (patch)
treec46bb497262483140ec674ea235ee7d5cd2e6065 /net-print
parentAdded function to get the shell for a given user, and a wrapper function to c... (diff)
downloadgentoo-2-008a3e3a9a825098ac4401f48c1519eec74b244b.tar.gz
gentoo-2-008a3e3a9a825098ac4401f48c1519eec74b244b.tar.bz2
gentoo-2-008a3e3a9a825098ac4401f48c1519eec74b244b.zip
Allow configuration of bindnow-flags. Bug #115504
(Portage version: 2.0.53)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups/ChangeLog8
-rw-r--r--net-print/cups/cups-1.1.23-r5.ebuild170
-rw-r--r--net-print/cups/files/cups-1.1.23-bindnow.patch47
-rw-r--r--net-print/cups/files/digest-cups-1.1.23-r51
4 files changed, 225 insertions, 1 deletions
diff --git a/net-print/cups/ChangeLog b/net-print/cups/ChangeLog
index 9a6af5b8fa55..30b41ef78a04 100644
--- a/net-print/cups/ChangeLog
+++ b/net-print/cups/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/cups
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.143 2005/12/14 11:58:34 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.144 2005/12/14 20:01:19 dang Exp $
+
+*cups-1.1.23-r5 (14 Dec 2005)
+
+ 14 Dec 2005; <dang@gentoo.org> +files/cups-1.1.23-bindnow.patch,
+ +cups-1.1.23-r5.ebuild:
+ Allow configuration of bindnow-flags. Bug #115504
14 Dec 2005; Fernando J. Pereda <ferdy@gentoo.org> cups-1.1.23-r4.ebuild:
stable on alpha wrt bug #115286
diff --git a/net-print/cups/cups-1.1.23-r5.ebuild b/net-print/cups/cups-1.1.23-r5.ebuild
new file mode 100644
index 000000000000..1de1d5945466
--- /dev/null
+++ b/net-print/cups/cups-1.1.23-r5.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.1.23-r5.ebuild,v 1.1 2005/12/14 20:01:19 dang Exp $
+
+inherit eutils flag-o-matic pam autotools
+
+MY_P=${P/_/}
+
+DESCRIPTION="The Common Unix Printing System"
+HOMEPAGE="http://www.cups.org/"
+SRC_URI="ftp://ftp2.easysw.com/pub/cups/test/${MY_P}-source.tar.bz2
+ftp://ftp.easysw.com/pub/cups/test/${MY_P}-source.tar.bz2
+ftp://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/test/${MY_P}-source.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="ssl slp pam samba nls cjk gnutls"
+
+DEP="pam? ( virtual/pam )
+ ssl? (
+ !gnutls? ( >=dev-libs/openssl-0.9.6b )
+ gnutls? ( net-libs/gnutls )
+ )
+ slp? ( >=net-libs/openslp-1.0.4 )
+ nls? ( sys-devel/gettext )
+ >=media-libs/libpng-1.2.1
+ >=media-libs/tiff-3.5.5
+ >=media-libs/jpeg-6b"
+DEPEND="${DEP}
+ >=sys-devel/autoconf-2.58"
+RDEPEND="${DEP}
+ !virtual/lpr
+ app-text/xpdf"
+PDEPEND="samba? ( >=net-fs/samba-3.0.8 )"
+PROVIDE="virtual/lpr"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ enewgroup lp
+ enewuser lp -1 -1 -1 lp
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/disable-strip.patch
+ epatch ${FILESDIR}/cups-gcc4-amd64.patch #79791
+ epatch ${FILESDIR}/cups-gentooalt.patch
+ epatch ${FILESDIR}/${P}-bindnow.patch
+ eautoconf
+
+ # disable builtin xpdf
+ sed -i -e "s:pdftops::" Makefile
+}
+
+src_compile() {
+
+ local myconf
+ use amd64 && replace-flags -Os -O2
+
+ use ssl && \
+ myconf="${myconf} $(use_enable gnutls) $(use_enable !gnutls openssl)"
+
+ econf \
+ --with-cups-user=lp \
+ --with-cups-group=lp \
+ --localstatedir=/var \
+ --with-bindnow=$(bindnow_flags) \
+ $(use_enable pam) \
+ $(use_enable ssl) \
+ $(use_enable slp) \
+ $(use_enable nls) \
+ ${myconf} \
+ || die "econf failed"
+
+ emake || die "compile problem"
+}
+
+src_test() {
+ # upstream includes an interactive test which is a nono for gentoo.
+ # therefore, since the printing herd has bigger fish to fry, for now,
+ # we just leave it out, even if FEATURES=test
+ true
+}
+
+src_install() {
+ dodir /var/spool /var/log/cups /etc/cups
+
+ make \
+ LOCALEDIR=${D}/usr/share/locale \
+ DOCDIR=${D}/usr/share/cups/docs \
+ REQUESTS=${D}/var/spool/cups \
+ SERVERBIN=${D}/usr/$(get_libdir)/cups \
+ DATADIR=${D}/usr/share/cups \
+ INCLUDEDIR=${D}/usr/include \
+ AMANDIR=${D}/usr/share/man \
+ PMANDIR=${D}/usr/share/man \
+ MANDIR=${D}/usr/share/man \
+ SERVERROOT=${D}/etc/cups \
+ LOGDIR=${D}/var/log/cups \
+ SBINDIR=${D}/usr/sbin \
+ PAMDIR=${D}/etc/pam.d \
+ EXEC_PREFIX=${D}/usr \
+ LIBDIR=${D}/usr/$(get_libdir) \
+ BINDIR=${D}/usr/bin \
+ bindir=${D}/usr/bin \
+ INITDIR=${D}/etc \
+ PREFIX=${D} \
+ install || die "install problem"
+
+ dodoc {CHANGES,CREDITS,ENCRYPTION,LICENSE,README}.txt
+ dosym /usr/share/cups/docs /usr/share/doc/${PF}/html
+
+ # cleanups
+ rm -rf ${D}/etc/init.d ${D}/etc/pam.d ${D}/etc/rc* ${D}/usr/share/man/cat* \
+ ${D}/etc/cups/{certs,interfaces,ppd} ${D}/var
+
+ sed -i -e "s:^#\(DocumentRoot\).*:\1 /usr/share/cups/docs:" \
+ -e "s:^#\(SystemGroup\).*:\1 lp:" \
+ -e "s:^#\(User\).*:\1 lp:" \
+ -e "s:^#\(Group\).*:\1 lp:" \
+ ${D}/etc/cups/cupsd.conf
+
+ pamd_mimic_system cups auth account
+
+ newinitd ${FILESDIR}/cupsd.rc6 cupsd
+ insinto /etc/xinetd.d ; newins ${FILESDIR}/cups.xinetd cups-lpd
+
+ # allow raw printing
+ dosed "s:#application/octet-stream:application/octet-stream:" /etc/cups/mime.types /etc/cups/mime.convs
+
+ # Let foreign charset PDF's print. (Bug: 67493)
+ dosym /etc/xpdfrc /etc/cups/pdftops.conf
+
+ # install pdftops filter
+ exeinto /usr/lib/cups/filter/
+ newexe ${FILESDIR}/pdftops.pl pdftops
+ dosed "s:/usr/local:/usr:" /usr/lib/cups/filter/pdftops
+}
+
+pkg_preinst() {
+ # cleanups
+ [ -n "${PN}" ] && rm -fR /usr/share/doc/${PN}-*
+}
+
+pkg_postinst() {
+ install -d -m0755 ${ROOT}/var/log/cups
+ install -d -m0755 ${ROOT}/var/spool
+ install -m0700 -o lp -d ${ROOT}/var/spool/cups
+ install -m1700 -o lp -d ${ROOT}/var/spool/cups/tmp
+ install -m0711 -o lp -d ${ROOT}/etc/cups/certs
+ install -d -m0755 ${ROOT}/etc/cups/{interfaces,ppd}
+
+ einfo "If you're using a USB printer, \"emerge coldplug; rc-update add"
+ einfo "coldplug boot\" is something you should probably do. This"
+ einfo "will allow any USB kernel modules (if present) to be loaded"
+ einfo "automatically at boot."
+ einfo
+ einfo "For more information about installing a printer take a look at:"
+ einfo "http://www.gentoo.org/doc/en/printing-howto.xml."
+
+ if useq cjk ; then
+ einfo
+ einfo "If you want CJK support on PDF's you'll need to re-emerge"
+ einfo "app-text/xpdf with your LINGUAS variable set instead of"
+ einfo "the CJK flag. (Bug: 67493)"
+ fi
+}
diff --git a/net-print/cups/files/cups-1.1.23-bindnow.patch b/net-print/cups/files/cups-1.1.23-bindnow.patch
new file mode 100644
index 000000000000..cfed45cd7ac4
--- /dev/null
+++ b/net-print/cups/files/cups-1.1.23-bindnow.patch
@@ -0,0 +1,47 @@
+diff --exclude-from=/home/dang/.diffrc -u -ruN cups-1.1.23.orig/config-scripts/cups-setXid.m4 cups-1.1.23/config-scripts/cups-setXid.m4
+--- cups-1.1.23.orig/config-scripts/cups-setXid.m4 1969-12-31 19:00:00.000000000 -0500
++++ cups-1.1.23/config-scripts/cups-setXid.m4 2005-12-14 14:30:10.000000000 -0500
+@@ -0,0 +1,9 @@
++dnl
++dnl Copyright 1999-2005 Gentoo Foundation
++dnl Distributed under the terms of the GNU General Public License v2
++dnl
++
++AC_ARG_WITH(bindnow, [ --with-bindnow Set linker flags for force-binding setuid binaries],
++ BINDNOW_FLAGS="$withval",
++ BINDNOW_FLAGS="")
++AC_SUBST(BINDNOW_FLAGS)
+diff --exclude-from=/home/dang/.diffrc -u -ruN cups-1.1.23.orig/configure.in cups-1.1.23/configure.in
+--- cups-1.1.23.orig/configure.in 2005-01-03 14:29:44.000000000 -0500
++++ cups-1.1.23/configure.in 2005-12-14 14:30:36.000000000 -0500
+@@ -40,6 +40,7 @@
+ sinclude(config-scripts/cups-pam.m4)
+
+ sinclude(config-scripts/cups-scripting.m4)
++sinclude(config-scripts/cups-setXid.m4)
+
+ AC_OUTPUT(Makedefs cups.list cups.sh cups-config conf/cupsd.conf conf/pam.std)
+
+diff --exclude-from=/home/dang/.diffrc -u -ruN cups-1.1.23.orig/Makedefs.in cups-1.1.23/Makedefs.in
+--- cups-1.1.23.orig/Makedefs.in 2005-01-03 14:29:44.000000000 -0500
++++ cups-1.1.23/Makedefs.in 2005-12-14 13:55:48.000000000 -0500
+@@ -93,6 +93,7 @@
+ DSOLIBS = @DSOLIBS@ $(COMMONLIBS)
+ IMGLIBS = @IMGLIBS@ -lm
+ LDFLAGS = -L../cups -L../filter $(RC_CFLAGS) @LDFLAGS@ $(OPTIM)
++BINDNOW_FLAGS = @BINDNOW_FLAGS@
+ LINKCUPS = @LINKCUPS@
+ LINKCUPSIMAGE = @LINKCUPSIMAGE@
+ LIBS = $(LINKCUPS) $(NETLIBS) @LIBS@ $(COMMONLIBS)
+diff --exclude-from=/home/dang/.diffrc -u -ruN cups-1.1.23.orig/systemv/Makefile cups-1.1.23/systemv/Makefile
+--- cups-1.1.23.orig/systemv/Makefile 2005-01-03 14:29:59.000000000 -0500
++++ cups-1.1.23/systemv/Makefile 2005-12-14 13:55:09.000000000 -0500
+@@ -174,7 +174,7 @@
+
+ lppasswd: lppasswd.o ../cups/$(LIBCUPS)
+ echo Linking $@...
+- $(CC) $(LDFLAGS) -o lppasswd lppasswd.o $(LIBZ) $(LIBS)
++ $(CC) $(LDFLAGS) $(BINDNOW_FLAGS) -o lppasswd lppasswd.o $(LIBZ) $(LIBS)
+
+
+ #
diff --git a/net-print/cups/files/digest-cups-1.1.23-r5 b/net-print/cups/files/digest-cups-1.1.23-r5
new file mode 100644
index 000000000000..64352b8bc3d5
--- /dev/null
+++ b/net-print/cups/files/digest-cups-1.1.23-r5
@@ -0,0 +1 @@
+MD5 4ce09b1dce09b6b9398af0daae9adf63 cups-1.1.23-source.tar.bz2 8705521