summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-01-31 22:30:20 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-01-31 22:30:20 +0000
commitda6039443cee33777e9305764486b4e5202418d4 (patch)
tree7722bd29d8b0cb8872eb0bccb752cdbb67ec78c7 /net-print/pykota
parentMarked ~hppa too. (diff)
downloadgentoo-2-da6039443cee33777e9305764486b4e5202418d4.tar.gz
gentoo-2-da6039443cee33777e9305764486b4e5202418d4.tar.bz2
gentoo-2-da6039443cee33777e9305764486b4e5202418d4.zip
Version bump
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-print/pykota')
-rw-r--r--net-print/pykota/ChangeLog9
-rw-r--r--net-print/pykota/pykota-1.26.ebuild65
2 files changed, 72 insertions, 2 deletions
diff --git a/net-print/pykota/ChangeLog b/net-print/pykota/ChangeLog
index 9de5837f14b9..84371d01c993 100644
--- a/net-print/pykota/ChangeLog
+++ b/net-print/pykota/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/pykota
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/ChangeLog,v 1.27 2011/06/02 17:57:12 dilfridge Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/ChangeLog,v 1.28 2012/01/31 22:30:20 dilfridge Exp $
+
+*pykota-1.26 (31 Jan 2012)
+
+ 31 Jan 2012; Andreas K. Huettel <dilfridge@gentoo.org> +pykota-1.26.ebuild:
+ Version bump
02 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org>
pykota-1.25_p2437-r1.ebuild:
diff --git a/net-print/pykota/pykota-1.26.ebuild b/net-print/pykota/pykota-1.26.ebuild
new file mode 100644
index 000000000000..8c8c3c1a8764
--- /dev/null
+++ b/net-print/pykota/pykota-1.26.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/pykota-1.26.ebuild,v 1.1 2012/01/31 22:30:20 dilfridge Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="Flexible print quota and accounting package for use with CUPS and lpd."
+HOMEPAGE="http://www.pykota.com"
+SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres snmp sqlite snmp xml"
+
+DEPEND="dev-lang/python
+ dev-python/egenix-mx-base
+ net-print/pkpgcounter
+ dev-python/chardet
+ dev-python/pkipplib
+ ldap? ( dev-python/python-ldap )
+ mysql? ( dev-python/mysql-python )
+ postgres? ( dev-db/postgresql-server dev-db/pygresql )
+ sqlite? ( dev-python/pysqlite:2 )
+ snmp? ( net-analyzer/net-snmp =dev-python/pysnmp-3.4* )
+ xml? ( dev-python/jaxml )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}"
+
+DOCS="README TODO SECURITY CREDITS FAQ"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ dodir /etc/${PN} || die
+ distutils_src_install
+
+ # cups backend ----------------------------------------------
+
+ dodir $(cups-config --serverbin)/backend || die
+ dosym /usr/share/pykota/cupspykota $(cups-config --serverbin)/backend/cupspykota || die
+
+ # extra docs: inits -----------------------------------------
+
+ init_dir="/usr/share/doc/${PF}/initscripts"
+ insinto "${init_dir}"
+ doins -r initscripts/* || die
+
+ # Fixes permissions for bug 155865
+ chmod 700 "${D}"/usr/share/pykota/cupspykota
+
+ for doc in ${DOCS}; do
+ rm "${D}"/usr/share/doc/${PN}/${doc} || die
+ done
+ rm "${D}"/usr/share/doc/${PN}/{LICENSE,COPYING} || die
+ mv "${D}"/usr/share/doc/${PN}/* "${D}"/usr/share/doc/${PF}/ || die
+ rmdir "${D}"/usr/share/doc/${PN} || die
+}