summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-10-27 20:31:27 +0000
committerThilo Bangert <bangert@gentoo.org>2009-10-27 20:31:27 +0000
commit8069ce0a994df899457ccca6505abc5ed8e3926f (patch)
tree1a79f8f7bd46ba28d5a7cb62a96a1c17372b9087 /net-print/mtink
parentversion bump, #281021 (diff)
downloadgentoo-2-8069ce0a994df899457ccca6505abc5ed8e3926f.tar.gz
gentoo-2-8069ce0a994df899457ccca6505abc5ed8e3926f.tar.bz2
gentoo-2-8069ce0a994df899457ccca6505abc5ed8e3926f.zip
version bump (bug #204163)
(Portage version: 2.2_rc46/cvs/Linux i686)
Diffstat (limited to 'net-print/mtink')
-rw-r--r--net-print/mtink/ChangeLog9
-rw-r--r--net-print/mtink/mtink-1.0.16.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/net-print/mtink/ChangeLog b/net-print/mtink/ChangeLog
index 29991d63a6d7..d8192fb38cad 100644
--- a/net-print/mtink/ChangeLog
+++ b/net-print/mtink/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/mtink
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/mtink/ChangeLog,v 1.30 2008/06/27 10:15:52 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/mtink/ChangeLog,v 1.31 2009/10/27 20:31:27 bangert Exp $
+
+*mtink-1.0.16 (27 Oct 2009)
+
+ 27 Oct 2009; Thilo Bangert <bangert@gentoo.org> +mtink-1.0.16.ebuild:
+ version bump (bug #204163)
27 Jun 2008; Ulrich Mueller <ulm@gentoo.org> mtink-1.0.11.ebuild:
Change dependency from virtual/motif to x11-libs/openmotif, bug 224749.
diff --git a/net-print/mtink/mtink-1.0.16.ebuild b/net-print/mtink/mtink-1.0.16.ebuild
new file mode 100644
index 000000000000..6d0dfe9c3c36
--- /dev/null
+++ b/net-print/mtink/mtink-1.0.16.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/mtink/mtink-1.0.16.ebuild,v 1.1 2009/10/27 20:31:27 bangert Exp $
+
+EAPI="2"
+inherit eutils
+
+DESCRIPTION="mtink is a status monitor and inkjet cartridge changer for some Epson printers"
+HOMEPAGE="http://xwtools.automatix.de/"
+SRC_URI="http://xwtools.automatix.de/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cups doc X"
+
+DEPEND="X? ( x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt
+ x11-libs/openmotif )
+ cups? ( net-print/cups )
+ dev-libs/libusb"
+
+src_prepare() {
+ #prevent stripping
+ sed -i -e 's:DBG =.*:DBG =:' Makefile.ORG
+}
+
+src_configure() {
+ ./Configure || die
+}
+
+src_compile() {
+ local mytargets
+ mytargets="ttink detect/askPrinter mtinkd"
+
+ if use X; then
+ mytargets="${mytargets} mtink mtinkc";
+ fi
+
+ make ${mytargets} || die "Compile problem"
+}
+
+src_install() {
+ dobin ttink detect/askPrinter
+
+ if use X; then
+ dobin mtinkc mtink
+ fi
+
+ dosbin mtinkd
+
+ newinitd "${FILESDIR}"/mtinkd.rc mtinkd
+ newconfd "${FILESDIR}"/mtinkd.confd mtinkd
+
+ if use cups; then
+ exeinto /usr/lib/cups/backend
+ doexe etc/mtink-cups
+ fi
+
+ dodoc README CHANGE.LOG
+ use doc && \
+ dohtml html/*.gif html/*.html
+}
+
+pkg_postinst() {
+ # see #70310
+ chmod 700 /var/mtink /var/run/mtink 2>/dev/null
+
+ elog
+ elog "mtink needs correct permissions to access printer device."
+ elog "To do this you either need to run the following chmod command:"
+ elog "chmod 666 /dev/<device>"
+ elog "or set the suid bit on mtink, mtinkc and ttink in /usr/bin"
+ elog
+}