summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-01-02 11:49:16 +0000
committerThilo Bangert <bangert@gentoo.org>2010-01-02 11:49:16 +0000
commit99fc1b72b67769a69fb12d883f3c1491f1cd529d (patch)
tree4f43b717f60ab9835c8e6ab2e1bcad6e9a49aa04 /net-print/ink
parentTransfer Prefix keywords (diff)
downloadgentoo-2-99fc1b72b67769a69fb12d883f3c1491f1cd529d.tar.gz
gentoo-2-99fc1b72b67769a69fb12d883f3c1491f1cd529d.tar.bz2
gentoo-2-99fc1b72b67769a69fb12d883f3c1491f1cd529d.zip
dont mess with CFLAGS - use LDFLAGS (bug #248163 again)
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'net-print/ink')
-rw-r--r--net-print/ink/ChangeLog8
-rw-r--r--net-print/ink/files/ink-0.5.0-asneeded.patch10
-rw-r--r--net-print/ink/ink-0.5.0.ebuild10
3 files changed, 21 insertions, 7 deletions
diff --git a/net-print/ink/ChangeLog b/net-print/ink/ChangeLog
index b834e990c7ab..c62ce76ccbaa 100644
--- a/net-print/ink/ChangeLog
+++ b/net-print/ink/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/ink
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/ink/ChangeLog,v 1.13 2009/10/27 21:09:11 bangert Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/ink/ChangeLog,v 1.14 2010/01/02 11:49:16 bangert Exp $
+
+ 02 Jan 2010; Thilo Bangert <bangert@gentoo.org> ink-0.5.0.ebuild,
+ +files/ink-0.5.0-asneeded.patch:
+ dont mess with CFLAGS - use LDFLAGS (bug #248163 again)
*ink-0.5.0 (27 Oct 2009)
diff --git a/net-print/ink/files/ink-0.5.0-asneeded.patch b/net-print/ink/files/ink-0.5.0-asneeded.patch
new file mode 100644
index 000000000000..f8e8d0c3aae5
--- /dev/null
+++ b/net-print/ink/files/ink-0.5.0-asneeded.patch
@@ -0,0 +1,10 @@
+--- Makefile.orig 2010-01-02 12:40:28.000000000 +0100
++++ Makefile 2010-01-02 12:40:51.000000000 +0100
+@@ -1,6 +1,6 @@
+ DESTDIR =
+ PREFIX = /usr/local/
+-CFLAGS += -Wall -O2 -linklevel
++LDLIBS = -linklevel
+ CC = gcc
+ OS=linux
+
diff --git a/net-print/ink/ink-0.5.0.ebuild b/net-print/ink/ink-0.5.0.ebuild
index 2612712041a2..5ca1f11e8120 100644
--- a/net-print/ink/ink-0.5.0.ebuild
+++ b/net-print/ink/ink-0.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/ink/ink-0.5.0.ebuild,v 1.1 2009/10/27 21:09:11 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/ink/ink-0.5.0.ebuild,v 1.2 2010/01/02 11:49:16 bangert Exp $
EAPI="2"
inherit eutils
@@ -17,9 +17,9 @@ IUSE=""
DEPEND=">net-print/libinklevel-0.8"
RDEPEND="${DEPEND}"
-#src_prepare() {
-# epatch "${FILESDIR}"/${P}-asneeded.patch
-#}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
src_install () {
emake PREFIX="/usr" DESTDIR="${D}" install || die "emake install failed"