summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-07-15 13:08:21 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-07-15 13:08:21 +0000
commitaa87953cfe5b3c3178b9918771338981553eebba (patch)
tree6d905a026330af60b16dd1445acc34656f13d67e /net-print/hpoj
parentfixed several bugs (diff)
downloadgentoo-2-aa87953cfe5b3c3178b9918771338981553eebba.tar.gz
gentoo-2-aa87953cfe5b3c3178b9918771338981553eebba.tar.bz2
gentoo-2-aa87953cfe5b3c3178b9918771338981553eebba.zip
fixed several bugs
Diffstat (limited to 'net-print/hpoj')
-rw-r--r--net-print/hpoj/ChangeLog11
-rw-r--r--net-print/hpoj/Manifest2
-rw-r--r--net-print/hpoj/files/digest-hpoj-0.90-r11
-rw-r--r--net-print/hpoj/files/hpoj.init16
-rw-r--r--net-print/hpoj/hpoj-0.90-r1.ebuild94
5 files changed, 121 insertions, 3 deletions
diff --git a/net-print/hpoj/ChangeLog b/net-print/hpoj/ChangeLog
index c0a4ee04edad..9c61c0b4f8cf 100644
--- a/net-print/hpoj/ChangeLog
+++ b/net-print/hpoj/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/hpoj
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hpoj/ChangeLog,v 1.2 2003/06/21 06:38:21 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hpoj/ChangeLog,v 1.3 2003/07/15 13:08:13 lanius Exp $
+
+*hpoj-0.90-r1 (15 Jul 2003)
+
+ 15 Jul 2003; Heinrich Wendel <lanius@gentoo.org> hpoj-0.90-r1.ebuild,
+ files/hpoj.init:
+ fixed bugs: #23304 (init.d wrapper script), #23010 (X dep fix),
+ #21109 (use usb = libusb dep), #21108(init.d before cupsd)
20 Jun 2003; <msterret@gentoo.org> hpoj-0.90.ebuild:
stop the creation of /dosym (bug 23208)
@@ -9,4 +16,4 @@
*hpoj-0.90 (25 Apr 2003)
25 Apr 2003; Thomas Raschbacher <lordvan@gentoo.org> hpoj-0.90.ebuild
initial import (bug #11527 )
- \ No newline at end of file
+
diff --git a/net-print/hpoj/Manifest b/net-print/hpoj/Manifest
index 8b16bb621065..4a6d300aa974 100644
--- a/net-print/hpoj/Manifest
+++ b/net-print/hpoj/Manifest
@@ -1,4 +1,4 @@
-MD5 7c99716d56de7c76430607384b166e99 ChangeLog 479
+MD5 ea98eeebe2ba4d24863e42a40da0b3a4 ChangeLog 726
MD5 8418c74c513841d527fd5746fe371b65 hpoj-0.90.ebuild 2798
MD5 c9040b2f601f5243c073c5e9c4d8595a hpoj-0.90-r1.ebuild 2753
MD5 dc8b953d80ad954d0016f88452864fa5 files/hpoj.init 195
diff --git a/net-print/hpoj/files/digest-hpoj-0.90-r1 b/net-print/hpoj/files/digest-hpoj-0.90-r1
new file mode 100644
index 000000000000..c59058653efc
--- /dev/null
+++ b/net-print/hpoj/files/digest-hpoj-0.90-r1
@@ -0,0 +1 @@
+MD5 dd76385c20bccabf6f5446b1004d8372 hpoj-0.90.tgz 492881
diff --git a/net-print/hpoj/files/hpoj.init b/net-print/hpoj/files/hpoj.init
new file mode 100644
index 000000000000..cba5f176f0f2
--- /dev/null
+++ b/net-print/hpoj/files/hpoj.init
@@ -0,0 +1,16 @@
+#!/sbin/runscript
+depend() {
+ before cupsd
+}
+
+start() {
+ ebegin "Starting hpoj"
+ /usr/sbin/ptal-init start -q
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping hpoj"
+ /usr/sbin/ptal-init stop -q
+ eend $?
+}
diff --git a/net-print/hpoj/hpoj-0.90-r1.ebuild b/net-print/hpoj/hpoj-0.90-r1.ebuild
new file mode 100644
index 000000000000..1a6d988c0ece
--- /dev/null
+++ b/net-print/hpoj/hpoj-0.90-r1.ebuild
@@ -0,0 +1,94 @@
+DESCRIPTION="HP OfficeJet Linux driver"
+HOMEPAGE="http://hpoj.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hpoj/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ssl scanner qt X snmp cups usb"
+
+DEPEND="qt? ( >=x11-libs/qt-3.1.0-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6h )
+ scanner? ( >=media-gfx/sane-backends-1.0.9 )
+ scanner? ( || ( X? ( >=media-gfx/xsane-0.89 ) >=media-gfx/sane-frontends-1.0.9 ) )
+ snmp? ( >=net-analyzer/ucd-snmp-4.2.6 )
+ cups? ( >=net-print/cups-1.1.18-r2 )
+ usb? ( dev-libs/libusb )
+ >=net-print/hpijs-1.3.1"
+RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf
+ use snmp \
+ && myconf="${myconf} --with-snmp=/usr" \
+ || myconf="${myconf} --without-snmp"
+
+ use cups \
+ && myconf="${myconf} --with-cups-backend=/usr" \
+ || myconf="${myconf} --without-cups"
+
+ # xojpanel
+ use qt \
+ && myconf="${myconf} --with-qt=/usr/qt/3" \
+ || myconf="${myconf} --without-qt"
+
+ use scanner \
+ && myconf="${myconf} --with-sane-packend=/usr" \
+ || myconf="${myconf} --without-sane"
+
+ econf ${myconf}
+# patch -p0 ${S}/mlcd/Makefile < ${FILESDIR}/mlcd_make.patch
+# patch -p0 ${S}/mlcd/ExMgr.cpp < ${FILESDIR}/ExMgr.cpp_patch
+ make || die "compilation failed"
+}
+## after cups
+src_install() {
+ cd apps/cmdline
+ dobin ptal-print hpojip-test ptal-connect ptal-device ptal-devid ptal-hp ptal-pml
+ cd ../../doc
+ dohtml *html
+ cd ..
+ dodoc COPYING LICENSE LICENSE.OpenSSL README
+ use qt && dobin apps/xojpanel/xojpanel
+ dodir /usr/include
+ insinto /usr/include
+ doins include/hpojip.h include/ptal.h
+ cd lib
+ dolib.so hpojip/libhpojip.so*
+ dolib.so ptal/libptal.so*
+ dodir /usr/lib/sane
+ insinto /usr/lib/sane
+ doins sane/libsane-hpoj.so*
+ dodir /usr/lib/ghostscript/filt \
+ /usr/lib/ghostscript/filt/bjc600 \
+ /usr/lib/ghostscript/filt/bjc600.1 \
+ /usr/lib/ghostscript/filt/bjc600.16 \
+ /usr/lib/ghostscript/filt/bjc600.24 \
+ /usr/lib/ghostscript/filt/bjc600.24.3 \
+ /usr/lib/ghostscript/filt/bjc600.32 \
+ /usr/lib/ghostscript/filt/bjc600.8 \
+ /usr/lib/ghostscript/filt/bjc600.8.1 \
+ /usr/lib/ghostscript/filt/bjt600.32 \
+ /usr/lib/ghostscript/filt/direct \
+ /usr/lib/ghostscript/filt/gsif \
+ /usr/lib/ghostscript/filt/indirect \
+ /usr/lib/ghostscript/filt
+ cd ..
+ dosbin apps/cmdline/ptal-photod apps/cmdline/ptal-printd mlcd/ptal-mlcd scripts/ptal-cups
+ exeinto /usr/sbin
+ doexe scripts/ptal-init
+ dodir /usr/lib/cups/backend
+ dosym /usr/sbin/ptal-cups /usr/lib/cups/backend/ptal
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hpoj.init hpoj
+}
+
+pkg_postinst() {
+ echo
+ einfo "You might want to emerge net-print/hpijs too for better quality"
+ einfo "or app-admin/mtools for photo-card support."
+ echo
+ einfo "Before starting hpoj you have to set it up with 'ptal-init setup'"
+ echo
+}