summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-08-15 11:08:00 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-08-15 11:08:00 +0000
commitf16314f105a54e942ae9198e472cebcd5db81eab (patch)
treecb7e7b360f35ff88f36e09ad03a89bb3efbac9e0 /net-print/hplip
parentRemove no-nptl profile. Marked deprecated long ago (diff)
downloadgentoo-2-f16314f105a54e942ae9198e472cebcd5db81eab.tar.gz
gentoo-2-f16314f105a54e942ae9198e472cebcd5db81eab.tar.bz2
gentoo-2-f16314f105a54e942ae9198e472cebcd5db81eab.zip
Fixed minor bug in debug output of device.py.
(Portage version: 2.2_rc7/cvs/Linux 2.6.25-gentoo-r6 i686)
Diffstat (limited to 'net-print/hplip')
-rw-r--r--net-print/hplip/ChangeLog5
-rw-r--r--net-print/hplip/hplip-2.8.6b.ebuild11
2 files changed, 12 insertions, 4 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index 6b38ceea69d8..3afabe86a3c6 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.106 2008/08/12 15:53:28 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.107 2008/08/15 11:08:00 calchan Exp $
+
+ 15 Aug 2008; Denis Dupeyron <calchan@gentoo.org> hplip-2.8.6b.ebuild:
+ Fixed minor bug in debug output of device.py.
12 Aug 2008; Brent Baude <ranger@gentoo.org> hplip-2.8.6b.ebuild:
Marking hplip-2.8.6b ppc stable. Went direct to stable per security
diff --git a/net-print/hplip/hplip-2.8.6b.ebuild b/net-print/hplip/hplip-2.8.6b.ebuild
index 8f350472a459..fd373208c149 100644
--- a/net-print/hplip/hplip-2.8.6b.ebuild
+++ b/net-print/hplip/hplip-2.8.6b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.8.6b.ebuild,v 1.5 2008/08/12 15:53:28 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.8.6b.ebuild,v 1.6 2008/08/15 11:08:00 calchan Exp $
inherit eutils linux-info python
@@ -98,8 +98,13 @@ src_unpack() {
local QT_VER
use qt4 && QT_VER="4"
use qt3 && QT_VER="3"
- sed -i -e "s/--force-startup/--force-startup', '--qt${QT_VER}/" base/device.py || die "sed failed"
- sed -i -e "s/Exec=hp-systray/Exec=hp-systray --qt${QT_VER}/" hplip-systray.desktop.in || die "sed failed"
+ sed -i \
+ -e "s/%s --force-startup/%s --force-startup --qt${QT_VER}/" \
+ -e "s/'--force-startup'/'--force-startup', '--qt${QT_VER}'/" \
+ base/device.py || die "sed failed"
+ sed -i \
+ -e "s/Exec=hp-systray/Exec=hp-systray --qt${QT_VER}/" \
+ hplip-systray.desktop.in || die "sed failed"
}
src_compile() {