summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-06-17 00:15:05 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-06-17 00:15:05 +0000
commita7311e2edd1fd2786fb02f4ef8227572e79c41ff (patch)
tree44ac7fb99aaaff0c1fc34035f72e91d638875dac /net-print/hplip
parentmask sys-cluster/rgmanager for 2.4 (parent) and unmask for 2.6 (diff)
downloadgentoo-2-a7311e2edd1fd2786fb02f4ef8227572e79c41ff.tar.gz
gentoo-2-a7311e2edd1fd2786fb02f4ef8227572e79c41ff.tar.bz2
gentoo-2-a7311e2edd1fd2786fb02f4ef8227572e79c41ff.zip
cups-1.2 fixes and major ebuild cleanups
(Portage version: 2.1.1_pre1)
Diffstat (limited to 'net-print/hplip')
-rw-r--r--net-print/hplip/ChangeLog5
-rw-r--r--net-print/hplip/files/digest-hplip-1.6.66
-rw-r--r--net-print/hplip/hplip-1.6.6.ebuild74
3 files changed, 44 insertions, 41 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index 59ffd01e0da7..2c54b648c608 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.35 2006/06/16 00:44:34 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.36 2006/06/17 00:15:05 genstef Exp $
+
+ 17 Jun 2006; Stefan Schweizer <genstef@gentoo.org> hplip-1.6.6.ebuild:
+ cups-1.2 fixes and major ebuild cleanups
*hplip-1.6.6 (16 Jun 2006)
diff --git a/net-print/hplip/files/digest-hplip-1.6.6 b/net-print/hplip/files/digest-hplip-1.6.6
index 1a434ce097e8..782e3d8985d3 100644
--- a/net-print/hplip/files/digest-hplip-1.6.6
+++ b/net-print/hplip/files/digest-hplip-1.6.6
@@ -1,2 +1,6 @@
-MD5 1bf699ebd394c9822086c1fef2937836 foomatic-db-hpijs-1.5-20060211.tar.gz 97873
+MD5 5aa44a363ceea0adad2c8fa5db4aa41f foomatic-db-hpijs-20060615.tar.gz 98297
+RMD160 d73b78424259953e1c01dbc11115e93c2dd3c4b9 foomatic-db-hpijs-20060615.tar.gz 98297
+SHA256 e21455a8e2f976118e6cabef633b23fedaa367abe9c1c610008cb3343a10bc6d foomatic-db-hpijs-20060615.tar.gz 98297
MD5 292fbcc25b79d273d7280760ce797666 hplip-1.6.6.tar.gz 10429794
+RMD160 84171d39677e132915169cb4c687271325777f25 hplip-1.6.6.tar.gz 10429794
+SHA256 cb148342ef56de7426290a8556114de440ff01ed36008ab81ea64755828701d0 hplip-1.6.6.tar.gz 10429794
diff --git a/net-print/hplip/hplip-1.6.6.ebuild b/net-print/hplip/hplip-1.6.6.ebuild
index d1aa7abceca6..0f80b728aef7 100644
--- a/net-print/hplip/hplip-1.6.6.ebuild
+++ b/net-print/hplip/hplip-1.6.6.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-1.6.6.ebuild,v 1.1 2006/06/16 00:44:34 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-1.6.6.ebuild,v 1.2 2006/06/17 00:15:05 genstef Exp $
inherit eutils
-DB_V=1.5-20060211
+DB_V=20060615
DESCRIPTION="HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools."
HOMEPAGE="http://hplip.sourceforge.net/"
SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
- foomaticdb? ( mirror://gentoo/foomatic-db-hpijs-${DB_V}.tar.gz )"
+ foomaticdb? ( http://gentooexperimental.org/~genstef/dist/foomatic-db-hpijs-${DB_V}.tar.gz )"
#http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-${DB_V}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="foomaticdb snmp X qt ppds scanner cups"
+IUSE="foomaticdb snmp X qt ppds scanner"
-DEPEND="dev-lang/python
+DEPEND=">=dev-lang/python-2.2.0
snmp? ( >=net-analyzer/net-snmp-5.0.9 )
!net-print/hpijs
!net-print/hpoj"
RDEPEND="virtual/ghostscript
- >=dev-lang/python-2.2.0
scanner? (
>=media-gfx/sane-backends-1.0.9
|| (
@@ -38,29 +37,46 @@ RDEPEND="virtual/ghostscript
>=net-print/foomatic-filters-3.0.2
${DEPEND}"
+pkg_setup() {
+ # avoid collisions
+ if [ -e ${ROOT}/usr/lib/cups/backend/hp ] && [ -e ${ROOT}/usr/libexec/cups/backend/hp ]; then
+ rm ${ROOT}/usr/libexec/cups/backend/hp;
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i -e "s:(uint32_t)0xff000000) >> 24))):(uint32_t)0xff000000) >> 24):" \
- "${S}"/scan/sane/mfpdtf.h
-
# bug 98428
sed -i -e "s:/usr/bin/env python:/usr/bin/python:g" \
- "${S}"/hpssd.py
+ hpssd.py
}
src_compile() {
- myconf="${myconf} --disable-cups-install --disable-foomatic-install"
-
- use snmp || myconf="${myconf} --disable-network-build"
+ econf \
+ $(use_enable snmp network-build) \
+ $(use_enable cups cups-install) \
+ $(use_enable ppds foomatic-install) \
+ || die "econf failed"
+ emake || die "emake failed"
- econf ${myconf} || die "Error: econf failed!"
- emake || die "Error: emake failed!"
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ econf || die "econf failed"
+ rm -fR data-generators/hpijs-rss
+ emake || die "emake failed"
+ fi
}
src_install() {
- make DESTDIR="${D}" install
+ # cups-1.2 installation paths, make sure that the .desktop is installed
+ sed -i -e "s:/usr/lib/cups:$(cups-config --serverbin):" \
+ -e 's:\(ICON_FILE = \).*:\1hplip.desktop:' \
+ -e 's:\(ICON_PATH = \).*:\1/usr/share/applications:' \
+ Makefile
+
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
newinitd "${FILESDIR}"/hplip.init.d hplip
@@ -87,34 +103,14 @@ src_install() {
rm -f "${D}"/usr/bin/hp-toolbox
rm -f "${D}"/usr/share/hplip/print
rm -f "${D}"/usr/share/hplip/toolbox
- rm -f "${D}"/usr/share/hplip/data/hplip.desktop
rm -f "${D}"/usr/share/applications/hplip.desktop
+ rm -f "${D}"/usr/lib/menu/hplip
fi
- if use ppds; then
- dodir /usr/share
- mv "${S}"/prnt/hpijs/ppd/* "${D}"/usr/share/ppd
- fi
-
- if use cups && use ppds ; then
- dodir /usr/share/cups/model
- dosym /usr/share/ppd /usr/share/cups/model/foomatic-ppds
- fi
-
- [ -e /usr/bin/foomatic-rip ] && rm -f "${D}"/usr/bin/foomatic-rip
+ rm -rf ${D}/$(cups-config --serverbin)/filter ${D}/usr/bin/foomatic-rip
if use foomaticdb ; then
cd ../foomatic-db-hpijs-${DB_V}
- econf || die "econf failed"
- rm -fR data-generators/hpijs-rss
- make || die
- make DESTDIR="${D}" install || die
- fi
-
- # desktop entry, bug 122758
- if use qt; then
- dodir /usr/share/applications
- mv "${D}"/usr/share/hplip/data/hplip.desktop \
- "${D}"/usr/share/applications
+ emake DESTDIR="${D}" install || die "emake install failed"
fi
}