summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-11-19 16:39:17 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-11-19 16:39:17 +0000
commit9e1945e317f099ab267950e9458512e254c1b07b (patch)
tree35f79f507d10a3b19fe9957ca88ab455277cae5d /net-print/hplip
parentalpha stable wrt #155220 (diff)
downloadgentoo-2-9e1945e317f099ab267950e9458512e254c1b07b.tar.gz
gentoo-2-9e1945e317f099ab267950e9458512e254c1b07b.tar.bz2
gentoo-2-9e1945e317f099ab267950e9458512e254c1b07b.zip
Version bump, bug #196795. Replaced udev rules, bug #197726.
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-print/hplip')
-rw-r--r--net-print/hplip/ChangeLog8
-rw-r--r--net-print/hplip/files/70-hpmud.rules19
-rw-r--r--net-print/hplip/files/digest-hplip-2.7.103
-rw-r--r--net-print/hplip/hplip-2.7.10.ebuild130
4 files changed, 159 insertions, 1 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index 8ad5baacc016..c2db3bb19591 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.86 2007/11/18 16:05:18 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.87 2007/11/19 16:39:16 calchan Exp $
+
+*hplip-2.7.10 (19 Nov 2007)
+
+ 19 Nov 2007; Denis Dupeyron <calchan@gentoo.org> +files/70-hpmud.rules,
+ +hplip-2.7.10.ebuild:
+ Version bump, bug #196795. Replaced udev rules, bug #197726.
18 Nov 2007; Denis Dupeyron <calchan@gentoo.org> hplip-2.7.9-r1.ebuild:
Fixed bug #193671 again.
diff --git a/net-print/hplip/files/70-hpmud.rules b/net-print/hplip/files/70-hpmud.rules
new file mode 100644
index 000000000000..1e6ab666d239
--- /dev/null
+++ b/net-print/hplip/files/70-hpmud.rules
@@ -0,0 +1,19 @@
+# Udev rules file for HP printer products.
+
+ACTION!="add", GOTO="hpmud_rules_end"
+
+SUBSYSTEM!="usb|usb_device", GOTO="hpmud_rules_end"
+SUBSYSTEM=="usb", ENV{DEVTYPE}!="usb_device" ,GOTO="hpmud_rules_end"
+
+# Check for AiO products (0x03f0xx11).
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??11", GROUP="lp"
+# Check for Photosmart products (0x03f0xx02).
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??02", GROUP="lp"
+# Check for Business Inkjet products (0x03f0xx12).
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??12", GROUP="lp"
+# Check for Deskjet products (0x03f0xx04).
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??04", GROUP="lp"
+# Check for LaserJet products (0x03f0xx17).
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??17", GROUP="lp"
+
+LABEL="hpmud_rules_end"
diff --git a/net-print/hplip/files/digest-hplip-2.7.10 b/net-print/hplip/files/digest-hplip-2.7.10
new file mode 100644
index 000000000000..8d5c01699dde
--- /dev/null
+++ b/net-print/hplip/files/digest-hplip-2.7.10
@@ -0,0 +1,3 @@
+MD5 eafb815ca4b4bb5a2f35a76ee3c2dc72 hplip-2.7.10.tar.gz 14441901
+RMD160 1bbfd405eb3d75fa38c0f2fc485438ee064ccce9 hplip-2.7.10.tar.gz 14441901
+SHA256 e289d5f6190caf4596f6770037569638d96915583339933d6c202f35fc02d8c3 hplip-2.7.10.tar.gz 14441901
diff --git a/net-print/hplip/hplip-2.7.10.ebuild b/net-print/hplip/hplip-2.7.10.ebuild
new file mode 100644
index 000000000000..3cba4c5c69f3
--- /dev/null
+++ b/net-print/hplip/hplip-2.7.10.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.7.10.ebuild,v 1.1 2007/11/19 16:39:16 calchan Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools."
+HOMEPAGE="http://hplip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="X doc fax minimal parport ppds scanner snmp"
+
+DEPEND="!net-print/hpijs
+ !net-print/hpoj
+ virtual/ghostscript
+ >=media-libs/jpeg-6b
+ net-print/foomatic-filters
+ !minimal? (
+ >=net-print/cups-1.2
+ dev-libs/libusb
+ scanner? ( >=media-gfx/sane-backends-1.0.9 )
+ snmp? (
+ net-analyzer/net-snmp
+ dev-libs/openssl
+ )
+ )"
+
+RDEPEND="${DEPEND}
+ !minimal? (
+ !<sys-fs/udev-114
+ fax? ( dev-python/reportlab )
+ scanner? (
+ dev-python/imaging
+ X? ( >=media-gfx/xsane-0.89 )
+ !X? ( >=media-gfx/sane-frontends-1.0.9 )
+ )
+ X? ( >=dev-python/PyQt-3.14 )
+ )"
+
+CONFIG_CHECK="PARPORT"
+ERROR_PARPORT="Please make sure Device Drivers -> Parallel port support is enabled in your kernel"
+
+pkg_setup() {
+ if ! use ppds ; then
+ ewarn "Not installing built-in PPD files, which is probably not what you want."
+ ewarn "You need USE=ppds if you want to install them."
+ fi
+ if use minimal ; then
+ ewarn "Installing hpijs driver only, make sure you know what you are doing."
+ else
+ use parport && linux-info_pkg_setup
+ fi
+
+ # avoid collisions with cups-1.2 compat symlinks
+ if [ -e "${ROOT}"/usr/lib/cups/backend/hp ] && [ -e "${ROOT}"/usr/libexec/cups/backend/hp ]; then
+ rm -f "${ROOT}"/usr/libexec/cups/backend/hp{,fax};
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:\$(doc_DATA)::" Makefile.in || die "Patching Makefile.in failed"
+ sed -i -e "s/'skipstone']/'skipstone', 'epiphany']/" \
+ -e "s/'skipstone': ''}/'skipstone': '', 'epiphany': '--new-window'}/" \
+ base/utils.py || die "Patching base/utils.py failed"
+
+ # bug 98428
+ sed -i -e "s:/usr/bin/env python:/usr/bin/python:g" hpssd.py || die "Patching hpssd.py failed"
+
+ # Force recognition of Gentoo distro by hp-check
+ sed -i \
+ -e "s:file('/etc/issue', 'r').read():'Gentoo':" \
+ installer/core_install.py || die "sed core_install.py"
+
+ # Replace udev rules, see bug #197726.
+ rm data/rules/55-hpmud.rules
+ cp "${FILESDIR}"/70-hpmud.rules data/rules
+ sed -i -e "s/55-hpmud.rules/70-hpmud.rules/g" Makefile.* */*.html */*/*.html
+}
+
+src_compile() {
+ econf \
+ --disable-cups11-build \
+ --with-cupsbackenddir=$(cups-config --serverbin)/backend \
+ $(use_enable minimal hpijs-only-build) \
+ $(use_enable doc doc-build) \
+ $(use_enable snmp network-build) \
+ $(use_enable parport pp-build) \
+ $(use_enable scanner scan-build) \
+ $(use_enable X gui-build) \
+ $(use_enable fax fax-build) \
+ $(use_enable ppds foomatic-ppd-install) \
+ --disable-foomatic-xml-install \
+ || die "econf failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ # bug 106035
+ use X || rm -Rf "${D}"/usr/share/applications
+
+ use minimal && rm -rf "${D}"/usr/lib
+}
+
+pkg_preinst() {
+ if ! use minimal && use scanner ; then
+ insinto /etc/sane.d
+ [ -e /etc/sane.d/dll.conf ] && cp /etc/sane.d/dll.conf .
+ [ -e "${ROOT}"/etc/sane.d/dll.conf ] && cp "${ROOT}"/etc/sane.d/dll.conf .
+ grep -q hpaio dll.conf || echo hpaio >> "${T}"/dll.conf
+ doins "${T}"/dll.conf
+ fi
+}
+
+pkg_postinst() {
+ elog "You should run hp-setup as root if you are installing hplip for the first time, and may also"
+ elog "need to run it if you are upgrading from an earlier version."
+ elog
+ elog "If your device is connected using USB, users will need to be in the lp group to access it."
+ elog
+ elog "This release doesn't use an init script anymore, so you should probably do a"
+ elog "'rc-update del hplip' if you are updating from an old version."
+}