summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-07-21 12:08:59 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-07-21 12:08:59 +0000
commit228153fdd8f8d2eb60dc244ac03e07a646e96587 (patch)
tree16fef87c4719dce117084fef8f842c5ece9ff744 /net-print/hplip
parentMasked =net-print/hplip-2.7.6 for testing. (diff)
downloadgentoo-2-228153fdd8f8d2eb60dc244ac03e07a646e96587.tar.gz
gentoo-2-228153fdd8f8d2eb60dc244ac03e07a646e96587.tar.bz2
gentoo-2-228153fdd8f8d2eb60dc244ac03e07a646e96587.zip
Major version bump.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'net-print/hplip')
-rw-r--r--net-print/hplip/ChangeLog7
-rw-r--r--net-print/hplip/files/digest-hplip-2.7.66
-rw-r--r--net-print/hplip/hplip-2.7.6.ebuild103
3 files changed, 115 insertions, 1 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index 81d05306be11..ca9b67d4d09b 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.67 2007/06/16 15:21:45 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.68 2007/07/21 12:08:59 calchan Exp $
+
+*hplip-2.7.6 (21 Jul 2007)
+
+ 21 Jul 2007; Denis Dupeyron <calchan@gentoo.org> +hplip-2.7.6.ebuild:
+ Major version bump.
16 Jun 2007; Denis Dupeyron <calchan@gentoo.org> -hplip-1.7.3.ebuild,
-hplip-1.7.4.ebuild, -hplip-1.7.4a.ebuild:
diff --git a/net-print/hplip/files/digest-hplip-2.7.6 b/net-print/hplip/files/digest-hplip-2.7.6
new file mode 100644
index 000000000000..a8df550a25c1
--- /dev/null
+++ b/net-print/hplip/files/digest-hplip-2.7.6
@@ -0,0 +1,6 @@
+MD5 b623b7d06e033e1a8e8db6852b72887b hplip-2.7.6-1.patch 641
+RMD160 8fb3653de10a49188fe067bb5b6b8b1e749b5759 hplip-2.7.6-1.patch 641
+SHA256 9d7d2c0bfbab48e87a7fc88c82c3a210ead2c39da54e1a6c05e8bef8ac56ca24 hplip-2.7.6-1.patch 641
+MD5 7493f4d53ec98123d69c9b36318cc1f5 hplip-2.7.6.tar.gz 14025487
+RMD160 3cf9b11907cd2678880b8ddfc184ba2f20227976 hplip-2.7.6.tar.gz 14025487
+SHA256 d4ec63934b13ea36b1bd10aa785ff58affcc454721f526ab059b0f399ac56ac5 hplip-2.7.6.tar.gz 14025487
diff --git a/net-print/hplip/hplip-2.7.6.ebuild b/net-print/hplip/hplip-2.7.6.ebuild
new file mode 100644
index 000000000000..059d49c11fb0
--- /dev/null
+++ b/net-print/hplip/hplip-2.7.6.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.7.6.ebuild,v 1.1 2007/07/21 12:08:59 calchan Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools."
+HOMEPAGE="http://hplip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
+ mirror://sourceforge/hplip/${P}-1.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="X doc fax minimal parport ppds scanner snmp"
+
+DEPEND="!net-print/hpijs
+ !net-print/hpoj
+ dev-libs/openssl
+ virtual/ghostscript
+ >=media-libs/jpeg-6b
+ >=net-print/cups-1.2
+ dev-libs/libusb
+ >=dev-lang/python-2.2
+ net-print/foomatic-filters
+ fax? ( >=dev-lang/python-2.3 )
+ snmp? ( net-analyzer/net-snmp )"
+
+RDEPEND="${DEPEND}
+ fax? ( dev-python/reportlab )
+ X? ( >=dev-python/PyQt-3.14 )
+ scanner? (
+ X? ( >=media-gfx/xsane-0.89 )
+ !X? ( >=media-gfx/sane-frontends-1.0.9 )
+ )"
+
+CONFIG_CHECK="PARPORT"
+ERROR_PARPORT="Please make sure Device Drivers -> Parallel port support is enabled in your kernel"
+
+pkg_setup() {
+ use parport && linux-info_pkg_setup
+
+ # avoid collisions with cups-1.2 compat symlinks
+ if [ -e ${ROOT}/usr/lib/cups/backend/hp ] && [ -e ${ROOT}/usr/libexec/cups/backend/hp ]; then
+ rm -f ${ROOT}/usr/libexec/cups/backend/hp{,fax};
+ fi
+
+ use ppds || ewarn "Not installing built-in PPD files. You need USE=ppds if you want to install them."
+ use minimal && ewarn "Installing hpijs driver only, make sure you know what you are doing."
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${DISTDIR}/${P}-1.patch"
+
+ sed -i -e "s:toolbox:toolbox.py:" hplip.desktop.in || die "Patching hplip.desktop.in failed"
+ sed -i -e "s:\$(doc_DATA)::" Makefile.in || die "Patching Makefile.in failed"
+ sed -i -e "s/'skipstone']/'skipstone', 'epiphany']/" \
+ -e "s/'skipstone': ''}/'skipstone': '', 'epiphany': '--new-window'}/" \
+ base/utils.py || die "Patching base/utils.py failed"
+
+ # bug 98428
+ sed -i -e "s:/usr/bin/env python:/usr/bin/python:g" hpssd.py || die "Patching hpssd.py failed"
+}
+
+src_compile() {
+ econf --disable-dependency-tracking \
+ --disable-cups11-build \
+ --with-cupsbackenddir=$(cups-config --serverbin)/backend \
+ $(use_enable minimal hpijs-only-build) \
+ $(use_enable doc doc-build) \
+ $(use_enable snmp network-build) \
+ $(use_enable parport pp-build) \
+ $(use_enable scanner scan-build) \
+ $(use_enable X gui-build) \
+ $(use_enable fax fax-build) \
+ $(use_enable ppds foomatic-ppd-install) \
+ --disable-foomatic-xml-install \
+ || die "econf failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ # bug 106035
+ use X || rm -Rf "${D}"/usr/share/applications
+}
+
+pkg_preinst() {
+ if use scanner; then
+ insinto /etc/sane.d
+ [ -e /etc/sane.d/dll.conf ] && cp /etc/sane.d/dll.conf .
+ [ -e ${ROOT}/etc/sane.d/dll.conf ] && cp ${ROOT}/etc/sane.d/dll.conf .
+ grep -q hpaio dll.conf || echo hpaio >> dll.conf
+ doins dll.conf
+ fi
+}
+
+pkg_postinst() {
+ elog "If your device is connected using USB, users will need to be in the lp group to access it."
+}