summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-17 20:43:19 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-17 20:43:19 +0000
commit6384573dc829abb2101262161d6802c2d6343b05 (patch)
tree0dedd6aeaf5d5be110b8959d40a4dba35f680f4f /net-print/foomatic-db-ppds
parentVersion bump, #307067 (diff)
downloadgentoo-2-6384573dc829abb2101262161d6802c2d6343b05.tar.gz
gentoo-2-6384573dc829abb2101262161d6802c2d6343b05.tar.bz2
gentoo-2-6384573dc829abb2101262161d6802c2d6343b05.zip
Version bump, #307067
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-print/foomatic-db-ppds')
-rw-r--r--net-print/foomatic-db-ppds/ChangeLog8
-rw-r--r--net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20100218.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/net-print/foomatic-db-ppds/ChangeLog b/net-print/foomatic-db-ppds/ChangeLog
index fd9eaa150a9c..3019d383b0d1 100644
--- a/net-print/foomatic-db-ppds/ChangeLog
+++ b/net-print/foomatic-db-ppds/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/foomatic-db-ppds
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-ppds/ChangeLog,v 1.17 2010/02/07 17:39:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-ppds/ChangeLog,v 1.18 2010/05/17 20:43:19 jlec Exp $
+
+*foomatic-db-ppds-4.0.20100218 (17 May 2010)
+
+ 17 May 2010; Justin Lecher <jlec@gentoo.org>
+ +foomatic-db-ppds-4.0.20100218.ebuild:
+ Version bump, #307067
*foomatic-db-ppds-4.0.20100205 (07 Feb 2010)
diff --git a/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20100218.ebuild b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20100218.ebuild
new file mode 100644
index 000000000000..e31af9e9a41f
--- /dev/null
+++ b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20100218.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20100218.ebuild,v 1.1 2010/05/17 20:43:19 jlec Exp $
+
+inherit eutils versionator
+
+MY_P=${PN/-ppds}-$(replace_version_separator 2 '-')
+DESCRIPTION="linuxprinting.org PPD files for postscript printers"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+SRC_URI="http://gentooexperimental.org/~genstef/dist/${MY_P}.tar.gz
+ http://linuxprinting.org/download/foomatic/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${PN/-ppds}-$(get_version_component_range 3 ${PV})"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/Makefile.in-20070508.patch"
+ # scripts do not belong to this package, no translated ppds, no html and text files
+ rm -r "${S}"/db/source/PPD/Kyocera/{de,es,fr,it,pt,*.htm,*.txt}
+}
+
+src_compile() {
+ econf || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}