summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-12 08:34:09 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-12 08:34:09 +0000
commitfce1fcef350497414dce26279a2e23bbf84d32ec (patch)
tree020b78e7265dd34115db459df5d8c13d06b705b0 /net-p2p
parentVersion bump. (diff)
downloadgentoo-2-fce1fcef350497414dce26279a2e23bbf84d32ec.tar.gz
gentoo-2-fce1fcef350497414dce26279a2e23bbf84d32ec.tar.bz2
gentoo-2-fce1fcef350497414dce26279a2e23bbf84d32ec.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gtk-gnutella/ChangeLog10
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-0.98.ebuild70
2 files changed, 79 insertions, 1 deletions
diff --git a/net-p2p/gtk-gnutella/ChangeLog b/net-p2p/gtk-gnutella/ChangeLog
index aedc682b741e..bbe5815560eb 100644
--- a/net-p2p/gtk-gnutella/ChangeLog
+++ b/net-p2p/gtk-gnutella/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/gtk-gnutella
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.123 2011/12/12 08:19:17 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.124 2011/12/12 08:34:09 graaff Exp $
+
+ 12 Dec 2011; Hans de Graaff <graaff@gentoo.org> +gtk-gnutella-0.98.ebuild:
+ Version bump.
+
+*gtk-gnutella-0.98 (12 Dec 2011)
+
+ 12 Dec 2011; Hans de Graaff <graaff@gentoo.org> +gtk-gnutella-0.98.ebuild:
+ Version bump.
12 Dec 2011; Hans de Graaff <graaff@gentoo.org> -gtk-gnutella-0.97.ebuild:
Remove old version.
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-0.98.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-0.98.ebuild
new file mode 100644
index 000000000000..05ada9bfb751
--- /dev/null
+++ b/net-p2p/gtk-gnutella/gtk-gnutella-0.98.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/gtk-gnutella-0.98.ebuild,v 1.1 2011/12/12 08:34:09 graaff Exp $
+
+EAPI="2"
+
+inherit eutils
+
+IUSE="nls dbus ssl +gtk"
+
+DESCRIPTION="A GTK+ Gnutella client"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ gtk? ( >=x11-libs/gtk+-2.2.1:2 )
+ dbus? ( >=sys-apps/dbus-0.35.2 )
+ ssl? ( >=net-libs/gnutls-2.2.5 )
+ nls? ( >=sys-devel/gettext-0.11.5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ # There is no option to turn off optimization through the build.sh
+ # script.
+ sed -i -e "s/Configure -Oder/Configure -Oder -Doptimize=none/" build.sh || die
+
+ # The build script does not support the equivalent --enable
+ # options so we must construct the configuration by hand.
+
+ local myconf
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if ! use dbus; then
+ myconf="${myconf} --disable-dbus"
+ fi
+
+ if ! use ssl; then
+ myconf="${myconf} --disable-gnutls"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --gtk2"
+ else
+ myconf="${myconf} --topless"
+ fi
+
+ ./build.sh \
+ --configure-only \
+ --prefix="/usr" \
+ --cc=$(tc-getCC) \
+ ${myconf}
+}
+
+src_install() {
+ dodir /usr/bin
+ emake INSTALL_PREFIX="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ # Touch the symbols file into the future to avoid warnings from
+ # gtk-gnutella later on, since we will most likely strip the binary.
+ touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
+}