summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-12-18 15:29:56 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-12-18 15:29:56 +0000
commitf4ed2c8bc31aa6991829503d5ebb9ba484717947 (patch)
treecbc6a76be18b42a3c835f426506cccebe6e2b62e /net-p2p
parentold (diff)
downloadgentoo-2-f4ed2c8bc31aa6991829503d5ebb9ba484717947.tar.gz
gentoo-2-f4ed2c8bc31aa6991829503d5ebb9ba484717947.tar.bz2
gentoo-2-f4ed2c8bc31aa6991829503d5ebb9ba484717947.zip
Version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog10
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.0.1.ebuild46
2 files changed, 55 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 418f3e78ee70..f8adf9623a86 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.64 2009/12/18 01:04:30 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.65 2009/12/18 15:29:56 armin76 Exp $
+
+ 18 Dec 2009; Raúl Porcel <armin76@gentoo.org> +qbittorrent-2.0.1.ebuild:
+ Version bump
+
+*qbittorrent-2.0.1 (18 Dec 2009)
+
+ 18 Dec 2009; Raúl Porcel <armin76@gentoo.org> +qbittorrent-2.0.1.ebuild:
+ Version bump
18 Dec 2009; Ben de Groot <yngwin@gentoo.org> -qbittorrent-1.0.0.ebuild,
-qbittorrent-1.3.3-r1.ebuild, -qbittorrent-1.4.0.ebuild:
diff --git a/net-p2p/qbittorrent/qbittorrent-2.0.1.ebuild b/net-p2p/qbittorrent/qbittorrent-2.0.1.ebuild
new file mode 100644
index 000000000000..2dc56005fa39
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.0.1.ebuild,v 1.1 2009/12/18 15:29:56 armin76 Exp $
+
+EAPI="2"
+inherit eutils qt4 multilib
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# boost version so that we always have thread support
+DEPEND=" x11-libs/qt-gui:4
+ >=net-libs/rb_libtorrent-0.14.7
+ >=dev-libs/boost-1.34.1
+ dev-libs/zziplib
+ net-misc/curl
+ dev-cpp/commoncpp2"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.3
+ geoip? ( dev-libs/geoip )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4_src_prepare
+}
+
+src_configure() {
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr || die "configure failed"
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS Changelog NEWS README TODO
+}